No announcement yet.

Quake Audio Issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • Quake Audio Issues

    Hi, a few days ago I decided to try out Slackware once again, so I installed it, updated it to -current, and then upgraded to the latest kernel. I decided to use the newest version of alsa, so i didn't compile support for it in my kernel, but that is resulting in some audio anomolies.

    If I launch quake3, I get no sound at all. If i launch quake4, the sound is very low quality, like on an older cell phone, or equivalent to motherboard beeps (I suppose this would also happen for doom3). But, I'm fully able to play my .mp3's in amarok and noatune and a whole slew of winamp wanna-be apps. But I know that my audio is working, to some extent.

    Optimally I'd like to get my 5.1 surround sound working, without mirroring the front two channels in quake 4, if its possible. But I'd settle with the audio just working correctly.

    I'd also like to get the audio working properly in quake3, I was able to get it working in ioquake3 (from icculus) since it uses openal, but if I were to use that, then I would be unable to play it online, especially in the punkbuster servers.


    update: I was just able to get quake4 to sound correctly by running it with the following command: "aoss quake4 set s_driver oss" wierdly enough, I need both the "aoss" and the "set s_driver oss" for my audio to not sound like utter crap. This seems like a good temporary solution, but if I can, i'd like to fix it and use alsa because of the small chance of my 5.1 surround sound working.

    Thanks again!

  • #2
    Have you tried alsoconf to make sure all the proper channels are not muted?


    • #3
      I had some problems getting sound working properly in Doom3 & Quake4. I had to increase the buffer size in .asoundrc.

      Also, check out the Doom3 and Quake4 Linux pages:
      Doom 3
      Quake 4


      • #4
        Quake 3 uses OSS for sound, so you'll need OSS-compatibility compiled into your kernel or as modules. As an alternative, you can try ioquake3 as an alternative. I uses OpenAL, which can either uses ALSA or OSS as the backend (preferably ALSA).

        As far as Q4 is concerned, it seems that everyone has that problem. Either change the backend to OSS, or increase your ALSA buffer size as someone mentioned above.


        • #5
          ok, I followed your instructions, no my volume isn't muted, and I didn't install or use alsaconf, but after doing 'quake4 +set s_numberOfSpeakers 6' I've got full surround sound working in quake4 and that will probably work for doom3 aswell, now... to get regular quake3 working...

          Yes, I tried ioquake3, and it works fine with alsa, but I'd prefer to get regular/official quake3 working, so I can play on real servers with punkbuster.

          Thanks for the help


          • #6
            Scott, try using the alsa-oss (aoss) emulation wrapper and see if that helps you.

            I had problems like that before... but I ended up switching to OSS (as idSoft has suggested).


            • #7
              I found out that the root of all my sound issues is because onboard audio sucks. It lacks hardware mixing support, so I traded sound cards with a friend, gave him an Audigy LS for an old SB Live 5.1! (yea I know it looks like a bad deal on my part, but the Audigy LS has no mic support and I don't know if it has hardware mixing support in linux) After installing that new sound card and recompiling the alsa drivers with support for the emu10k1 chip, my sound has been flawless without doing any extra crap. I guess I've learned my lesson about using onboard sound