Announcement

Collapse
No announcement yet.

RadeonSI Gallium3D Can Work With XCOM 2 On Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RadeonSI Gallium3D Can Work With XCOM 2 On Linux

    Phoronix: RadeonSI Gallium3D Can Work With XCOM 2 On Linux

    While at first using open-source drivers to play XCOM 2 on Linux looked bleak, after some more trials, the latest Mesa Gallium3D code can work for Intel and Radeon...

    http://www.phoronix.com/scan.php?pag...onSI-G3D-XCOM2

  • #2
    Now everybody can chill out a bit.

    Comment


    • #3
      Great news! I know this might be a bit much to ask but are you still planning to try with catalyst?

      Comment


      • #4
        So they developed the game using AMD/ATI chips, but announce it as "recommended with nVidia"...

        Comment


        • #5
          Originally posted by rastersoft View Post
          So they developed the game using AMD/ATI chips, but announce it as "recommended with nVidia"...
          Yes, that's right. More accurately the game is developed against future versions of AMD/ATI drivers. The drivers in the wild don't work with the game so they can't support them.

          Comment


          • #6
            Originally posted by Petteri View Post

            Yes, that's right. More accurately the game is developed against future versions of AMD/ATI drivers. The drivers in the wild don't work with the game so they can't support them.
            When it comes to Amd, it's always about future.

            Comment


            • #7
              Originally posted by bulletxt View Post

              When it comes to Amd, it's always about future.
              The article says it'll probably work on current mesa (11.1.1)

              Comment


              • #8
                Originally posted by chris200x9 View Post
                Great news! I know this might be a bit much to ask but are you still planning to try with catalyst?
                If he doesn't I will install Ubuntu over my Fedora install and gave it a go.
                All opinions are my own not those of my employer if you know who they are.

                Comment


                • #9
                  Originally posted by Petteri View Post
                  Yes, that's right. More accurately the game is developed against future versions of AMD/ATI drivers. The drivers in the wild don't work with the game so they can't support them.
                  Just curious, what is your comment based on ? I wasn't able to find anything in Michael's article that suggested "future drivers" or that the game was developed on AMD hardware (although that would be nice).

                  Thanks,
                  John
                  Last edited by bridgman; 04 February 2016, 08:57 PM.
                  Test signature

                  Comment


                  • #10
                    Well, I get the impression they at least tested very recent mesa versions during the port. And it seems logical that those drivers will make it into stable distributions sometime in the future.

                    Comment

                    Working...
                    X