Announcement

Collapse
No announcement yet.

BioShock Infinite Now Available For Linux, Demands Binary Graphics Drivers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #71
    @Kano:

    not playing it via HDMI, maybe there's a difference in playing sound through speakers & headphones compared to HDMI ?

    anyway: I had to raise buffers in the past for the intel HDA cards otherwise it would lead to sound stuttering and more glitches

    using an external audio card was easier (it didn't cost that much 10-15 €) - pop it in, set that card in alsa and sound in the game worked reliably


    Originally posted by haagch View Post
    Random suggestion:
    Try the game with the environment variable PULSE_LATENCY_MSEC=60
    Helps with broken sound in wine (without pulse patches) on certain sound cards. Maybe it's worth a shot?
    unfortunately there's no sound at all with Metro Last Light - it doesn't know about pulseaudio ?


    running steam (and thus Metro) works with e.g.:

    Code:
    SDL_AUDIODRIVER=alsa AUDIODEV="front:CARD=Device,DEV=0"


    To get on topic again:

    BioShock Infinite still had no crashes

    it only, on occassion, has some slowness in rendering - when things get really hectic and if I remember correctly that was also the case under Windows - when running it with too high quality settings

    so there's obviously an overhead compared to windows but it's not too bad

    Comment


    • #72
      Originally posted by phoronix View Post
      Phoronix: BioShock Infinite Now Available For Linux, Demands Binary Graphics Drivers
      Is there any Steam-free option to buy and play this game on Linux? I'd love to play this game on my Linux system but I don't want Steam installed.

      Comment


      • #73
        Originally posted by kernelOfTruth View Post
        unfortunately there's no sound at all with Metro Last Light - it doesn't know about pulseaudio ?
        It shouldn't need to know. Pulseaudio has an alsa plugin. On archlinux there is a package pulseaudio-alsa that only contains this config file:
        Code:
        $ cat /etc/asound.conf
        # Use PulseAudio by default
        pcm.!default {
          type pulse
          fallback "sysdefault"
          hint {
            show on
            description "Default ALSA Output (currently PulseAudio Sound Server)"
          }
        }
        
        ctl.!default {
          type pulse
          fallback "sysdefault"
        }
        And metro last light worked fine for me with it with pulseaudio without any special setup...

        But there can always be a bug...

        Comment

        Working...
        X