Announcement

Collapse
No announcement yet.

Borderlands 2 Launches On Steam For Linux

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • darkbasic
    replied
    Originally posted by sarmad View Post
    Has anyone encountered temporary freezes in the game when using ATI open source driver?
    Very small ones and not so common, but in other games I remember they were more annoying.

    Leave a comment:


  • sarmad
    replied
    Has anyone encountered temporary freezes in the game when using ATI open source driver? I tried it on Radeon HD 6750m and from time to time it freezes for few seconds and then continues. On Intel HD 3000 no such freezes happen (but the performance is slower obviously)
    I have seen similar freezes in Painkiller: Hell and Damnation so it looks like a driver issue. Also, the videos in the game are sluggish on ATI while they work fine on Intel. Using the ATI card was done using DRI_PRIME by the way.
    Anyone had similar issues?

    Leave a comment:


  • tomtomme
    replied
    Originally posted by darkbasic View Post
    I finally tried it: with radeonsi and my HD 7950 it runs very smooth at 60 fps with the highest quality settings possible (including FXAA) at 2560x1600.
    similar here:
    RadeonSI HD 7950, core2Quad@3ghz on openSUSE factory (mesa 10.3, llvm 3.5, kernel 3.16)

    played until second level. all maxed out (fullHD, also vsync enabled) HUD showed fps between 40 and 80. Lowest fps with 20 was on the beginning of second level when you look down in the big valley. but its really rarely dropping below 40.

    nice work for a just released port. witcher2 is still not near to that for my hardware.

    Leave a comment:


  • darkbasic
    replied
    I finally tried it: with radeonsi and my HD 7950 it runs very smooth at 60 fps with the highest quality settings possible (including FXAA) at 2560x1600.

    Leave a comment:


  • tomtomme
    replied
    Originally posted by Dukenukemx View Post
    I goofed. I bought it on my Windows machine when I heard it was on Linux.
    if you PLAY it mostly on linux from now on the money should still go to aspyr / linux-guys

    Leave a comment:


  • Dukenukemx
    replied
    Originally posted by kaprikawn View Post
    Just tried it on R600 on a 6870. Seems to be working fine. Performance is a little iffy, but certainly playable. I'm getting a fair bit of micro-stutter. Well I think it's micro-stutter, it's not something I've come across before, I normally game on Windows with a fairly high-end card, so I normally can play 1080p/60fps without much trouble. But I'm noticing some stutter in places (not in full on combat though thankfully, mainly in the exposition bits).
    I'm experiencing pauses in game or micro-stutter. It's gotten better with an update to Borderlands 2 and my gallium drivers. Not sure what improved it but it did get better. Not completely gone though.

    Leave a comment:


  • stiiixy
    replied
    Originally posted by kaprikawn View Post
    Due to the advice of the guy who made the youtube video posted earlier in the comments, I've been able to get it running with the GALLIUM_HUD="fps" option enabled. What I deemed to be micro-stutter I now think is just a plain bad framerate. I'm getting ~25fps. Though, again, I stress I think this is playable, though obviously not anywhere near what you'd get on Windows. I tried dropping some settings down to medium mainly, but it didn't seem to help. I'll play more tomorrow.
    I found the old-skool turn off and on again method to help here. Reducing settings can just create confusion. This way you can simply see the end result of your testing efforts quickly and single out the one (or seven) naughty features. It's a big bonus to your time that the game does this on the fly without a restart.

    Leave a comment:


  • kaprikawn
    replied
    Due to the advice of the guy who made the youtube video posted earlier in the comments, I've been able to get it running with the GALLIUM_HUD="fps" option enabled. What I deemed to be micro-stutter I now think is just a plain bad framerate. I'm getting ~25fps. Though, again, I stress I think this is playable, though obviously not anywhere near what you'd get on Windows. I tried dropping some settings down to medium mainly, but it didn't seem to help. I'll play more tomorrow.

    Leave a comment:


  • kaprikawn
    replied
    Originally posted by bibaheu View Post
    Has anyone tried it with the Gallium3D Radeon driver? I'll wait to buy it, I don't want to use Catalyst

    The game will be at 5? for the next 40 hours.
    Just tried it on R600 on a 6870. Seems to be working fine. Performance is a little iffy, but certainly playable. I'm getting a fair bit of micro-stutter. Well I think it's micro-stutter, it's not something I've come across before, I normally game on Windows with a fairly high-end card, so I normally can play 1080p/60fps without much trouble. But I'm noticing some stutter in places (not in full on combat though thankfully, mainly in the exposition bits).

    All in all, I'm impressed. Everything seemed to default to the lowest setting, so definitely go into settings before you launch a game, or you'll be playing at a fairly low resolution.

    For reference, this is on a fully updated Arch install, with all the crappy old libraries that Steam ships with deleted so I don't get that 'no GLX rendering' error. CPU is i5 750, and it's with 8gb RAM game running from an SSD (though that didn't stop a bit of texture pop-in which plagues many Unreal 3 titles).

    I might try sticking a 7970 in to see if brute force can improve performance. The 6870 is always the most mature card on the OSS drivers which is why I've stuck with it, but the 7970 (which I've got lying around) is a much better card, now might be the time to try it out.

    Leave a comment:


  • Pontostroy
    replied
    Originally posted by dcc24 View Post
    This happens to me as well and it is extremely annoying. I've tested on Windows and OS X as well, neither has this problem. Outside areas are especially worse. I have an HD5850M (iMac) with latest r600g in Arch.

    Any ideas?
    Open the file ~/.local/share/aspyr-media/borderlands 2/willowgame/config/willowengine.ini Under [SystemSettings], look for the following line: DynamicLights=False
    Change ?False? to ?True"

    Leave a comment:

Working...
X