Announcement

Collapse
No announcement yet.

Steam Linux Beta Opens Up To More Gamers

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Steam Linux Beta Opens Up To More Gamers

    Steam Linux Beta Opens Up To More Gamers

    Phoronix: Steam Linux Beta Opens Up To More Gamers

    Prior to going on their Thanksgiving holiday, Valve's Linux cabal opened up the Steam Linux Beta program to an additional five-thousand applicants...

    http://www.phoronix.com/vr.php?view=MTIzNDA

  • foxfire
    replied
    I have Steam and TF2 working on openSUSE 12.2 64bit, KDE 4.9 and Catalyst 12.10. I had to fix the symlinks for /usr/lib/libGL* and install some 32bit libraries. libnsssharedhelper0-32bit, libpng12-0-32bit, libpng14-14-32bit, libasound2-32bit, libpulse0-32bit and maybe a few others. In order to get the sound working in TF2 I have to launch Steam with:

    Code:
    export SDL_AUDIODRIVER=alsa; /usr/bin/steam %U steam://store
    I'm not in the beta and I haven't had any trouble playing TF2. I have to turn off compositing in KDE to get it to run smoothly. I did not try to use the mic yet.

    Leave a comment:


  • liamdawe
    replied
    The latest roundup for you guys:
    Steam For Linux Roundup

    Leave a comment:


  • liamdawe
    replied
    FTL and Puddle will be on Steam:
    http://www.gamingonlinux.com/index.p...on-linux.1482/

    Leave a comment:


  • b15hop
    replied
    I'm not one of these applicants either. Doesn't matter though because I use arch linux x64 and not going to care for steam if it's only for 32bit.... I don't really have the time to stuff around with steam beta at the moment anyway. LoL ...

    Anyone who IS using the steam beta, be sure to post some info up here. I think that would make us all warm and fuzzy inside!

    Leave a comment:


  • Larian
    replied
    Originally posted by mike4 View Post
    The icon properites say:
    /usr/bin/steam %U

    maybe try in a term and post details?
    That'll only work if you're in the beta. But running "~/Steam/steam.sh steam://open/friends" gets the client up if you're not. (And I would SWEAR I tried this before as I distinctly remember it dying in the terminal with no output, but...)

    The problem is with, of all things, my X-Box 360 controller (wireless w/ dongle). Opening TF2 launch options and setting the -nojoy flag circumvents the issue. Now there is an amusing bug. Yay, beta!

    Leave a comment:


  • entropy
    replied
    Originally posted by mike4 View Post
    The icon properites say:
    /usr/bin/steam %U

    maybe try in a term and post details?

    Doom3 BFG got opensourced. Would I be able to play, once the Linux version will
    be hacked, with a windoze buy from within steam on Linux?
    Thanks
    Why shouldn't you?
    I guess the assets are not encrypted and you'll start another binary, ofc.

    Leave a comment:


  • mike4
    replied
    The icon properites say:
    /usr/bin/steam %U

    maybe try in a term and post details?

    Doom3 BFG got opensourced. Would I be able to play, once the Linux version will
    be hacked, with a windoze buy from within steam on Linux?
    Thanks

    Leave a comment:


  • Larian
    replied
    Originally posted by Artemis3 View Post
    I clicked play and the normal "your game is being downloaded" window showed, library downloads show the game downloading normally. A 12G download... for you 20 mins, for me 10 hours... Let's hope it works.
    Well, at least you're getting that much. I've downloaded and installed the game, let it update, and I still get a big, fat nothing when I launch. My Steam Chat window indicates that I've gone into TF2 for a couple of seconds, but then *poof*. The process quietly dies.

    I guess I'm just going to wait for the full client. Shouldn't be that much longer now anyway.

    Leave a comment:


  • Artemis3
    replied
    Originally posted by ronybeck View Post
    I had a similar experience. I noticed that there was some significant network traffic while TF2 appeared to be stuck in the "Launching" phase. I let it be for about 20 minutes and then *BAM*. It started working.
    I clicked play and the normal "your game is being downloaded" window showed, library downloads show the game downloading normally. A 12G download... for you 20 mins, for me 10 hours... Let's hope it works.

    Leave a comment:

Working...
X