Announcement

Collapse
No announcement yet.

Unreal Engine 3 works on Linux via Stage3D

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • winddos
    started a topic Unreal Engine 3 works on Linux via Stage3D

    Unreal Engine 3 works on Linux via Stage3D

    Today I've read news about Adobe Flash 11.4 and get an idea to test how Pepper Flash plugin works on Linux.
    Last time I tested 11.2 release and it's was completely unusual, because hardware acceleration was disabled by Adobe.
    Here is topic about that on phoronix: No OpenGL for Flash Stage3D on Linux.

    But today I checked latest version of Google Chrome and find that situation is completely changed.
    From Stage3D now disabled in plugin, but only disabled in Google Chrome configuration by default.

    There is screenshot of Unreal Engine 3 flash demo:
    1920x1200 screenshot
    My configuration is: Ubuntu 12.04 32-bit, AMD HD6950 1GB, FGLRX driver, Google Chrome 21.0.1180.81 with flash player 11.3.31.230.

    Try this:
    1. Install latest Google Chrome
    2. Run it with "--ignore-gpu-blacklist" flag
    3. Open chrome://gpu-internals/ and check Stage3D status
    4. Serf to http://www.unrealengine.com/flash/ or any other demo


    PS: For me it's even works on notebook with mobile Intel i3 and HD3000.
    Performance is quite low, looks like 10-15FPS, but all textures is here and all effects working like on HD6950.

  • dvanzo
    replied
    Originally posted by Gps4l View Post
    I just tested my system. I can pick 10000 fish, although the fps cave in when I start it, but then the fps go up to 49 fps.

    It shows 60 fps on all other number of fish.

    Amd phenom II X4, HD 5750. on windows

    On linux (opensuse) its disapointing

    Never get 60 fps not even with 1 fish.

    10000 fish gives 4 fps
    2000 fish 23 - 24 fps

    then changed kernel setting to performance.
    Some times it hits 60, but its not steady.

    2000 fish, 29 - 30 fps
    250 fish between 50 and 60 fps.
    Just tried the fishtank...

    2000 fish, 60 fps (steady)
    10000 fish, 50 fps (steady)

    Ubuntu 12.04 32 bits

    Leave a comment:


  • Gps4l
    replied
    Originally posted by kwahoo View Post
    I just tested my system. I can pick 10000 fish, although the fps cave in when I start it, but then the fps go up to 49 fps.

    It shows 60 fps on all other number of fish.

    Amd phenom II X4, HD 5750. on windows

    On linux (opensuse) its disapointing

    Never get 60 fps not even with 1 fish.

    10000 fish gives 4 fps
    2000 fish 23 - 24 fps

    then changed kernel setting to performance.
    Some times it hits 60, but its not steady.

    2000 fish, 29 - 30 fps
    250 fish between 50 and 60 fps.
    Last edited by Gps4l; 02-28-2013, 12:24 PM.

    Leave a comment:


  • dvanzo
    replied
    Originally posted by Kano View Post
    You did not fully close chrome after that change.
    Yes, I closed it... even checked the process list just to be sure...

    Really apreciate your help!!

    Leave a comment:


  • Kano
    replied
    You did not fully close chrome after that change.

    Leave a comment:


  • dvanzo
    replied
    Originally posted by Kano View Post
    Enable "Override software rendering list"
    Done, but nothing happens... Weird...

    Leave a comment:


  • Kano
    replied
    Enable "Override software rendering list"

    Leave a comment:


  • dvanzo
    replied
    Originally posted by Kano View Post
    It does not work that way with newer chrome versions, but you can use a much simpler way via:

    chrome://flags
    Ok, and wich flags I should change?

    Thanks in advance!

    Leave a comment:


  • Kano
    replied
    It does not work that way with newer chrome versions, but you can use a much simpler way via:

    chrome://flags

    Leave a comment:


  • dvanzo
    replied
    Originally posted by blackout23 View Post
    This because you didn't set "--ignore-gpu-blacklist" like the OP said. Otherwise it looks the same
    on my hardware. Not a bug.
    Mmm, no luck even launching chromium with: chromium-browser --ignore-gpu-blacklist

    Graphics Feature Status
    Canvas: Hardware accelerated
    Compositing: Hardware accelerated
    3D CSS: Hardware accelerated
    CSS Animation: Accelerated
    WebGL: Hardware accelerated
    WebGL multisampling: Hardware accelerated
    Flash 3D: Hardware accelerated
    Flash Stage3D: Hardware accelerated
    Texture Sharing: Hardware accelerated
    Video Decode: Hardware accelerated
    Video: Hardware accelerated
    Panel Fitting: Unavailable. Hardware acceleration disabled.
    Force Compositing Mode: Unavailable. Hardware acceleration disabled.
    Problems Detected
    Panel fitting is unavailable, either disabled at the command line or not supported by the current system.
    Force compositing mode is off, either disabled at the command line or not supported by the current system.
    Version Information
    Data exported 27/2/2013 20:55:09
    Chrome version 24.0.1312.56 (Build para desarrolladores 24.0.1312.56-0ubuntu0.12.04.1) Ubuntu 12.04
    Operating system Linux 3.5.0-18-generic
    Software rendering list version 0
    ANGLE revision 1560
    2D graphics backend Skia
    Driver Information
    Initialization time 91
    Sandboxed false
    GPU0 VENDOR = 0x10de [NVIDIA Corporation], DEVICE= 0x11c6 [Device 11c6]
    Optimus false
    AMD switchable false
    Driver vendor NVIDIA
    Driver version 310.14
    Driver date
    Pixel shader version 4.30
    Vertex shader version 4.30
    Machine model
    GL version 4.3
    GL_VENDOR NVIDIA Corporation
    GL_RENDERER GeForce GTX 650 Ti/PCIe/SSE2
    GL_VERSION 4.3.0 NVIDIA 310.14

    Leave a comment:

Working...
X