Announcement

Collapse
No announcement yet.

Unigine OilRush Officially Ships Today For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Qaridarium
    replied
    Originally posted by frustum View Post
    Thanks guys for the support. Both issues are fixed. The updated game will be available soon. I hope it helps to improve open source driver implementations.
    ok thank you

    Leave a comment:


  • frustum
    replied
    Thanks guys for the support. Both issues are fixed. The updated game will be available soon. I hope it helps to improve open source driver implementations.

    Leave a comment:


  • madrang
    replied
    Unigine just fix your game

    Originally posted by http://software.intel.com/en-us/blogs/2009/12/16/interview-ian-romanick-graphics-programmer/
    Ian Romanick is a Software Engineer in Intel's Open Source Technology Center. He is also one of Intel?s representatives to the OpenGL ARB. For the past 8 years he has been working very diligently to make OpenGL on Linux better. He has been doing graphics programming for 18 years, having released his first Amiga demo in 1991. Ian holds a Bachelors Degree in Computer Science from Portland State University. In his spare time, he teaches graphics programming in the Visual and Game Development program at the Art Institute of Portland.
    Originally posted by https://bugs.freedesktop.org/show_bug.cgi?id=45238
    Ian Romanick: The game is just broken. It check the client extension string (returned by
    glXGetClientString(dpy, GLX_EXTENSIONS)) instead of the list of extensions that
    are actually available for use (returned by glXQueryExtensionsString).
    Unigine, fix your game.

    Leave a comment:


  • smitty3268
    replied
    Well, this will be fixed without breaking spec once we get GLSL 1.4 (GL 3.1)

    If I'm understanding everything correctly. Hopefully that's ready in Mesa 8.1

    Leave a comment:


  • Qaridarium
    replied
    Marek Ol??k :"Hi everyone,
    If your Mesa driver supports GL3 or EXT_texture_array or ARB_draw_instanced, Unigine is broken for you. (I tested Unigine Sanctuary and Unigine Heaven, the others probably won't be any different)
    The only way to make it work seems to be to relax some requirements of the GL spec and extensions (i.e. being non-compliant and non-portable in theory, but actually being very portable in practice). There are probably more ways to go about it. The patch below fixes softpipe and r600g. I think we should discuss this and come up with some solution, otherwise Unigine will be broken forever. It doesn't have to be exactly like this patch. I think that if we go with an out-of-spec behavior, we should print a compiler warning at least."

    LOL!!!!! i Vote for broke Unigine forever!

    Hell what a crap shit! ok my 15$ are lost on this company.

    Leave a comment:


  • Paulie889
    replied
    Originally posted by whizse View Post
    Filed a proper bug report to keep track of this:
    https://bugs.freedesktop.org/show_bug.cgi?id=45238
    That was resolved real quick: NOTOURBUG :-(
    I really don't like what Unigine is doing with the OpenGL spec... And this is not the first time. There is another known bug when GL_ARB_draw_instanced is used, I did report this "gl_InstanceID" problem to them back in 08 April 2011 and it still isn't fixed.
    http://oilrush-game.com/forum/index....nced-properly/
    They just don't care.

    And now there is a talk about breaking GL compliance in mesa in order for Unigine to run!!!
    http://lists.freedesktop.org/archive...ry/018140.html
    WTF? This is not the way its done, this could set a really bad precedent for all. Instead we need to put some pressure on Unigine corp to fix this.

    Leave a comment:


  • whizse
    replied
    Filed a proper bug report to keep track of this:
    https://bugs.freedesktop.org/show_bug.cgi?id=45238

    Leave a comment:


  • ChrisXY
    replied
    Originally posted by whizse View Post
    Updating to 1.11.99.901 doesn't help, it's a known bug:
    http://lists.freedesktop.org/archive...ry/017892.html
    I can confirm that... xorg git from today:
    Code:
     ~ % unigine-heaven
    Fullscreen? Please enter 1 or 0. (1 = yes, 0 = no)
    0
    Video width? e.g. 1024
    
    Video height? e.g. 768
    
    Engine::init(): can't create log file
    Loading "/opt/unigine-heaven/bin/../data/heaven_2.5.cfg"...
    Engine::init(): clear video settings for "Gallium 0.4 on AMD REDWOOD 2.1 Mesa 8.0-devel (git-dc435ae)"
    Loading "libGL.so.1"...
    Loading "libopenal.so.1"...
    Set 640x480 windowed video mode
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  154 (GLX)
      Minor opcode of failed request:  34 ()
      Serial number of failed request:  46
      Current serial number in output stream:  45
    
     ~ % X -version
    
    This is a pre-release version of the X server from The X.Org Foundation.
    It is not supported in any way.
    Bugs may be filed in the bugzilla at http://bugs.freedesktop.org/.
    Select the "xorg" product for bugs you find in this release.
    Before reporting bugs in pre-release versions please check the
    latest version in the X.Org Foundation git repository.
    See http://wiki.x.org/wiki/GitPage for git access instructions.
    
    X.Org X Server 1.11.99.901 (1.12.0 RC 1)
    Release Date: 2011-12-27
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 3.3.0-1-mainline x86_64 
    Current Operating System: Linux chrisl 3.3.0-1-mainline #1 SMP PREEMPT Fri Jan 20 23:44:26 UTC 2012 x86_64
    Kernel command line: root=/dev/disk/by-uuid/1ec5d4eb-f2c2-445a-88bd-41b5717fab29 ro init=/sbin/e4rat-preload quiet radeon.pcie_gen2=1 initrd=../initramfs-linux-mainline.img BOOT_IMAGE=../vmlinuz-linux-mainline 
    Build Date: 25 January 2012  06:51:11PM
     
    Current version of pixman: 0.24.2
            Before reporting problems, check http://wiki.x.org
            to make sure that you have the latest version.

    Leave a comment:


  • whizse
    replied
    Originally posted by Ansla View Post
    That minor opcode is for the GLX_ARB_create_context extension that latest mesa advertises but your X server does not understand. Try with xorg-server 1.11.99.901 or latest git.
    Updating to 1.11.99.901 doesn't help, it's a known bug:
    http://lists.freedesktop.org/archive...ry/017892.html

    Leave a comment:


  • Kakarott
    replied
    Originally posted by kokoko3k View Post
    I'd like to check before buy, is there a demo?
    Not right now. But it will come.
    http://oilrush-game.com/forum/index....dpost__p__4498

    Leave a comment:

Working...
X