Announcement

Collapse
No announcement yet.

Alien Arena 2010 v7.45 Offers Up More Features

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    does not work on R520 (1800XT) with 300g. The screen is just as posted above garbage. I added the return statement as instructed and recompiled with same result.

    Comment


    • #32
      Originally posted by voxiac View Post
      Hi guys

      I have exactly the same problem with but G45. It seems to me that the check for that GL_EXT_framebuffer_blit extension is somehow busted. First it reports in the log "...using GL_EXT_framebuffer_blit" and then fails to load the actual function. Actually I commented out the
      Code:
      if(gl_state.hasFBOblit) {
      		if(!qglBlitFramebufferEXT) {
      			Com_Printf("qglBlitFramebufferEXT not found...\n");
      			//no point in continuing on
      			gl_state.hasFBOblit = false;
      			return;
      		}
      	}
      in r_shadowmaps.c and the game happily starts up...
      Yeah, that makes perfect sense. The driver has the support for it, but it's badly broken. I'll have to think of a reasonable solution here, though it'd be nice if the authors of the drivers would just fix this once and for all.

      Comment


      • #33
        with commenting out the code check, the gane started. Now can I change the video option without crashing the game?

        Comment


        • #34
          Originally posted by Beiruty View Post
          with commenting out the code check, the gane started. Now can I change the video option without crashing the game?
          Only one way to find out.

          Comment


          • #35
            Originally posted by Irritant View Post
            Yeah, that makes perfect sense. The driver has the support for it, but it's badly broken. I'll have to think of a reasonable solution here, though it'd be nice if the authors of the drivers would just fix this once and for all.
            Also after digging some more in the code I found that qglBlitFramebufferEXT is never called anyway for all open source drivers because that code path is guarded by "atoi(&gl_config.version_string[0]) >= 3.0" which I assume (my OpenGL-fu is almost nonexistent) requires OpenGL 3.

            Comment


            • #36
              I think I got it. The reason it fails is because there's no symbol "glBlitFramebufferEXT" in my libGL, but it has "glBlitFramebuffer".

              Comment


              • #37
                Originally posted by voxiac View Post
                I think I got it. The reason it fails is because there's no symbol "glBlitFramebufferEXT" in my libGL, but it has "glBlitFramebuffer".
                That's ok, the problem is that the driver is returning either one of those. The game is checking for the extension, if the driver returns it, it proceeds forward. If the driver didn't return the extension, the game wouldn't try to use it.

                The problem is the driver should not return the extension, because the extension is broken in the driver.

                There are a couple things I can do here. I can put a check for that driver and tell the game to not to bother checking for the extension, which IMO is a hokey, but necessary thing to do, or the authors of the driver can get their act together and either fix the problem, or remove the extension until they do.

                I'm in favor of the latter. If somebody can give me the contact information for whoever is working on this driver, I'd greatly appreciate it.

                Comment


                • #38
                  For Intel:
                  http://intellinuxgraphics.org/how_to_report_bug.html

                  Comment


                  • #39
                    Originally posted by voxiac View Post
                    Hi guys

                    I have exactly the same problem with but G45. It seems to me that the check for that GL_EXT_framebuffer_blit extension is somehow busted. First it reports in the log "...using GL_EXT_framebuffer_blit" and then fails to load the actual function. Actually I commented out the
                    Code:
                    if(gl_state.hasFBOblit) {
                            if(!qglBlitFramebufferEXT) {
                                Com_Printf("qglBlitFramebufferEXT not found...\n");
                                //no point in continuing on
                                gl_state.hasFBOblit = false;
                                return;
                            }
                        }
                    in r_shadowmaps.c and the game happily starts up...
                    That worked perfectly.

                    Comment


                    • #40
                      I'm deeply impressed with the new game's performance. I haven't had the opportunity to measure the exact performance (FPS) ,but, using my eye-o'meter, i can tell it goes all the way over 30 FPS (I couldn't tell anything beyond that, it could be 31 FPS as well). This is , with an integrated GPU (ATI 3200 I believe) and a stock Athlon II X4 at 2.6ghz. Nexuiz never gave me that kind of performance, and Urban Terror, at the same resolution (1280x1024) gives around 80 FPS and it's a worse looking game.

                      The only downside is the hella slow mouse movement for me, even moving the mouse all over the table isn't enough for turning twice, but this may be a personal problem and otherwise unrelated to the game.


                      Congratz on this amazingly fast (As performance and date) release, keep it up.

                      Comment

                      Working...
                      X