Announcement

Collapse
No announcement yet.

Alien Arena 2010 v7.45 Offers Up More Features

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    I think it looks gorgeous! Nice work devs! Alien Arena is one of my favourite games!

    Nitpick: The only thing that I feel lets down the game graphically is the aliens, it would be nice if they were more sinister looking rather than comical looking.

    e.g. more this:


    than this:



    But of course that's just a minor personal preference, and I'm probably missing the point

    Comment


    • #12
      Originally posted by Kazade View Post
      Nitpick: The only thing that I feel lets down the game graphically is the aliens, it would be nice if they were more sinister looking rather than comical looking.
      I think they found just the right balance between funny looking characters (which also contribute to the fun atmosphere of the game) and seriousness.

      Comment


      • #13
        The game is supposed to have that 50s and 60s scifi feel to it, hence the peculiar alien appearance and the level design (or the Godzilla named bots). It's part of the game's charm. Tech. issue for me though: the game doesn't seem to work correctly with the 300g driver (pixel garbage is displayed on screen), despite the previous 7.40 version working.

        Comment


        • #14
          Originally posted by Melcar View Post
          The game is supposed to have that 50s and 60s scifi feel to it, hence the peculiar alien appearance and the level design (or the Godzilla named bots). It's part of the game's charm. Tech. issue for me though: the game doesn't seem to work correctly with the 300g driver (pixel garbage is displayed on screen), despite the previous 7.40 version working.
          Hmm, sounds like the driver is erroneous reporting that it has FBOblit when it isn't working correctly.

          Try disabling gl_shadowmaps and see if it works then. You can set gl_shadows 2 as well, to use the older stencil types.

          Comment


          • #15
            Originally posted by Irritant View Post
            Ok, well in that thread, several people tried to help you, and you never responded.
            My comments in the thread are an adequate response.

            Comment


            • #16
              Originally posted by Irritant View Post
              Hmm, sounds like the driver is erroneous reporting that it has FBOblit when it isn't working correctly.

              Try disabling gl_shadowmaps and see if it works then. You can set gl_shadows 2 as well, to use the older stencil types.

              Doesn't work. I can't get past the menu screen:



              ... and here is the terminal output:

              Code:
              execing default.cfg
              bind <key> [command] : attach a command to a key
              Unknown command "wave 4"
              execing config.cfg
              Console initialized.
              
              ------- sound initialization -------
              OpenAL Information:
              Active Device: ALSA Software
                Vendor:     OpenAL Community
                Version:    1.1 ALSOFT 1.12.854
                Renderer:   OpenAL Soft
                ALC Frequency: 48000
                Generated Buffer Count: 256
                ALC Mono Sources: 255
                ALC Stereo Sources: 1
                Generated Source Count: 128
              Available Devices:
                ALSA Software
              ------------------------------------
              --------- [Loading Renderer] ---------
              Initializing OpenGL display
              ...setting mode 1: 800 600
              Using XFree86-VidModeExtension Version 2.2
              GL_VENDOR: X.Org R300 Project
              GL_RENDERER: Gallium 0.4 on RS480
              GL_VERSION: 2.1 Mesa 7.9-devel
              GL_EXTENSIONS: GL_ARB_copy_buffer GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_fragment_coord_conventions GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_map_buffer_range GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_shading_language_120 GL_ARB_shadow GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_swizzle GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_logic_op GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_copy_texture GL_EXT_draw_range_elements GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_fog_coord GL_EXT_gpu_program_parameters GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_pixels GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_polygon_offset GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_subtexture GL_EXT_texture GL_EXT_texture3D GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_object GL_EXT_texture_rectangle GL_EXT_texture_sRGB GL_EXT_texture_swizzle GL_EXT_vertex_array GL_EXT_vertex_array_bgra GL_APPLE_packed_pixels GL_APPLE_vertex_array_object GL_ATI_blend_equation_separate GL_ATI_texture_env_combine3 GL_ATI_texture_mirror_once GL_ATI_separate_stencil GL_IBM_multimode_draw_arrays GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_INGR_blend_func_separate GL_MESA_pack_invert GL_MESA_ycbcr_texture GL_MESA_window_pos GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_light_max_exponent GL_NV_packed_depth_stencil GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_OES_read_format GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_border_clamp GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod GL_SUN_multi_draw_arrays GL_OES_EGL_image
              ...allowing CDS
              ...enabling GL_EXT_compiled_vertex_array
              ...ignoring GL_EXT_point_parameters
              ...3DFX_set_global_palette not found
              ...GL_EXT_shared_texture_palette not found
              ...using GL_ARB_multitexture
              ...GL_SGIS_multitexture not found
              ...using GL_ARB_texture_env_combine
              ...using GL_EXT_texture_filter_anisotropic
              ...using GL_EXT_stencil_wrap
              ...using GL_EXT_framebuffer_blit
              ...using GL_EXT_stencil_two_side
              ...using GL_ARB_vertex_buffer_object
              ...Initializing VBO cache
              qglBlitFramebufferEXT not found...
              ------------------------------------
              ...Initializing IRC client
              ...IRC rejected due to unset player name
              ======== CRX Initialized ========
              
              Master server at 174.37.203.131:27900
              Sending shutdown to 174.37.203.131:27900
              recursive shutdown

              Comment


              • #17
                Wow, never saw that before!

                What GPU do you have?

                Trying to think here, what may have changed from 7.40 to cause that, and I'm thinking it's not liking the use of multiple framebuffer objects. What exactly is the 300g driver, I'm not familiar with that?

                Comment


                • #18
                  GL_RENDERER: Gallium 0.4 on RS480
                  GL_VERSION: 2.1 Mesa 7.9-devel

                  Ah there we go. I'm not sure what is borking up, but I have heard alot of bad things about ATI Linux drivers. I know that they sometimes have real bad issues with framebuffer objects and blitting...

                  Comment


                  • #19
                    Is there another driver you might try?

                    Comment


                    • #20
                      Not really. Its a 200M chip (RS480), so radeon/mesa is the only driver I can use. Will try classic mesa this weekend and see if anything changes.

                      Comment

                      Working...
                      X