Announcement

Collapse
No announcement yet.

ETQW 1.5 under Gallium3D (R300)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Beiruty
    started a topic ETQW 1.5 under Gallium3D (R300)

    ETQW 1.5 under Gallium3D (R300)

    What is needed to run ETQW under Gallium3D, ATI R520 GPU? I can start the game but when I hit play, it crashes.

    I am use ppa edgers for the Gallium3D r300g.

  • Saunabad
    replied
    Originally posted by Beiruty View Post
    I complied and installed the 32-bit version of the texture compression lib. I can report that I am now successfull starting and running the game in 64-bit system. At 1920x1200 it is bit slow, maybe in single digit frame rate. NO corruptions or Artifacts. That is great will try with lower resolution later.

    Thanks for the help! Great progress in r300g
    Is the 32-bit library available for download somewhere?

    I have successfully compiled and installed the 64-bit version on my Arch Linux system.

    Had a bit of trouble finding the source files since http://homepage.hispeed.ch/rscheideg...n070518.tar.gz doesn't exist anymore, but finally found them here.

    Leave a comment:


  • Beiruty
    replied
    I complied and installed the 32-bit version of the texture compression lib. I can report that I am now successfull starting and running the game in 64-bit system. At 1920x1200 it is bit slow, maybe in single digit frame rate. NO corruptions or Artifacts. That is great will try with lower resolution later.

    Thanks for the help! Great progress in r300g

    Leave a comment:


  • Zhick
    replied
    I'm running an amd64 gentoo system and I just played the etqw-demo for maybe 15-30 mins and experienced no crashes or anything similar.

    Leave a comment:


  • marek
    replied
    I know, I was running whole 32-bit Mesa and libdrm and libtxc_dxtn on a 64-bit system and I can tell you it is not worth it. It still crashed sometimes and gdb could not recognize the binary format, so I wasn't able to not debug it.

    Really, if you want ETQW, the easiest way is to install a 32-bit system with libtxc_dxtn.

    Leave a comment:


  • Zhick
    replied
    GODDAMN 1 min edit limit.

    What you should do is CFLAGS="-m32" LDFLAGS="-m32" make; sudo make install32. I just c&p the Makefile without looking at it again, and I thought I had added the -m32 flag in there. But apparently I set them as environment-variables.

    And since I'm doing another post anyway, I might as well add this:
    And I'm not 100% sure, as I'm not a Ubuntu-user, but I think the xorg-edgers ppa already gives you 32bit mesa and drivers, so you should be clear on that front.
    In case I'm wrong on that, you'll have to build mesa yourself, but that's not so hard as well. This:
    Code:
    git clone git://anongit.freedesktop.org/git/mesa/mesa
    cd mesa
    ./autogen.sh --enable-32-bit --enable-gallium-radeon --disable-gallium-llvm --with-state-trackers=dri,glx,egl,vega --with-dri-drivers=r300,swrast
    make -j2
    cp lib/gallium/radeong_dri.so lib/gallium/r300_dri.so
    should do the trick. If you're missing any dependencies you should be able to install them via apt-get build-dep mesa. When you build mesa that way you'll need to prepend LIBGL_DRIVERS_PATH=~/src/mesa32/lib/gallium/ LD_LIBRARY_PATH=~/src/mesa32/lib/ (adjust the paths) to what you want to run.

    Leave a comment:


  • Zhick
    replied
    Originally posted by marek View Post
    You need to compile Mesa and libdrm for 32-bit too if you want direct rendering. Baahh, just get a 32-bit distro, really. I think you have no other choice.
    It's really not that bad.
    For libtxc_dtn.so you just have to adjust the Makefile like this:
    Code:
    CFLAGS += -Wall -pedantic -fPIC
    OPT_CFLAGS = -O3
    LDFLAGS += -shared -fPIC
    OBJS = txc_compress_dxtn.o txc_fetch_dxtn.o
    LIB = libtxc_dxtn.so
    
    $(LIB): $(OBJS)
            $(CC) $(LDFLAGS) -o [email protected] $(OBJS)
    
    %.o: %.c txc_dxtn.h
            $(CC) $(CFLAGS) $(OPT_CFLAGS) -c -o [email protected] $<
    
    clean:
            rm -f $(OBJS) $(LIB)
    
    install: $(LIB)
            install -d $(DESTDIR)/usr/lib
            install -m 755 $(LIB) $(DESTDIR)/usr/lib
    
    install32: $(LIB)
            install -d $(DESTDIR)/usr/lib32
            install -m 755 $(LIB) $(DESTDIR)/usr/lib32
    Then just do make; sudo make install and you should be ready.
    And I'm not 100% sure, as I'm not a Ubuntu-user, but I think the xorg-edgers ppa already gives you 32bit mesa and drivers, so you should be clear on that front.

    Leave a comment:


  • nanonyme
    replied
    Originally posted by Beiruty View Post
    Now how do I compile that lib in 32-bits mode?
    Put -m32 to CFLAGS and LDFLAGS in Makefile. Though you do need 32bit deps as marek said.

    Leave a comment:


  • Beiruty
    replied
    In a nutshell, ETQW can't run under 64-bit. I will give up on that game to run under linux. I still double boot my machine and still run the game under WinXP.

    Leave a comment:


  • marek
    replied
    You need to compile Mesa and libdrm for 32-bit too if you want direct rendering. Baahh, just get a 32-bit distro, really. I think you have no other choice.

    Leave a comment:

Working...
X