Announcement

Collapse
No announcement yet.

Unigine Heaven 2.0 Launches For Linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic Unigine Heaven 2.0 Launches For Linux

    Unigine Heaven 2.0 Launches For Linux

    Phoronix: Unigine Heaven 2.0 Launches For Linux

    Unigine Heaven has finally arrived! Unigine Heaven, a tech demo / benchmark that offers heavenly graphics and was released for Windows 7 back in October with a DirectX 11 renderer, is now available on Linux with its OpenGL 3.2 renderer. As we suspected, the Linux support has arrived with the release of Unigine Heaven 2.0, which includes an updated Windows binary as well...

    http://www.phoronix.com/vr.php?view=ODA5NA

  • Apteryx
    replied
    Quick Heaven benchmark

    I've done this quick benchmark while upgrading my machine from Ubuntu 9.10 to 10.04. Here are the results :





    Leave a comment:


  • cliff
    replied
    Originally posted by Michael View Post
    You're not running the latest Git snapshot, but the test profile that I had written against the internal build.

    New version: http://phorogit.com/index.php?p=phor...e.git&dl=targz (Git)
    Thanks, But you are talking wayyyy over my head I downloaded that file and uncompressed it but didn't know what to do next.

    Leave a comment:


  • whizse
    replied
    Originally posted by pvtcupcakes View Post
    @Bridgman, or anybody

    What would it take to implement GL_ARB_map_buffer_range into the r600 mesa driver? I tried running Unigine Sanctuary, and that's the error I get.

    Code:
    Unigine fatal error
    Engine::init(): clear video settings for "Mesa DRI R600 (RV770 9442) 20090101 x86/MMX+/3DNow!+/SSE2 TCL DRI2 2.0 Mesa 7.9-devel"
    GLRender::GLRender(): Unknown GPU
    GLRender::require_extension(): required extension GL_ARB_map_buffer_range is not supported
    FWIW, you can lie to an application and pretend the extension is available by starting it with MESA_EXTENSION_OVERRIDE=+GL_ARB_map_buffer_range

    It will either spit out the next missing extension, or crash.

    Leave a comment:


  • matty429
    replied
    Originally posted by entropy View Post
    Maybe you just discovered the hidden anaglyph support.
    If I could just find those d**n glasses...
    I think I enabled Led Zeppelin / Black Sabbath mode...

    Leave a comment:


  • matty429
    replied
    Originally posted by Raven3x7 View Post
    Yes. Are you using the beta drivers(xorg 1.7 support) from the latest ubuntu release?
    2:8.721

    I tried the 10.3 from ati, that broke everything but basic 2d.

    Leave a comment:


  • entropy
    replied
    Originally posted by matty429 View Post
    Anyone else getting this?
    ATi 5750 X64
    Maybe you just discovered the hidden anaglyph support.
    If I could just find those d**n glasses...

    Leave a comment:


  • Kano
    replied
    @Michael

    It is hard to say use the "git version" because when you really use git, then you get outdated code (compared to your tar.gz):

    checking phoronix-test-suite.diff:
    18 files changed, 86 insertions(+), 77 deletions(-)

    Leave a comment:


  • Raven3x7
    replied
    Originally posted by matty429 View Post
    Anyone else getting this?
    ATi 5750 X64
    Yes. Are you using the beta drivers(xorg 1.7 support) from the latest ubuntu release?

    Leave a comment:


  • Michael
    replied
    Originally posted by cliff View Post
    Its not working on my 64 bit Ubuntu.
    When I type this in the terminal.
    "phoronix-test-suite benchmark unigine-heaven"
    It acts as though its downloading 130 some megs then in just a few seconds it asks about tesselation and resolution then it just shows
    Unigine Heaven:
    unigine-heaven [Tessellator: Disabled - Resolution: 1920 x 1080]
    Expected Trial Run Count: 3
    Started Run 1 @ 03:25:45
    Started Run 2 @ 03:25:47
    Started Run 3 @ 03:25:49

    Test Results:

    Average: 0 Frames Per Second
    Never leaves the terminal for some reason it doesn't download correctly?
    I even reinstalled the Test Suite.
    Any ideas??
    You're not running the latest Git snapshot, but the test profile that I had written against the internal build.

    New version: http://phorogit.com/index.php?p=phor...e.git&dl=targz (Git)

    Leave a comment:

Working...
X