Announcement

Collapse
No announcement yet.

Proton 5.13-2 Released With A Variety Of Game Fixes, VKD3D-Proton 2.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Proton 5.13-2 Released With A Variety Of Game Fixes, VKD3D-Proton 2.0

    Phoronix: Proton 5.13-2 Released With A Variety Of Game Fixes, VKD3D-Proton 2.0

    In time for the weekend Linux gamers is an updated Proton release from Valve and CodeWeavers for powering Steam Play to enjoy the latest Windows games on Linux...

    http://www.phoronix.com/scan.php?pag....13-2-Released

  • #2
    I tried Assassin's Creed: Odyssey. It works quite well (better than several months ago), except for the handling of Shift+F2. Does the newest Wine 5.21 also have Shift+F2 issues with Uplay games?

    Comment


    • #3
      Originally posted by atomsymbol View Post
      I tried Assassin's Creed: Odyssey. It works quite well (better than several months ago), except for the handling of Shift+F2. Does the newest Wine 5.21 also have Shift+F2 issues with Uplay games?
      It might but the other Proton and Wine flavor's, one of them could have created a patch for it as well. Difficult to say anymore. I just randomly try different ones if there's a problem and one often solves it. Its lame but its something.

      But, there are plenty of problems not yet solved by any. Wine just works better than it used to because there's more activity and stuff working.

      Comment


      • #4
        Company of Heroes 2 doesn't work with any of the newer Proton 5.13 releases, at least on Manjaro 20.2 RC1. On Ubuntu it would at least get into the menue, but wouldn't run the game or run the benchmark. I do start it with the suggested settings from protondb. The last known Proton that runs it successfully is the latest Glorious Eggroll release (5.9-GE-8-ST).

        Edit: I've just tested it on the current openSUSE Tumbleweed, to make it work with a popular mesa-git repo, I need to break a dependancy of a mesa-vulkan-device-select package and can get the game to work with Proton 5.13-2. I guess that makes this issue Manjaro-specific.

        By the way, the current Mesa/LLVM doesn't work fine with VAAPI in Chromium, I get a visually messed-up video and only deactivating hw video decode makes it work again...
        Last edited by ms178; 14 November 2020, 11:27 AM.

        Comment


        • #5
          Gave The Witcher III a lot of movement and cursor stuttering. Still using glorious eggroll customs. For the most part these releases are good but thank the gods for glorious eggrolls.
          Manjaro: R7 5800X, 32GB DDR4 3200, GTX 1070

          Comment


          • #6
            Still can't seem to get Mangohud to work with this 5.13 releases. 5.0 works fine.

            Comment


            • #7
              Originally posted by Melcar View Post
              Still can't seem to get Mangohud to work with this 5.13 releases. 5.0 works fine.
              I managed to enable vkBasalt with Proton 5.13 in AC: Odyssey. The procedure for enabling Mangohud (Vulkan overlay) might be similar. See http://atom-symbol.net/f/2020-11-14/

              Comment

              Working...
              X