Announcement

Collapse
No announcement yet.

Feral's GameMode 1.5 Now Supports Changing The CPU Governor Differently For iGPUs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • audi.rs4
    replied
    Originally posted by HenryM View Post

    so that confirms that gamemode lacks the privileges to change governor settings, something I'm pretty sure sudo/root is normally needed to do and the it's the same problem I encountered. does the output of
    Code:
    groups user
    include gamemode?

    ...
    [/CODE]
    I removed the Ubuntu gamemode package and just downloaded the 1.5 version from Github. It works now. Perhaps the Ubuntu package is just broken. I'll go submit a bug report for it to Ubuntu, if one doesn't exist for it already.

    Thanks for the help! Now, with a working gamemode, I'm off to play some Dirt 4.

    Leave a comment:


  • HenryM
    replied
    Originally posted by audi.rs4 View Post

    I already had the gamemode.ini setup. When performance was manually set as the governor, it gave no error. When I put schedutil as the governor, I got the following output from gamemoded. I also checked, to see if with performance on, when launching Dirt 4, if when I quit, it would switched it to schedutil, but It did not.

    [email protected]:~$ gamemoded -t

    :: Feature tests
    ::: Verifying CPU governor setting
    ERROR: Governor was not set to performance (was actually schedutil)!
    ::: Failed!
    so that confirms that gamemode lacks the privileges to change governor settings, something I'm pretty sure sudo/root is normally needed to do and the it's the same problem I encountered. does the output of
    Code:
    groups user
    include gamemode?

    annoying how fickle this usually is. I'm on Arch and I moved between gamemode-git and the normal gamemode release via the AUR before it started to work, which may or may not have been a factor.
    the extent of my bash_history when I got gamemode working includes only
    Code:
    systemctl --user enable gamemoded
    systemctl --user start gamemoded
    gamemoded -r
    
    cat /etc/group
    
    sudo groupadd gamemode
    sudo gpasswd -a [insert username here] gamemode
    Last edited by HenryM; 01-25-2020, 09:26 AM.

    Leave a comment:


  • nranger
    replied
    Do Intel CPUs still boost sufficiently with the powersave governor? On my last AMD APU laptop (Mullins 15W), setting the governor to "powersave" downclocked the CPU to 1 Ghz on all cores and pretty much locked it there even under load with only occasional boosting to 1.8Ghz (short of the normal 2.4Ghz boost). The "conservative" governor seemed much more responsive, and still saved considerable power (more of a "race to sleep" approach).

    Leave a comment:


  • audi.rs4
    replied
    Originally posted by HenryM View Post

    did you configure a gamemode.ini file? by default gamemode uses the powersave governor, but Ryzen seems to perfer the shedutil governor.

    if you haven't already done this, there should be an example file at /usr/share/doc/gamemode/example/gamemode.ini set defaultgov=schedutil and save to /home/.config

    the file is also accessible here: https://github.com/FeralInteractive/...master/example

    I can't remember the exact moment when gamemode started to work fully on my new Zen 2 system, but it was definitely after doing these things

    also it's interesting that you have so many governor options, I only get performance and schedutil.

    what is the result of running
    Code:
    gamemoded -t
    I already had the gamemode.ini setup. When performance was manually set as the governor, it gave no error. When I put schedutil as the governor, I got the following output from gamemoded. I also checked, to see if with performance on, when launching Dirt 4, if when I quit, it would switched it to schedutil, but It did not.

    [email protected]:~$ gamemoded -t
    : Loading config
    Loading config file [/home/curtis/.config/gamemode.ini]
    : Running tests

    :: Basic client tests
    :: Passed

    :: Dual client tests
    gamemode request succeeded and is active
    Quitting by request...
    :: Passed

    :: Gamemoderun and reaper thread tests
    ...Waiting for child to quit...
    ...Waiting for reaper thread (reaper_frequency set to 5 seconds)...
    :: Passed

    :: Supervisor tests
    :: Passed

    :: Feature tests
    ::: Verifying CPU governor setting
    ERROR: Governor was not set to performance (was actually schedutil)!
    ::: Failed!
    ::: Verifying Scripts
    ::: Passed (no scripts configured to run)
    ::: Verifying GPU Optimisations
    ::: Passed (gpu optimisations not configured to run)
    ::: Verifying renice
    ::: Passed (no renice configured)
    ::: Verifying ioprio
    ::: Passed
    ERROR: :: Failed!
    : Tests Failed!

    Leave a comment:


  • HenryM
    replied
    Originally posted by audi.rs4 View Post

    Thanks for the input. I tried out your suggestion, but no luck. Gamemode still doesn't automatically switch me to performance mode. I'm on a Ryzen 5 gen 1 CPU.

    Any other ideas? Should I post this to the Github site for gamemode?
    did you configure a gamemode.ini file? by default gamemode uses the powersave governor, but Ryzen seems to perfer the shedutil governor.

    if you haven't already done this, there should be an example file at /usr/share/doc/gamemode/example/gamemode.ini set defaultgov=schedutil and save to /home/.config

    the file is also accessible here: https://github.com/FeralInteractive/...master/example

    I can't remember the exact moment when gamemode started to work fully on my new Zen 2 system, but it was definitely after doing these things

    also it's interesting that you have so many governor options, I only get performance and schedutil.

    what is the result of running
    Code:
    gamemoded -t
    Last edited by HenryM; 01-24-2020, 01:59 AM.

    Leave a comment:


  • audi.rs4
    replied
    Originally posted by HenryM View Post

    I also had this issue, where gamemode runs via "gamemoderun %command%" steam launch option but cannot change the governor, confirmed by running
    Code:
    cpupower frequency-info
    I think I fixed it recently by uninstalling gamemode, creating the user group "gamemode" and adding myself to it, then installing gamemode again.
    Code:
    groupadd gamemode
    gpasswd -a user gamemode
    should do it
    Thanks for the input. I tried out your suggestion, but no luck. Gamemode still doesn't automatically switch me to performance mode. I'm on a Ryzen 5 gen 1 CPU.

    [email protected]:~$ cpupower frequency-info
    analyzing CPU 0:
    driver: acpi-cpufreq
    CPUs which run at the same hardware frequency: 0
    CPUs which need to have their frequency coordinated by software: 0
    maximum transition latency: Cannot determine or is not supported.
    hardware limits: 1.55 GHz - 3.20 GHz
    available frequency steps: 3.20 GHz, 2.80 GHz, 1.55 GHz
    available cpufreq governors: conservative ondemand userspace powersave performance schedutil
    current policy: frequency should be within 1.55 GHz and 3.20 GHz.
    The governor "ondemand" may decide which speed to use
    within this range.
    current CPU frequency: Unable to call hardware
    current CPU frequency: 1.38 GHz (asserted by call to kernel)
    boost state support:
    Supported: no
    Active: no
    [email protected]:~$ groups
    audi adm cdrom sudo dip plugdev lpadmin sambashare gamemode

    Any other ideas? Should I post this to the Github site for gamemode?

    Leave a comment:


  • SilverBird775
    replied
    While I appeciate the Feral's GameMode initiative, they cannot beat the power budget equation I believe. The one has to consider too many tweaking variables to get an optimum result. It is not a problem with GameMode daemon, absolutely not. It is just nowhere close to be universal solution. The main challenge here is a persistent system overheat. The modern notebooks are designed to dangerously overheat and trottle on the verge of self destruction. You will sure understand the pain when you actually get alike model. Just as an example, you absolutely dont want to force or even boost to highest nvidia's optimus clocks because the whole system already pushing its temperature limits.

    The user has to fine tune his system with ... downclocking, actually! Moderate downclocking\Unboosting the CPU do allow more power budget for discrete GPU in my case while keeping the wattage perfectly safe for both user (keyboard heating and heat exhaust) and notebook. The very same trick do the same effect for my other silent ATOM notebook with integrated GPU, just as an article suggest. I'm getting best results with "powersave" gaming and "performance" desktop on baytrail ATOM. No preinstalled daemon can possibly know such a perversion.

    Edit:
    To think even better, there is even more power budget scenarios. The one with the BIOS governed fan controller (default) and forced fan spin mode (undocumented). The clocks can be higher in case the fan is locked at maximum. It allows the user to trade the brutal noise for more performance juice.
    For a moment I'm fine with scripting all this things in per-application manner but it is tempting to write my own daemon. Sudoing the power budget matter gets extremely annoying very fast.
    Last edited by SilverBird775; 01-23-2020, 12:02 PM.

    Leave a comment:


  • HenryM
    replied
    Originally posted by audi.rs4 View Post
    when I launch games, it gives me the notification gamemode is enabled. But it doesn't change my CPU governor. I then manually do that via command line. I did have a Gnome Extension to do this, but it broke at some point, so I removed it. Could it still have a piece hanging around preventing gamemode from adjusting the CPU governor?
    I also had this issue, where gamemode runs via "gamemoderun %command%" steam launch option but cannot change the governor, confirmed by running
    Code:
    cpupower frequency-info
    I think I fixed it recently by uninstalling gamemode, creating the user group "gamemode" and adding myself to it, then installing gamemode again.
    Code:
     groupadd gamemode  
     gpasswd -a user gamemode
    should do it
    Last edited by HenryM; 01-23-2020, 01:22 AM.

    Leave a comment:


  • audi.rs4
    replied
    It might have said 1.5-dev. I didn't look that closely and I'm just going from memory from a month ago. I'll be curious if Ubuntu updates it now that it is finalized.

    Originally posted by vb_linux View Post

    How do you run the game - "gamemoderun ./game" or "gamemoderun %command%" in steam?

    Edit: Apparently, DiRT 4 should run with gamemode automatically. Still, either install Gnome extension or trying running with command to check if gamemode is running properly.
    I have nearly every game set to use gamemode. All that are set, are configured with "gamemoderun %command%". Dirt 4 as you stated though, supports it automatically, so I don't have to set it in Steam.

    I do have the gamemode Gnome extension installed, so when I launch games, it gives me the notification gamemode is enabled. But it doesn't change my CPU governor. I then manually do that via command line. I did have a Gnome Extension to do this, but it broke at some point, so I removed it. Could it still have a piece hanging around preventing gamemode from adjusting the CPU governor?

    Leave a comment:


  • vb_linux
    replied
    Originally posted by audi.rs4 View Post
    Weird. I thought 1.5 was already released, as that is what the version shows installed in my Ubuntu 19.10 from the apt repository. I also noticed that this "gamemode" doesn't set the CPU governor either because when I launch Dirt 4, it warns me my governor isn't in performance mode.

    Maybe I should remove the version in apt, and use the latest one just released.
    How do you run the game - "gamemoderun ./game" or "gamemoderun %command%" in steam?

    Edit: Apparently, DiRT 4 should run with gamemode automatically. Still, either install Gnome extension or trying running with command to check if gamemode is running properly.
    Last edited by vb_linux; 01-22-2020, 04:58 PM.

    Leave a comment:

Working...
X