Announcement

Collapse
No announcement yet.

Feral's GameMode 1.5 Now Supports Changing The CPU Governor Differently For iGPUs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by HenryM View Post

    did you configure a gamemode.ini file? by default gamemode uses the powersave governor, but Ryzen seems to perfer the shedutil governor.

    if you haven't already done this, there should be an example file at /usr/share/doc/gamemode/example/gamemode.ini set defaultgov=schedutil and save to /home/.config

    the file is also accessible here: https://github.com/FeralInteractive/...master/example

    I can't remember the exact moment when gamemode started to work fully on my new Zen 2 system, but it was definitely after doing these things

    also it's interesting that you have so many governor options, I only get performance and schedutil.

    what is the result of running
    Code:
    gamemoded -t
    I already had the gamemode.ini setup. When performance was manually set as the governor, it gave no error. When I put schedutil as the governor, I got the following output from gamemoded. I also checked, to see if with performance on, when launching Dirt 4, if when I quit, it would switched it to schedutil, but It did not.

    [email protected]:~$ gamemoded -t
    : Loading config
    Loading config file [/home/curtis/.config/gamemode.ini]
    : Running tests

    :: Basic client tests
    :: Passed

    :: Dual client tests
    gamemode request succeeded and is active
    Quitting by request...
    :: Passed

    :: Gamemoderun and reaper thread tests
    ...Waiting for child to quit...
    ...Waiting for reaper thread (reaper_frequency set to 5 seconds)...
    :: Passed

    :: Supervisor tests
    :: Passed

    :: Feature tests
    ::: Verifying CPU governor setting
    ERROR: Governor was not set to performance (was actually schedutil)!
    ::: Failed!
    ::: Verifying Scripts
    ::: Passed (no scripts configured to run)
    ::: Verifying GPU Optimisations
    ::: Passed (gpu optimisations not configured to run)
    ::: Verifying renice
    ::: Passed (no renice configured)
    ::: Verifying ioprio
    ::: Passed
    ERROR: :: Failed!
    : Tests Failed!

    Comment


    • #12
      Do Intel CPUs still boost sufficiently with the powersave governor? On my last AMD APU laptop (Mullins 15W), setting the governor to "powersave" downclocked the CPU to 1 Ghz on all cores and pretty much locked it there even under load with only occasional boosting to 1.8Ghz (short of the normal 2.4Ghz boost). The "conservative" governor seemed much more responsive, and still saved considerable power (more of a "race to sleep" approach).

      Comment


      • #13
        Originally posted by audi.rs4 View Post

        I already had the gamemode.ini setup. When performance was manually set as the governor, it gave no error. When I put schedutil as the governor, I got the following output from gamemoded. I also checked, to see if with performance on, when launching Dirt 4, if when I quit, it would switched it to schedutil, but It did not.

        [email protected]:~$ gamemoded -t

        :: Feature tests
        ::: Verifying CPU governor setting
        ERROR: Governor was not set to performance (was actually schedutil)!
        ::: Failed!
        so that confirms that gamemode lacks the privileges to change governor settings, something I'm pretty sure sudo/root is normally needed to do and the it's the same problem I encountered. does the output of
        Code:
        groups user
        include gamemode?

        annoying how fickle this usually is. I'm on Arch and I moved between gamemode-git and the normal gamemode release via the AUR before it started to work, which may or may not have been a factor.
        the extent of my bash_history when I got gamemode working includes only
        Code:
        systemctl --user enable gamemoded
        systemctl --user start gamemoded
        gamemoded -r
        
        cat /etc/group
        
        sudo groupadd gamemode
        sudo gpasswd -a [insert username here] gamemode
        Last edited by HenryM; 01-25-2020, 09:26 AM.

        Comment


        • #14
          Originally posted by HenryM View Post

          so that confirms that gamemode lacks the privileges to change governor settings, something I'm pretty sure sudo/root is normally needed to do and the it's the same problem I encountered. does the output of
          Code:
          groups user
          include gamemode?

          ...
          [/CODE]
          I removed the Ubuntu gamemode package and just downloaded the 1.5 version from Github. It works now. Perhaps the Ubuntu package is just broken. I'll go submit a bug report for it to Ubuntu, if one doesn't exist for it already.

          Thanks for the help! Now, with a working gamemode, I'm off to play some Dirt 4.

          Comment

          Working...
          X