Announcement

Collapse
No announcement yet.

SuperTuxKart 1.1 Released With Better Online Play, UI Enhancements, New Arena

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SuperTuxKart 1.1 Released With Better Online Play, UI Enhancements, New Arena

    Phoronix: SuperTuxKart 1.1 Released With Better Online Play, UI Enhancements, New Arena

    For those looking for some family-friendly, open-source gaming fun this weekend, SuperTuxKart 1.1 has been released as the Mario Kart inspired cross-platform racing game...

    http://www.phoronix.com/scan.php?pag...t-1.1-Released

  • #2
    If I compile my own version that lets me go 10x faster and play online, is that frowned upon?

    Comment


    • #3
      Usually in network gaming only the commands are transmitted over the network, so if the two (or more) game instances use a different engine the game will go out of sync (the players see different status) and will soon give an error.

      Anyway... cheating on a free child game, wouldn't you feel shame for it?

      Comment


      • #4
        I suspect the engine to be poorly optimized. The graphics are not so good in the default setting, and when you increase the details them frame rate drops and gets slow.

        Comment


        • #5
          Originally posted by uid313 View Post
          I suspect the engine to be poorly optimized. The graphics are not so good in the default setting, and when you increase the details them frame rate drops and gets slow.
          If I crank up the settings all the way, it only slows down if I enable Bloom. With Bloom disabled, but everything else maxed out, almost all of the maps have good frame rate and never slow me down. And mind you, I only have an iGPU, so I expect ever better performance out of a nVidia or good Radeon card.

          Also, aside from my experiences: the engine IS optimized. In fact, that was one of the main goals for 1.0.

          So stop spreading nonsense, this is not the first time you enter a topic and spread nonsense. Either that, or you're saying the truth, but you just have a very old video card.

          Comment


          • #6
            Originally posted by Vistaus View Post

            If I crank up the settings all the way, it only slows down if I enable Bloom. With Bloom disabled, but everything else maxed out, almost all of the maps have good frame rate and never slow me down. And mind you, I only have an iGPU, so I expect ever better performance out of a nVidia or good Radeon card.

            Also, aside from my experiences: the engine IS optimized. In fact, that was one of the main goals for 1.0.

            So stop spreading nonsense, this is not the first time you enter a topic and spread nonsense. Either that, or you're saying the truth, but you just have a very old video card.
            I use it on my Intel Core i7 "Haswell" 47770K with the integrated Intel GPU. The performance is decent with the standard settings, but slow when ramping up the graphics.

            Comment


            • #7
              Originally posted by uid313 View Post

              I use it on my Intel Core i7 "Haswell" 47770K with the integrated Intel GPU. The performance is decent with the standard settings, but slow when ramping up the graphics.
              This is expected on integrated graphics, especially older ones like the ones found in Haswell CPUs. There's no such thing as an IGP that runs modern engines at maxed settings smoothly

              Comment


              • #8
                Originally posted by uid313 View Post

                I use it on my Intel Core i7 "Haswell" 47770K with the integrated Intel GPU. The performance is decent with the standard settings, but slow when ramping up the graphics.
                ... so like I said: your GPU is too old.

                Comment


                • #9
                  Originally posted by Calinou View Post

                  This is expected on integrated graphics, especially older ones like the ones found in Haswell CPUs. There's no such thing as an IGP that runs modern engines at maxed settings smoothly
                  That's not true. Haven't you read my previous post? With the exception of Bloom, max settings on SuperTuxKart runs great on my Intel GPU (the one inside the i5 Kaby Lake R).

                  Comment


                  • #10
                    Originally posted by Vistaus View Post

                    ... so like I said: your GPU is too old.
                    But my old 4770K GPU runs very smooth and nice in other games such as War§ow, Half-Life 2, Portal 2, and Tesseract.
                    But on SuperTuxKart it is slow.

                    Originally posted by Vistaus View Post

                    That's not true. Haven't you read my previous post? With the exception of Bloom, max settings on SuperTuxKart runs great on my Intel GPU (the one inside the i5 Kaby Lake R).
                    My 4770K "Haswell" is older than your Kaby Lake R, and for me it runs slow on high settings even without bloom.
                    But other games run fast though and look much more beautiful, like Half-Life 2.

                    Comment

                    Working...
                    X