Announcement

Collapse
No announcement yet.

Civ6 and AMD GPU

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Civ6 and AMD GPU

    Has anyone managed to make Civ6 working with AMD GPU and latest Mesa 3D? I cannot even start it from Steam.

    System Info
    • GPU: [AMD/ATI] Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] (rev c6)
    • Kernel: 5.3.6
    • Xorg: compiled for 1.20.5, module version = 19.1.0
    • Mesa3d: 19.2.2

    Error message

    Code:
    [1104/225556:ERROR:browser_main_loop.cc(217)] Running without the SUID sandbox! See https://chromium.googlesource.com/chromium/src/+/master/docs/linux_suid_sandbox_development.md for more information on developing with the sandbox on.
    ERROR: ld.so: object '/home/niewod/.local/share/Steam/ubuntu12_32/gameoverlayrenderer.so' from LD_PRELOAD cannot be preloaded (wrong ELF class: ELFCLASS32): ignored.
       DEBUG: Start URL: "https://gameguide3.aspyr.com?bundle_id=289070&game_version=1.2.4&game_type=steamm&launches=30&locale=C&os_version=Linux%205.3.6&windowed=1&smallweb=0&platform=LinuxGame&disable_settings_menu=1#/whats_new"
       DEBUG: Delay: 1000
    getrlimit(RLIMIT_NOFILE) failed
     WARNING: QPixmap::scaleWidth: Pixmap is a null pixmap
    LOCALENAME: C
    UILANGUAGES 0 C
    ../src/gallium/auxiliary/nir/tgsi_to_nir.c:1815:get_image_format: Assertion `!"unhandled image format"' failed.
    Aborted
    Game removed: AppID 289070 "", ProcID 13256
    Uploaded AppInterfaceStats to Steam
    Exiting app 289070
    No cached sticky mapping in ActivateActionSet.Installing breakpad exception handler for appid(steam)/version(1572467527)
    Installing breakpad exception handler for appid(steam)/version(1572467527)
Working...
X