Announcement

Collapse
No announcement yet.

Proton Re-Based To Wine 4.11, Adds D9VK Direct3D 9, Better CPU Utilization & DXVK 1.3

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #51
    Originally posted by skeevy420 View Post

    I get that 100%.

    I'm currently having nothing but trouble with the latest Proton 4.11 release. My frickin PS4 controller doesn't work with it...or at least work with it and Hitman 2...I gots everything I needs in place for Fsync, Mesa with ACO, got the TKG and Valve Proton 4.11s, and my god damn controller doesn't work...fuck me running....
    Have you tried to set controller profile to forced off? One of my (cheap Chinese) controllers wouldn't work at all and the x360 one will show up as two distinct controllers in game if any profile is enabled.

    Comment


    • #52
      Originally posted by slavikgenes View Post

      Have you tried to set controller profile to forced off? One of my (cheap Chinese) controllers wouldn't work at all and the x360 one will show up as two distinct controllers in game if any profile is enabled.
      Forced on causes my system to "force lock up".

      Forced off make my PS4 controller do nothing in game. Ditto with the per game profile option.

      Enabling PS4 controller support in Steam BPM while the game is running and then setting it to force off (a common fix for some Proton games) leaves the PS4 controller in desktop mode.

      SC Controller in 360 Emulation mode causes my system to lock up.

      Revert back to Proton 4.2 or any TKG build from before the 4.11 commits and it works just fine with any controller combination.

      Hkp38f9 The problem with the kernel theory is that it my controller works on the same kernel with lower Proton versions. The kernel detects it and uses it just fine with my custom Proton builds based on 4.2 or 4.2 and earlier from Valve, it's Proton 4.11 that causes the problem. I do have 4.19 installed so I'll give that a shot just to see if it could be running 5.2.

      It's also the only controller connected to my system and is picked up as js0.

      EDIT: I should add that the same setups that causes lock ups and whatnot with Hitman 2 work just fine with Kingdom Come Deliverance.
      Last edited by skeevy420; 08-01-2019, 08:44 AM.

      Comment


      • #53
        Originally posted by skeevy420 View Post

        The problem with the kernel theory is that it my controller works on the same kernel with lower Proton versions. The kernel detects it and uses it just fine with my custom Proton builds based on 4.2 or 4.2 and earlier from Valve, it's Proton 4.11 that causes the problem. I do have 4.19 installed so I'll give that a shot just to see if it could be running 5.2.

        It's also the only controller connected to my system and is picked up as js0.
        Ok then your issue is unrelated to mine as yours is resolved by rolling back proton versions. Also the fact that your controller is the only jsX device on your computer on even kernel 5.2, means that (I presume) using an older kernel won't resolve your issue regardless of version.

        Also I missremembered, it was the LTS 4.14. kernel that worked in my scenario, and not the 4.19 LTS kernel.

        Comment


        • #54
          Fallout 4 still has no sound. This is a game made in 2015, how is it we're 4 years later and sound isn't working?

          Comment


          • #55
            Originally posted by Dukenukemx View Post
            Fallout 4 still has no sound. This is a game made in 2015, how is it we're 4 years later and sound isn't working?
            It requires a workaround be enabled via launch options:

            https://www.protondb.com/app/377160

            People are saying to do "WINEDLLOVERRIDES="xaudio2_7=n,b" PROTON_NO_ESYNC=1 %command%", although I suspect that "WINEDLLOVERRIDES="xaudio2_7=n,b" %command%" would be enough. This seems like something that will be fixed in a future version given the faudio work that has been being done.

            Comment


            • #56
              Originally posted by Dukenukemx View Post
              Fallout 4 still has no sound. This is a game made in 2015, how is it we're 4 years later and sound isn't working?
              WINEDLLOVERRIDES="xaudio2_7=n,b" PULSE_LATENCY_MSEC=60 %command%

              Sounds good to me.

              Comment


              • #57
                Originally posted by Dukenukemx View Post
                Fallout 4 still has no sound. This is a game made in 2015, how is it we're 4 years later and sound isn't working?
                That's likely because you need to set a WINEDLLOVERRIDE variable, like this, prepended in the Launch Options of the game:

                Code:
                WINEDLLOVERRIDES="xaudio2_7=n,b" %command%
                Essentially telling it to use xaudio 2.7, with priority to use native first, and built in as fallback.

                My sound works well in Fallout 4, only sometimes doing something like setting off a fatman nuke in an enclosed area will cause the audio to drop.

                Comment


                • #58
                  Originally posted by skeevy420 View Post

                  Good luck
                  Okay, the crash problem was caused by my own custom Wine Manager system. It's quite complex, and at its core is a multiplexed XDG system. The host .config, .local/share, and Desktop directories are multiplexed via mergerfs, and wine bottles (or prefixes as some call them) each have their own multiplexed XDG directories that provide a dynamic interface to the host.

                  Linux Steam had no problem with it a few months ago when my latest development spurt ended, so something happened between then and now. Linux Steam is now looking at the mergerfs as it would a link, and generates write errors when trying to access them.

                  In any case, I temporarily disabled the multiplexing system and following your instructions (with just a little problem installing dotnet40) I was able to get Elite Dangerous running for the first time! I really don't play games very much, and in fact have never even gotten beyond the training stage of Elite Dangerous, but it seemed to work amazingly well.

                  So thanks again for your help. I learned a bit about Proton (I didn't even know protontricks existed), and discovered a problem with my own Wine Manager system. I don't think the problem is on my end, but nevertheless it may be something I have to work around. If Steam doesn't work with it for some reason I need to make sure it's the only problematic program. The multiplexing system was designed to be completely transparent to the host, and if it's not I have big problems.

                  Comment


                  • #59
                    quick question about wine: is there any env variable to set to disable FAUDIO?

                    Comment


                    • #60
                      Originally posted by loganj View Post
                      quick question about wine: is there any env variable to set to disable FAUDIO?
                      Unfortunately not that I'm aware of. You either have to custom compile wine without FAudio, or find a way to use DLL overrides to disable it.

                      I don't have time to do it myself right now, but the DLLs I know of are xaudio2_0, xaudio2_1, xaudio2_2, xaudio2_3, xaudio2_4, xaudio2_5, xaudio2_6, xaudio2_7, xaudio2_8, xaudio2_9. You might simply be able to set them to "Native", which could possibly force wine not to use them. However it may be more complicated than that, you'll just have to experiment.

                      I'm sorry I could only give you a hint, but if you're still having problems after giving it your best then post here again and I'll look into it further in a few days. However there are a lot of people in this forum more knowledgeable than I, so hopefully you'll get better assistance before then

                      Comment

                      Working...
                      X