No announcement yet.

Yukon - Open GL video recording source code

  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Dragonlord View Post
    Especially things like lame, mplayer and mencoder I can hardly imagine ( yukon records into an own video format and the last time I checked it had no sound recording ).
    I'd expect those are there so that people can convert the video's to avi etc.


    • #12
      Yukon doesn't convert anything. What it does is providing a cat type tool that decompresses the video into raw AVI format to stdout. You then pipe it into mencoder which then turns this into whatever video you need. Since AVI is not an mencoder exclusive format I got a bit astonished on why it got pulled into the dep-tree. That said I worked with an older version of Yukon so you never know what happened in the mean time. I'll check the new version out on my gentoo box. I know then exactly what it needs and what not.

      EDIT: No way. The old website is down and the linkbox you provided is also down. I'm not sure but did the project not get renamed?
      Last edited by Dragonlord; 11-17-2008, 01:14 PM.


      • #13
        This was an ubuntu guide so I'd assume whoever did made a script to convert the video's to .avi using memcoder.

        As for Yukon I can't find it anywhere so I now use glc when I want to capture a video.


        • #14
          It's definitely worth a try. I'll check this one out to see how good it works ( if at all :P )


          • #15
            I tried glc before. That did not work for me at all. It didn't dump anything. I even think it dropped into SIGSEGVs.


            • #16
              so did you run seom-build/yukon-build yet ?


              • #17
                Originally posted by Licaon View Post
                so did you run seom-build/yukon-build yet ?
                I'll do that this weekend. Real life keeps disrupting these stuff.


                • #18
                  Hmm... I did configure&&make&&make install on both seom and yukon and it seems to compile fine.

                  I put yukon in my own configure prefix though. When I tried to add it on ldconfig path, I had problems with libX11 and I couldn't start a terminal. Thank goodness I have plenty of those running.

                  Now, I'll see if it works.

                  I tried it on mupen and nope. No seom dump file. Hmm... maybe it's because the X11 files are not included or something.
                  Last edited by niniendowarrior; 11-20-2008, 11:37 PM.


                  • #19
                    run from /yukon-src/tools/


                    • #20
                      Okay, got the time to do this one.

                      I ran that script and it told me to copy sysconf to /etc/yukon/system/ or $HOME/.yukon/system/.

                      I have NO such folders on my system so I made the folders and copied it.

                      This is what I get now.
                      Yukon seems installed correctly!
                      Note that this script doesn't check the runtime. Applications may still
                      fail to work with yukon due to various reasons (bugs etc.).
                      I'll try and see if it works.

                      EDIT: Nope. Doesn't work. No such luck.
                      Last edited by niniendowarrior; 12-05-2008, 09:50 PM.