Announcement

Collapse
No announcement yet.

Steam UI Finally Has A Scaling Mode For HiDPI Monitors

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steam UI Finally Has A Scaling Mode For HiDPI Monitors

    Phoronix: Steam UI Finally Has A Scaling Mode For HiDPI Monitors

    At the same time as adding HiDPI monitor support for Windows 10, Valve has added a "2X-scaling mode" for the Steam client to satisfy modern high resolution monitors...

    http://www.phoronix.com/scan.php?pag...eam-2X-UI-Mode

  • sl1pkn07
    replied
    why GDK_SCALE and not GDK_DPI_SCALE? 2x is horrible in my NON-HiDPI 4K display

    Leave a comment:


  • scirocco
    replied
    They had fixed it, steam was finally readable on my 4k tv for about a week, but todays update broke the scaling again, so steam is unusable.

    Leave a comment:


  • cj.wijtmans
    replied
    on my windows 10 laptop with hgh dpi 4k screen i have not noticed anything on this update.

    Leave a comment:


  • andrebrait
    replied
    Originally posted by pal666 View Post
    obviously i'm not asking to remaster old apps, i'm talking about current release of gnome for example.
    i mentioned steam client, which is browser displaying some html pages
    But Steam is one of those apps. And the only part of it that's a browser is the store and community tabs. All the rest isn't, AFAIK, which is the part that needs scaling too.

    If you weren't talking about Steam, I'm sorry, I thought you were.

    Leave a comment:


  • andrebrait
    replied
    Originally posted by holunder View Post
    @andrebrait: HiDPI Scaling in KDE Plasma works very well, you just have to set a custom font DPI and DON’T fiddle with the official UI scaling in monitor settings. Additionally, you should set the icons a resolution higher in system settings.
    https://www.frumble.de/blog/2017/03/...ium-2017/#HiDP
    Scaling is not just using a different font size. That can be done with GNOME and pretty much any DE out there. Getting stuff to work manually isn't exactly the same as scaling working as it should. The fact that you advised me to stay away from the UI scaling in the Monitor settings pretty much confirms that (but I must say it was working kind of ok the last time I tried Neon).

    Leave a comment:


  • pal666
    replied
    Originally posted by FishPls View Post
    Steam isn't just a wrapped browser. It's mostly a VGUI mess, that also happens to have a browser inside it. The biggest issue though is VGUI, that shit has existed since Half-Life.
    steam client (thing from which you launch steam games) is just a browser. it has css files and i manually increased font sizes in them. and my issue is this browser can't change scale without manual editing of css files

    Leave a comment:


  • pal666
    replied
    Originally posted by andrebrait View Post
    Because browsers don't display decades old desktop applications
    obviously i'm not asking to remaster old apps, i'm talking about current release of gnome for example.
    Originally posted by andrebrait View Post
    but some HTML pages, which have *some* standart by which it is possible to calculate how stuff should look like when upscaled
    i mentioned steam client, which is browser displaying some html pages
    Originally posted by andrebrait View Post
    ​​​​GNOME hasn't got fractional scaling working so far
    that's exactly what i'm complaining about

    Leave a comment:


  • pal666
    replied
    Originally posted by caligula View Post
    You don't even need HiDPI to scale the window.
    obviously, human eye has angular resolution, and angles are not measured in inches, but it looks like most ui devs skipped classes at school

    Leave a comment:


  • holunder
    replied
    @andrebrait: HiDPI Scaling in KDE Plasma works very well, you just have to set a custom font DPI and DON’T fiddle with the official UI scaling in monitor settings. Additionally, you should set the icons a resolution higher in system settings.
    https://www.frumble.de/blog/2017/03/...ium-2017/#HiDP

    Leave a comment:

Working...
X