Announcement

Collapse
No announcement yet.

Linux 4.9-rc7 Kernel Released: Final In 1~2 Weeks

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 4.9-rc7 Kernel Released: Final In 1~2 Weeks

    Phoronix: Linux 4.9-rc7 Kernel Released: Final In 1~2 Weeks

    The Linux 4.9-rc7 test kernel is now available although it's yet undecided whether there will be an RC8 before declaring it gold...

    http://www.phoronix.com/scan.php?pag...9-rc7-Released

  • #2
    Any idea if this kernel will support AMD Vega, or for that some future kernels with newer amdgpu will be needed?

    Comment


    • #3
      OK, hopefully it will come out in time before Vega release.

      Comment


      • #4
        We have not pushed Vega support out to public repos yet. Vega is a 2017 product despite all the rumors flying around.
        Test signature

        Comment


        • #5
          Is anyone able to boot this Kernel using the amdgpu driver on GCN 1.0 cards? Last time I checked there was no audio.

          Comment


          • #6
            Originally posted by Amarildo View Post
            Is anyone able to boot this Kernel using the amdgpu driver on GCN 1.0 cards? Last time I checked there was no audio.
            On my GCN 1.0 machine it seems to work fine. On my r9-380 I just get a blank screen with any of the 4.9.0rc kernels though.

            Comment


            • #7
              Interesting, that's exactly what I get now. Do you have any idea on why that happens?

              Comment


              • #8
                Originally posted by Amarildo View Post
                Interesting, that's exactly what I get now. Do you have any idea on why that happens?
                No, I'm assuming KMS is messed up, but there is nothing in the logs to show a problem. The machine responds to CTRL-ALT-DEL, and boots back into 4.8 just fine, so I'm not going to worry about. I'd like to think someone that knows how to file a proper bug report will do so before 4.9 is released, but I'd be willing to bet 4.9 gets released with amdgpu broken, to be honest.

                Comment


                • #9
                  Actually it looks like this is happening on 4.8, and never does on 4.9:

                  Nov 28 00:22:13 black kernel: fbcon: amdgpudrmfb (fb0) is primary device
                  Nov 28 00:22:13 black kernel: Console: switching to colour frame buffer device 320x98
                  Nov 28 00:22:13 black kernel: amdgpu 0000:01:00.0: fb0: amdgpudrmfb frame buffer device

                  So, I guess that explains the blank screen.

                  Comment


                  • #10
                    Originally posted by NateHubbard View Post

                    No, I'm assuming KMS is messed up
                    And it was, and it was my fault:

                    "amdgpu 0000:01:00.0: Direct firmware load for amdgpu/tonga_k_smc.bin failed with error -2"

                    "amdgpu 0000:01:00.0: amdgpu_init failed"

                    I said I couldn't find anything in the logs, but I was dumb and wrong. Buried among all the "AMD-Vi: Event logged [" and "IO_PAGE_FAULT device=01:00.0" messages was the error message that I wasn't running new enough firmware, and never again shall I doubt the great kernel gods or trust my distros firmware package.

                    Comment

                    Working...
                    X