Announcement

Collapse
No announcement yet.

Linux 4.9-rc1 Kernel Released Early

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by frosth View Post
    Yes, but it is disable by default. You have to enable SI support manually.
    It won't boot my PC, can't find my root drive...this is odd.
    Please disable CONFIG_MODVERSIONS [1] (It works for me)
    https://git.kernel.org/cgit/linux/ke...273404d2e2a64a

    Comment


    • #12
      blablo, thanks it works

      Comment


      • #13
        Tested with my hd 7850, result same, not working: debian unstable.
        https://www.phoronix.com/forums/foru...404#post903404

        Comment


        • #14
          I think is work only with mesa 12-1 or more, not less.
          But i dont know how compil mesa 12-1 without broke/conflict my system and packages mesa debian.

          Comment


          • #15
            As i said before, ask debianxfce

            Comment


            • #16
              Originally posted by kripteks View Post
              I think is work only with mesa 12-1 or more, not less.
              But i dont know how compil mesa 12-1 without broke/conflict my system and packages mesa debian.
              Classic autogen/configure what you want, make and make install - what else (some prefer ninja, etc... but let alone build alternatives for a moment )... And if you want to revert back do distro mesa then make uninstall that and reinstall distro mesa packages.

              Comment


              • #17
                And padoka is old really, author lag on that currently have 2 weeks old llvm there . If you don't won't to compile llvm too, use those are more up to date:

                http://apt.llvm.org/

                Comment


                • #18
                  Finaly its work with mesa 12-1 git.
                  But performance with glxgears is bad, i go test with game steam, steam cant boot, is say:
                  Couldn't find bootstrap, it's not safe to reset Steam. Please contact technical support.

                  I used this configure:
                  ./configure --enable-gles1 --enable-gles2 --enable-glx-tls --with-egl-platforms=drm,x11 --with-gallium-drivers=radeonsi --enable-texture-float --enable-gbm --enable-dri3 --enable-debug --enable-shared-glapi --with-dri-drivers="" --enable-opencl

                  After make and make install, i have copy/past to /usr/lib/x86_64-linux-gnu startx work, amdgpu load, glxinfo glxheads work fine.

                  I need to recompile for x86_64 and i386 ?
                  I think steam accept only i386 and i386 lib is missing, i dont know how compile target.

                  Comment


                  • #19
                    Originally posted by kripteks View Post
                    performance
                    Revert 87744ab3832b83ba71b931f86f9cfdb000d07da5

                    https://lists.freedesktop.org/archiv...er/002908.html

                    Comment


                    • #20
                      Originally posted by kripteks View Post
                      I need to recompile for x86_64 and i386 ?
                      Yes.

                      Originally posted by kripteks View Post
                      I think steam accept only i386 and i386 lib is missing, i dont know how compile target.
                      Something like this might work to build 32-bit libs:

                      Code:
                      export CFLAGS="$CFLAGS -m32"
                      export CXXFLAGS="$CXXFLAGS -m32"
                      ARCH32=i686-pc-linux-gnu
                      INSTALL32="$PWD/install32"
                      cd build32
                      ../mesa/configure --prefix="$INSTALL32" --build=$ARCH32 --host=$ARCH32 ...
                      cd ..
                      For 64-bit libs: replace "32" with "64" and use ARCH64=x86_64-pc-linux-gnu.

                      Comment

                      Working...
                      X