No announcement yet.

Strange bash problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • Strange bash problem

    I am not sure where this post belongs, so I'll put it here. I am having the darndest problem with getting a PTS comparison done. My post on the Ubuntu forums has not birthed a solution so I am hoping for better luck here.

    Here's the full story: At one point earlier this month (PTS 1.0,) I made a complete download-cache of all of the tests. I downloaded those files on my laptop running Ubuntu 8.04 (32-bit) where they ran fine. I used those files on my "BigBox" machine (AMD dual core 64-bit) where they ran fine. I also used them on my "GamingBox" machine (Intel C2D 64-bit) with my x1950pro 512MB installed where they ran fine. I completed my testing on that machine and swapped out gfx cards for a 7900GS 512MB. For the sake of consistent results, I wrote down all the steps I took in customizing my successful ATI "GamingBox" install including manually installing the latest drivers. I performed those same steps for my Nvidia install...but with different drivers of course Then I installed PTS, copied over the download-cache from my external HDD and ran a successful install-all which installed all of the tests.

    Here's where the problem starts. NONE of the tests that were extracted from *.run files are working. What happens is that when I try to execute certain files, I get the "No such file or directory" error in bash. This happens despite the fact that I used tab completions to insert the file name. Also the files are set to be executable in their permissions and my account is the owner. Here is an example:
    [email protected]:~/.phoronix-test-suite/installed-tests/etqw/data$ ls
    base            etqw-rthread       readme_1_5_patch.txt
    copyrights.txt  etqw-rthread.x86       README.txt
    etqw            etqwtv.txt  sdl.1.2.12.patch
    etqw-dedicated  etqw.x86      server_readme.txt
    etqwded.x86     EULA.txt
    etqw_icon.png       pb
    [email protected]:~/.phoronix-test-suite/installed-tests/etqw/data$ ./etqw-rthread.x86 
    bash: ./etqw-rthread.x86: No such file or directory
    [email protected]:~/.phoronix-test-suite/installed-tests/etqw/data$
    I am also unable to run the *.run files (like even when I chmod +x them. Fyi the md5sum's match. Someone on the Ubuntu Forums suggested that I try executing them in the Live-CD and they worked.

    When I first ran into this problem, I reformatted and reinstalled and I am still getting the same result. I have been using Ubuntu since 5.04 so I'm not a total noob, but I'm still green. Also, I have run into this issue before, but it goes away with time. Any help or suggestions would be greatly appreciated.

    [SOLVED]This problem has been fixed by looking at this page
    Last edited by Max Spain; 06-30-2008, 12:17 AM. Reason: SOLVED