Announcement

Collapse
No announcement yet.

Qt 5.3 Might Depend On SSE2 CPUs

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • sonnet
    replied
    Can anyone pls explain to me what kind of specific advantages it would bring supporting sse2 (or sse3) only cpus?

    Leave a comment:


  • Dukenukemx
    replied
    Originally posted by shaurz View Post
    Time to retire you Athlon XP ;-)
    NEVER!

    Ok, well maybe it's time to upgrade.

    Leave a comment:


  • Vim_User
    replied
    Originally posted by siavashserver
    Did you mean videos with dimensions only a little bigger than a match box ?
    So you know only those two extremes? Your experience must be rather limited then, but it is more likely that you are just a troll.

    I have tried Sabayon, Mint, Ubuntu, Xubuntu, Fedora, Crunchbang and none gave a smooth desktop experience on that machine for kids. Regards to the CPU usage, no matter what software being used (CMUS, Audacity, DeadBeef, GNOME player, VLC, etc). Note that this behavior happens on Windows XP and Windows Media Player too.
    That looks like your hardware isn't configured correctly or just broken.

    In conclusion, when installing modern software on ancient hardware and expecting them to run smoothly, you should be quite ballsy or willing to torture somebody.
    I was only that ballsy, it actually worked without torturing people. Am I a here now for knowing how to configure an OS for a low-spec system? Or is your argumentation just invalid?

    Leave a comment:


  • Guest's Avatar
    Guest replied
    Originally posted by curfew View Post
    The whole article seems rubbish, it's like Michael was completely drunk. Half of the writing is nonsensical gibberish.
    What to expect from troll who's probably sponsored by apple? Now he wants to make flames against Qt.

    Leave a comment:


  • DanL
    replied
    Originally posted by smitty3268 View Post
    Distros can just compile Qt to allow older processors. This only affects people who download the binaries straight from the Qt website.
    If that's true, then this isn't a big deal. Otherwise, requiring SSE2 for 32-bit seems a bit much.

    Leave a comment:


  • Vim_User
    replied
    Originally posted by siavashserver
    Believe it or not, my old Pentium3 750MHz box (bundled with 256MB of memory and an ATI Radeon 7000) is not even capable of running a bare minimum install of Openbox with light weight set of GTK applications smoothly, don't even mention running LXDE, XFCE, etc. CPU usage goes %100 even when only trying to play music and whole system goes nearly unusable. Now you are hoping to run VLC and play HD videos too on these old farts?

    The best use that I have found for that box is a headless (home) FTP server and download manager.
    Sorry, but I never spoke about HD video, so don't put words ion my mouth. I run LXDE (on Salix) on an old Athlon 1.1 GHz, this systems acts as a jukebox for our party room and it works just fine with Audacity and LXDE. Before that I ran LXDE (on Debian) on an old laptop, Celeron 550 Mhz with 256MB of RAM and it also worked just fine, even Youtube videos, thanks to Minitube. If your system is running that sluggish you may have not configured it correctly or are just using a crappy distro.

    Originally posted by pingufunkybeat
    Do these apps use Qt 5?
    I have no doubt that they will transition to Qt5 some time in the future, the same way they have done from Qt3 to Qt4, but in this case with the intention to be Wayland/Mir compatible.

    Leave a comment:


  • cb88
    replied
    Originally posted by siavashserver
    Believe it or not, my old Pentium3 750MHz box (bundled with 256MB of memory and an ATI Radeon 7000) is not even capable of running a bare minimum install of Openbox with light weight set of GTK applications smoothly, don't even mention running LXDE, XFCE, etc. CPU usage goes %100 even when only trying to play music and whole system goes nearly unusable. Now you are hoping to run VLC and play HD videos too on these old farts?

    The best use that I have found for that box is a headless (home) FTP server and download manager.
    That doesnt not sound normal... there is probably something wrong with your board to cause that. I've see such things happen...GPU stick at 100% constantly and reboots on one of my machines I suspect bad caps since it reboots by itself after awhile but it could be irq storming or something and eventually triple faulting etc...

    I've ran openbox, KDE3, e16 etc... on my transmeta crusoe its much slower than your P3 but it still runs fine and though it pegs the CPU alot it doesn't stick there once things are done processing and it play's mp3s and FLAC fine and small avi's okish.

    Leave a comment:


  • pingufunkybeat
    replied
    Originally posted by Vim_User View Post
    Where the hell did you get that info from? So people with older CPUs don't use Razor-Qt or now LXDE-Qt? Also they don't use VLC or other Qt based software?
    You realize that more software than just KDE is using Qt?
    Do these apps use Qt 5?

    Leave a comment:


  • vivo
    replied
    Backwards compatibility is a good thing, but it also slows down progress.
    Anyway, here we are talking about a change in default compiling options, and as was already mentioned, people with non SSE2 CPUs can just recompile, or use a distro that compiles the package without SSE2. Just because Qt decides to use SSE2 by default,it doesn't mean the distributions have to follow upstream.

    Leave a comment:


  • Nille
    replied
    Originally posted by Alliancemd View Post
    People with such old processors don't use new software, so that pretty much doesn't have any negative results.
    Bullshit. Specialy on Linux you are Forced to use new Software on older Systems.

    Leave a comment:

Working...
X