Announcement

Collapse
No announcement yet.

FSF Wastes Away Another "High Priority" Project

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • kwahoo
    replied
    OpenCASCADE is not GPL licensed. BTW http://sourceforge.net/apps/mediawik...?title=Licence

    Leave a comment:


  • uid313
    replied
    Wow

    Wow, it is retarded that LibreDWG is licensed under the GPLv3.

    It ought to be licensed under the LGPL or BSD license.

    This reminds me of the GNU Readline library which is also licensed under the GPL instead of the LGPL which causes pain to free software developers because now it cant be used in projects such as PHP.

    Some of these silly decisions (by RMS, FSF and the GNU project) really harm free software.

    Leave a comment:


  • brosis
    replied
    I am with Stallman on this one, software should be "GPL3+ and later".
    The only difference between GPL2 and GPL3 is tivization exploit fix - a fix to license exploit that allowed to close down the platform, preventing GPL2 freedoms to be used anyway.

    Any developer that prefers "GPL2" over "GPL3" essentially needs that exploit and wants to produce closed source product.

    In this case, these people should really use BSD license instead.

    Originally posted by uid313 View Post
    Some of these silly decisions (by RMS, FSF and the GNU project) really harm free software.
    It is vice versa.
    People that use freedom granting license refuse to actually provide these freedoms, because their scheme is based on exploitation of the older version of the license.
    Last edited by brosis; 01-24-2013, 11:23 AM.

    Leave a comment:

Working...
X