Announcement

Collapse
No announcement yet.

KLANG: A New Linux Audio System For The Kernel

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • I would be content for ALSA to just properly set the volume on my devices. Every single one of my machines (PC and Mac) have weirdly screwed up output levels running in Linux relative to Windows or OS X. My current X1 Carbon Gen 3 is much, much quieter at max volume via the build-in speakers when running Kubuntu 15.04 or Fedora 22 or Antergos. I've made sure that all the ALSA mixer levels are maxed out and that the PulseAudio levels are maxed out, and despite that I can't get the same useful volume levels out of the machine in Linux.

    It drives me nuts. I paved the machine and put Windows back on it and used an SPL meter playing a variety of sources (Hulu, Google Play, Clementine, and VLC) just to verify. I don't know what the problem is, but it's thoroughly aggravating.

    Comment


    • WIN and OSX probably artificially turn up the loudness over 100%
      play a sine at full loudness and hear if its clipping
      (VLC and afaik PA can do it)
      or worse they could be flattening the dynamic range to make it, on avg, louder

      otherwise it could be the sound card driver (also if there is a separate amp control)

      did you try googling that laptop/sound_card/driver ?

      Comment


      • I'm sure that the audio isn't being overdriven by default in Windows on this hardware because there's no clipping happening, and I can make Windows overdrive the volume via EQ controls or just having things like VLC "boost" the volume on their own... in which case I definitely hear the distortion.

        It very well could be a driver issue since this thing has an ALC3232 and I can barely find any information on it, nor any particular support for it in ALSA. That said, the same is true of the ALC3263 in the XPS 13 9343 sitting here next to the X1 Carbon, and yet it's somehow significantly louder in Linux than the X1, but in Windows they're barely different (the X1 being only slightly worse due primarily to its downward firing speakers).

        I've tried everything I can find, but the world of Linux audio is such a colossal mess of onion layers and pitiful to non-existent documentation that I can't ever be sure if where I'm looking is in the right place or if what I'm screwing around with should have any effect whatsoever.

        Comment


        • Originally posted by Nathan_A View Post
          I've tried everything I can find, but the world of Linux audio is such a colossal mess of onion layers and pitiful to non-existent documentation that I can't ever be sure if where I'm looking is in the right place or if what I'm screwing around with should have any effect whatsoever.
          well, alsa is fairly simple
          the complete and utter lack of documentation makes it seem complicated

          since realtek usually has good OSS drivers, my best guess would be that lenovo is doing something

          just to be sure, you maxed out "Master" and "PCM" in alsamixer ?

          Comment


          • Originally posted by Nathan_A View Post
            I would be content for ALSA to just properly set the volume on my devices. Every single one of my machines (PC and Mac) have weirdly screwed up output levels running in Linux relative to Windows or OS X. My current X1 Carbon Gen 3 is much, much quieter at max volume via the build-in speakers when running Kubuntu 15.04 or Fedora 22 or Antergos.
            Reading around online, that seems to be just a config setting in ALSA that's the issue, not pulse.

            Not everytime your audio breaks it is alone PulseAudio's fault. For example, the original flame of Jeffrey's was about the low volume that he experienced when running PA. This is mostly due to the suckish way we initialize the default volumes of ALSA sound cards. Most distributions have simple scripts that initialize ALSA sound card volumes to fixed values like 75% of the available range, without understanding what the range or the controls actually mean. This is actually a very bad thing to do. Integrated USB speakers for example tend export the full amplification range via the mixer controls. 75% for them is incredibly loud. For other hardware (like apparently Jeffrey's) it is too low in volume. How to fix this has been discussed on the ALSA mailing list, but no final solution has been presented yet. Nonetheless, the fact that the volume was too low, is completely unrelated to PulseAudio.

            Comment


            • Originally posted by gens View Post
              just to be sure, you maxed out "Master" and "PCM" in alsamixer ?
              Correct. Master, Speaker, and PCM are all maxed out. The KMix volume controls appear to adjust Master until the bottom 5 and 10% where it also lowers Speaker.

              Comment


              • Originally posted by profoundWHALE View Post

                Reading around online, that seems to be just a config setting in ALSA that's the issue, not pulse.
                First, I wasn't blaming Pulse. Second, that link contains nothing that points at a solution to this problem. Was it supposed to?

                Comment


                • I'm interested on how to implement audio hardware acceleration ...

                  Comment


                  • Originally posted by profoundWHALE View Post
                    Not everytime your audio breaks it is alone PulseAudio's fault.
                    just most of the time
                    also "alone"...

                    Comment


                    • Originally posted by Nathan_A View Post

                      First, I wasn't blaming Pulse. Second, that link contains nothing that points at a solution to this problem. Was it supposed to?
                      To up your volume use pactl set-sink-volume. This will let you increase the volume almost arbitrarily (obviously no higher than the speakers' ratings for safety). Keep in mind, the more you amp it the more distortion.

                      Comment

                      Working...
                      X