No announcement yet.

zcache for 2.6.38

  • Filter
  • Time
  • Show
Clear All
new posts

  • zcache for 2.6.38

    Hi guys,

    those who want to test out the new zcache today:

    zcache + fixes + make btrfs work and tweaks & improvements to zram (included in 2.6.39)

    to be applied on top of*

    zcache_2.6.38.3_zen.txt (154.26 KB)

    403f93e253cd01efea186a0da939960f zcache_2.6.38.3_zen.txt

    Enjoy !

    to enable it you need to append zcache to your kernel in grub.conf, lilo.conf, etc.

  • #2
    is it in fedora 14 kernel too ?
    can you be more verbose about files to edit also , i am a newbie ;']


    • #3
      Originally posted by jcgeny View Post
      is it in fedora 14 kernel too ?
      can you be more verbose about files to edit also , i am a newbie ;']
      everything is in the patch

      no, afaik it's not included yet

      zcache just got into 2.6.39, cleancache (essential) and frontswap are still missing from it

      so most likely it will be first fully available with 2.6.40

      you clone the kernel from the zen-kernel git-repo or download a tarball (snapshot)

      then apply the patch

      and enable zram, zcache, cleancache & frontswap in the config

      after that you need to build a rpm-package (manually installing a kernel in fedora is a not so good idea)

      after it has finished: install it and boot it:

      at boot / grub.conf you need to append "zcache"

      without the "" signs


      • #4
        Hello kernelOfTruth,

        As you seem to be kind of an expert:

        I applied your patch to the vanilla, enabled everything and added "zcache" to my kernel parameters. But after rebooting, statistics in /sys/kernel/mm/ show that neither cleancache nor frontswap are ever used. /sys/kernel/mm/zcache is not even there. Is there anything missing from the vanilla kernel that frontswap, cleancache or zcache require?

        I tried zcache both in-kernel and as a module.

        And now that zcache is included in 2.6.39, are there patches for frontswap and cleancache that can be applied to that kernel? I tried the latest ones from lkml but some hunks failed. I then tried to apply them manually but ran into trouble in swapfile.c.


        • #5
          yeah, this has been sort of a "known" problem:

          make sure you activate:

          - zram (which zcache and/or cleancache is dependent on)
          - zcache
          - cleancache
          - frontswap

          it's still somewhat in the flux ...

          ... so if you can't get zcache to work with 2.6.39 even after having corrected the rejects

          then please contact Dan Magenheimer & Nitin Gupta (the two developers of it)

          thanks !