Announcement

Collapse
No announcement yet.

AppArmor Is Going Into The Linux 2.6.36 Kernel

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • V!NCENT
    replied
    Originally posted by RahulSundaram View Post
    Hi

    If you run setenforce 0 and it is still not working, then the problem doesn't have anything to do with SELinux as I pointed out. As the blog describes, certain protections needs to be toggled off for Wine apps to work in some cases but wine bugs themselves are offtopic for this discussion.
    Like I said Wine stubs are the only problem remaining so it worked

    Leave a comment:


  • RahulSundaram
    replied
    Hi

    If you run setenforce 0 and it is still not working, then the problem doesn't have anything to do with SELinux as I pointed out. As the blog describes, certain protections needs to be toggled off for Wine apps to work in some cases but wine bugs themselves are offtopic for this discussion.

    Leave a comment:


  • V!NCENT
    replied
    Originally posted by RahulSundaram View Post
    Hi,

    You have to make the right booleans are toggled. Refer to

    http://danwalsh.livejournal.com/37067.html

    A quick way to check whether it is SELinux blocking it or not is to run setenforce 0 which sets it to permissive mode and see if it works.
    SELinux stopped 'whining' already, but I set the setenforce 0 anyway since I am not on the USA most wanted list or anything xD

    Steam is still not running but it keeps complaining about winbind and some unsupported stuff. I installed all the samba stuff and now the only errors I get are Wine related stubs.

    Thanks for the help

    Leave a comment:


  • RahulSundaram
    replied
    Hi,

    You have to make the right booleans are toggled. Refer to

    http://danwalsh.livejournal.com/37067.html

    A quick way to check whether it is SELinux blocking it or not is to run setenforce 0 which sets it to permissive mode and see if it works.

    Leave a comment:


  • V!NCENT
    replied
    Originally posted by RahulSundaram View Post
    That appears be a Wine issue. Nothing to do with SELinux. Report a bug upstream.
    Realy? SELinux is still whining.
    [[email protected] vincent]# /sbin/restorecon '/home/vincent/.wine/drive_c/Program Files/Steam/bin/p2pvoice.dll'
    [[email protected] vincent]# chcon -t textrel_shlib_t '/home/vincent/.wine/drive_c/Program Files/Steam/bin/SteamService.dll'
    [[email protected] vincent]# chcon -t textrel_shlib_t '/home/vincent/.wine/drive_c/Program Files/Steam/bin/p2pvoice.dll'
    [[email protected] vincent]# chcon -t textrel_shlib_t '/home/vincent/.wine/drive_c/Program Files/Steam/bin/p2pvoice.dll'
    [[email protected] vincent]# /sbin/restorecon '/home/vincent/.wine/drive_c/Program Files/Steam/bin/mss32_s.dll'
    [[email protected] vincent]# chcon -t textrel_shlib_t '/home/vincent/.wine/drive_c/Program Files/Steam/bin/mss32_s.dll'
    Will post when this shit train ends

    Leave a comment:


  • RahulSundaram
    replied
    Originally posted by V!NCENT View Post
    Did exactly that. Steam installs but doesn't run.
    Code:
    wine: cannot find L"C:\\windows\\system32\\wineboot.exe"
    err:process:start_wineboot failed to start wineboot, err 2
    CellID: Fetching server list from CSDS. . .
    fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
    [B]err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
    err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.[/B]
    Not exactly working here.
    That appears be a Wine issue. Nothing to do with SELinux. Report a bug upstream.

    Leave a comment:


  • V!NCENT
    replied
    Originally posted by RahulSundaram View Post
    Fedora 13, 64-bit release. yum install wine. Turn off the boolean in SELinux via SELinux troubleshooter. Just point and click. Installation via Wine works just fine. Just tried yesterday.
    Did exactly that. Steam installs but doesn't run.
    Code:
    wine: cannot find L"C:\\windows\\system32\\wineboot.exe"
    err:process:start_wineboot failed to start wineboot, err 2
    CellID: Fetching server list from CSDS. . .
    fixme:process:SetProcessShutdownParameters (00000100, 00000000): partial stub.
    [B]err:ntlm:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path.
    err:ntlm:SECUR32_initNTLMSP Usually, you can find it in the winbind package of your distribution.[/B]
    Not exactly working here.

    Leave a comment:


  • RahulSundaram
    replied
    Originally posted by V!NCENT View Post

    Okey fine. You realy want to see that dansing rapport, I mean play some game and you feel like lowering security is OK so you take of your tinfoil hat and execute that command as root.

    You go back to the terminal and launch that game you have been desperately wanting to play for your entire life.

    Not very much planctime passes before Wine crashes... again! Pissed of as you are you are going to Google it.

    It being:
    "wine: cannot find L"C:\\windows\\system32\\wineboot.exe"

    You find out that, althought the previous error message you got, Wine 64bit, being installed when you yum install wine on 64bit images of Fedora, doesn't link to /usr/bin/wine for some wierd reason.

    Fantastic. Althought by reproducing it again I found the workaround on Google now. So....

    Fedora 13, 64-bit release. yum install wine. Turn off the boolean in SELinux via SELinux troubleshooter. Just point and click. Installation via Wine works just fine. Just tried yesterday.

    Leave a comment:


  • V!NCENT
    replied
    Originally posted by movieman View Post
    I've been trying to understand what you're saying, but it appears to be gibberish.
    Latest Fedora instal. Wine from Fedora respository installed. Steam installer for Windows.

    You install Wine and all of it's own apps like notepad and regedit work just fine. But then you decide to install a game and run it.

    SELinux pops up, saying that it has denied Wine to acces some lower level (RING) memmory and Wine crashes.

    The SELinux reports tells you how unfortunate this is and that you can grant Wine access if you losen up the permissions with some kind of command. It warns you though that there might also have been some potential malware, disguising itself as Wine that wanted to have lower level memory acces (OR SOMETHING).

    Okey fine. You realy want to see that dansing rapport, I mean play some game and you feel like lowering security is OK so you take of your tinfoil hat and execute that command as root.

    You go back to the terminal and launch that game you have been desperately wanting to play for your entire life.

    Not very much planctime passes before Wine crashes... again! Pissed of as you are you are going to Google it.

    It being:
    "wine: cannot find L"C:\\windows\\system32\\wineboot.exe"

    You find out that, althought the previous error message you got, Wine 64bit, being installed when you yum install wine on 64bit images of Fedora, doesn't link to /usr/bin/wine for some wierd reason.

    Fantastic. Althought by reproducing it again I found the workaround on Google now. So....

    Leave a comment:


  • movieman
    replied
    Originally posted by V!NCENT View Post
    And the lower level access to RAM, which is blocked and in turn makes it useless to run Wine. But not that that matters because Wine does not work by default on 64bit images (some linker crap, don't know the details).
    I've been trying to understand what you're saying, but it appears to be gibberish.

    Leave a comment:

Working...
X