Announcement

Collapse
No announcement yet.

Linux On The Apple M1 Can Now Boot To The GNOME Desktop But Lacking Acceleration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux On The Apple M1 Can Now Boot To The GNOME Desktop But Lacking Acceleration

    Phoronix: Linux On The Apple M1 Can Now Boot To The GNOME Desktop But Lacking Acceleration

    Running Linux on the Apple M1 with various out-of-tree patches is now capable of booting to a GNOME desktop albeit lacking any OpenGL/graphics acceleration...

    https://www.phoronix.com/scan.php?pa...M1-Boots-GNOME

  • #2
    On a side note, Plasma Wayland and Weston have options to force software rendering if no drm driver is available or if hardware acceleration is problematic. This allows the GUI to still run at full performance as opposed to being a 1fps shitshow under software OpenGL rendering with llvmpipe.

    Is there any such option for Gnome Wayland? If there isn't there really should be for obvious reasons.

    Comment


    • #3
      Maybe the effort of making an OpenGL driver can be skipped by "only" making a Vulkan driver an running Zink on top?

      Comment


      • #4
        Originally posted by Sonadow View Post
        On a side note, Plasma Wayland and Weston have options to force software rendering if no drm driver is available or if hardware acceleration is problematic. --

        Is there any such option for Gnome Wayland? If there isn't there really should be for obvious reasons.
        Sorry, but I fail to spot any obvious reasons. Accommodating for broken shit drivers/hardware is a bit of thing of the past by now. Personally I also don't see any reason for why every single DE should cater to this particular user base.

        Comment


        • #5
          Originally posted by Sonadow View Post
          On a side note, Plasma Wayland and Weston have options to force software rendering if no drm driver is available or if hardware acceleration is problematic. This allows the GUI to still run at full performance as opposed to being a 1fps shitshow under software OpenGL rendering with llvmpipe.
          there's pixman-based software renderer for swaywm, should be very fast as well

          Comment


          • #6
            Originally posted by curfew View Post
            Sorry, but I fail to spot any obvious reasons. Accommodating for broken shit drivers/hardware is a bit of thing of the past by now. Personally I also don't see any reason for why every single DE should cater to this particular user base.
            Because Plasma Wayland on a laptop with Nvidia graphics and the Nouveau driver produces a broken GUI with rainbow colours. If not for software rendering I would be typing this on Windows right now.Fuck that "broken/shit drivers are a thing of the past" bullshit.

            Way to be shortsighted.

            Comment


            • #7
              Originally posted by Sonadow View Post
              Because Plasma Wayland on a laptop with Nvidia graphics and the Nouveau driver produces a broken GUI with rainbow colours. If not for software rendering I would be typing this on Windows right now.
              Why on Windows? The nVidia driver also didn't work?

              Comment


              • #8
                The huge work those guys are doin' is amazing. I truly believe we will soon be able to run some brilliant distributions on M1 chips, thanks to all people involved into this.
                So many times we forgot the value any contributions to the FOSS have, but truth is every year we can run our PC/laptops equipped with shiny new hardware peripherals and updated applications thanks to the free contribution of many users, each one with their huge or normal skills.
                We should always work together, not shoot each other.

                Comment


                • #9
                  Originally posted by Black_Fox View Post

                  Why on Windows? The nVidia driver also didn't work?
                  It won't work with the git version of libdrm and 5.14rc6

                  Besides, I don't want to use the Nvidia driver.

                  Comment


                  • #10
                    Originally posted by Sonadow View Post

                    It won't work with the git version of libdrm and 5.14rc6

                    Besides, I don't want to use the Nvidia driver.
                    Just out of curiosity, which driver would you be using under Windows? Nouveau?

                    Comment

                    Working...
                    X