Announcement

Collapse
No announcement yet.

Linux 5.12 Released With Intel Xe Variable Rate Refresh, Clang LTO, KFENCE + More

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 5.12 Released With Intel Xe Variable Rate Refresh, Clang LTO, KFENCE + More

    Phoronix: Linux 5.12 Released With Intel Xe Variable Rate Refresh, Clang LTO, KFENCE + More

    After a week delay, the Linux 5.12 kernel was just released as stable...

    https://www.phoronix.com/scan.php?pa...-5.12-Released

  • #2
    Clang link-time optimizations
    Maybe I'm out of the loop, but does this mean there are no issues building the kernel with Clang? I thought only GCC was really supported.

    Comment


    • #3
      Originally posted by OpenSourceAnarchist View Post
      Maybe I'm out of the loop, but does this mean there are no issues building the kernel with Clang? I thought only GCC was really supported.
      Android has been using Linux kernel compiled with Clang for years now. Upstream support is relatively new, a couple of months or so.

      Comment


      • #4
        So Intel doesn't even have their graphics cards out yet and they have adaptive sync, but yet my video card from another vendor is just finally getting it after many years.

        Comment


        • #5
          On Ubuntu, the mainline monkey compiled the kernel-headers to require Hirsute/21.04 for this kernel.

          sudo dpkg -i linux-headers-5.12.0-051200-generic_5.12.0-051200.202104252130_amd64.deb

          Selecting previously unselected package linux-headers-5.12.0-051200-generic.
          (Reading database ... 377419 files and directories currently installed.)
          Preparing to unpack linux-headers-5.12.0-051200-generic_5.12.0-051200.202104252130_amd64.deb ...
          Unpacking linux-headers-5.12.0-051200-generic (5.12.0-051200.202104252130) ...

          dpkg: dependency problems prevent configuration of linux-headers-5.12.0-051200-generic:

          linux-headers-5.12.0-051200-generic depends on libc6 (>= 2.33); however:

          Version of libc6:amd64 on system is 2.31-0ubuntu9.2.

          dpkg: error processing package linux-headers-5.12.0-051200-generic (--install):
          dependency problems - leaving unconfigured
          Errors were encountered while processing:
          linux-headers-5.12.0-051200-generic


          One day, I'll stop installing dot zeros.

          Comment


          • #6
            I'd love to see Paragon's NTFS replace the old driver
            As far as I know PATCHv26 has been sitting in the mailing list since April 4

            Comment


            • #7
              Originally posted by ThoreauHD View Post
              linux-headers-5.12.0-051200-generic depends on libc6 (>= 2.33); however:
              Version of libc6:amd64 on system is 2.31-0ubuntu9.2.

              One day, I'll stop installing dot zeros.
              As you can see the problem is not about dot zero but the packager's mistake. They have to first publish libc6's 2.33 then this must be published.
              So all you have to wait for a little until your repo will get libc6's more recent version

              Comment


              • #8
                Does this release contain the the bits needed to operate both the Intel iGPU and the Xe dGPU together, without resorting to VM trickery?

                Comment


                • #9
                  Originally posted by ThoreauHD View Post
                  On Ubuntu, the mainline monkey compiled the kernel-headers to require Hirsute/21.04 for this kernel.

                  sudo dpkg -i linux-headers-5.12.0-051200-generic_5.12.0-051200.202104252130_amd64.deb

                  Selecting previously unselected package linux-headers-5.12.0-051200-generic.
                  (Reading database ... 377419 files and directories currently installed.)
                  Preparing to unpack linux-headers-5.12.0-051200-generic_5.12.0-051200.202104252130_amd64.deb ...
                  Unpacking linux-headers-5.12.0-051200-generic (5.12.0-051200.202104252130) ...

                  dpkg: dependency problems prevent configuration of linux-headers-5.12.0-051200-generic:

                  linux-headers-5.12.0-051200-generic depends on libc6 (>= 2.33); however:

                  Version of libc6:amd64 on system is 2.31-0ubuntu9.2.

                  dpkg: error processing package linux-headers-5.12.0-051200-generic (--install):
                  dependency problems - leaving unconfigured
                  Errors were encountered while processing:
                  linux-headers-5.12.0-051200-generic


                  One day, I'll stop installing dot zeros.
                  In the time needed to complain you could have already built one for yourself using the older distribution's compilers.

                  Comment


                  • #10
                    Originally posted by jpegxguy View Post
                    I'd love to see Paragon's NTFS replace the old driver
                    As far as I know PATCHv26 has been sitting in the mailing list since April 4
                    I mean the driver is still buggy (broken inodes? I don't know how to call it), which does not happen on the proprietary UFSD NTFS driver made by them, so I guess the kernel people at least wants that kind of quality before merging it into tree.

                    ---

                    Also I don't see signs of 5.12.0 on kernel.org, which made me really confused


                    There's also no signs of 5.12.0 builds on Fedora Bodhi

                    Last edited by rmnscnce; 25 April 2021, 10:28 PM.

                    Comment

                    Working...
                    X