Announcement

Collapse
No announcement yet.

Linux 5.11 Released With Intel Integer Scaling, AMD Performance Boost, RTX 30 KMS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by reba View Post
    As a Debian user I also get flak ("SJW", "Why not Gentoo, Arch or NixOS? They're so much nerdier" - yes they are, I'm just too dumb and too lazy) and as a vivid fan of KDE even more...
    how is that level of retrocomputing not the nerdier option? it's like using Windows 98 or a Commodore 64.

    Comment


    • #32
      Originally posted by hotaru View Post

      how is that level of retrocomputing not the nerdier option? it's like using Windows 98 or a Commodore 64.
      Well, you got me there

      I prefer the look of Windows 9x (bare bones but very good readability and with a quick glimpse you "get" how the UI is working, how the elements are arranged and nested) over the look of XP (too childish and big) and massively over Windows 10 (no clear indication of buttons, labels, areas or even the extents of whole windows).
      I also prefer true menus to hamburger menus or these terrible, terrible ribbon menus.

      Yeah, I'm so oldschool I experienced Amiga's bootsector intros first-hand and my dad put a hardware switch on the backside to select either Kickstart 1.2 or Kickstart 1.3. I wonder if our '83 Commodore 1541 (rainbow logo and spring load) still works...
      Last edited by reba; 17 February 2021, 07:58 AM.

      Comment


      • #33
        perpetually high

        Code:
        apt-cache policy virtualbox-6.1
        virtualbox-6.1:
        Installed: 6.1.18-142142~Ubuntu~eoan
        Candidate: 6.1.18-142142~Ubuntu~eoan
        Version table:
        *** 6.1.18-142142~Ubuntu~eoan 500
        500 https://download.virtualbox.org/virtualbox/debian focal/contrib amd64 Packages
        100 /var/lib/dpkg/status
        Code:
        cat /etc/apt/sources.list.d/virtualbox.list
        # Virtualbox
        deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian focal contrib
        This is what i currently use for Ubuntu 20.04 and linux-5.10.16 kernel.

        Ubuntu 20.04 is currently at 6.1.16, from the changelog i think this has "ubuntu patches" so that it currently works with 5.10.x ref.
        https://ubuntu.pkgs.org/20.04/ubuntu...amd64.deb.html
        Code:
        2020-12-04 - Gianfranco Costamagna <[email protected]> virtualbox (6.1.16-dfsg-6) unstable; urgency=medium * debian/patches/linux-5.10-r0drv-memobj-fix-r0.patch: - upstream-proposed patch to fix a build failure with linux 5.10 (LP: #1903741)

        Comment


        • #34
          Cybmax

          Hey, thanks for taking the time to share that. I just tried again from that apt repository (using both virtualbox and virtualbox-6.1 packages) and still no go.

          I even tried the latest 5.10.17 from kernel.ubuntu.com to remove my custom kernel from the equation and still no go. Really not sure why it's working for some, but I appreciate again you sharing the info. Cheers to you, reba and hotaru for your input on the vbox situation. I'll just wait it out for now and stay with 5.4, and skip 5.10 altogether and wait for 5.11 support.

          Comment


          • #35
            perpetually high
            Could you perhaps take a look at https://www.virtualbox.org/ticket/20055 and see if any of those patches are NOT included in your 6.1.18 version?

            The kernel driver source is (for me on Ubuntu) located in
            Code:
            /usr/share/virtualbox/src/vboxhost/vboxdrv/r0drv/linux
            other distro's might have different placements of the source tho.

            I also patched the 6.1.18 vbox netdriver so for me it now works with linux-5.11 aswell - Ref. https://www.virtualbox.org/ticket/20198

            Comment


            • #36
              Guys, apologies are in order! reba hotaru Cybmax

              It was, in fact, an Ubuntu problem. (in addition to using kernel 5.10+)

              I went into the log file and started digging around and came across this GitHub thread unrelated to VirtualBox.

              Big thanks to this dude:



              And sure enough, it worked on 5.10 and 5.11 after I did this

              $ sudo su
              $ wget https://raw.githubusercontent.com/to...s/module.lds.S -O /usr/src/linux-headers-5.11.10-051110+custom-generic/scripts/module.lds
              $ sed -i '$ d' /usr/src/linux-headers-5.11.10-051110+custom-generic/scripts/module.lds
              $ /sbin/vboxconfig
              $ exit

              For those on Ubuntu, the above is what I used for my custom 5.11 build, if you're on Ubuntu and would like to use VirtualBox with kernel 5.10 or higher, use uname -a to find out your current kernel version and replace it with the above. This may be fixed in a future version of Ubuntu, but this is as of March 2021 using Ubuntu 20.04.2

              EDIT: looks like as of April 7, the module.lds.S from torvalds/master now has the following conditional block that breaks it:

              #ifdef CONFIG_LTO_CLANG
              #endif

              Removing the above two lines only lets the code in the conditional block execute, allowing VirtualBox to build again. I bet more people aren't running into this problem since most aren't running a custom kernel on 20.04, which comes with 5.4. But for those that are running 5.10+ higher, this is how you get VirtualBox to work. To minimize the effort involved, just keep a good copy of module.lds.S (without the two lines above) and automate it with a script to drop it in /usr/src/linux-headers-your-version/scripts/module.lds after you build your kernel. Lotta effort I know, but worth it because 20.04 LTS is solid for a daily driver. Hope this helps someone.
              Last edited by perpetually high; 07 April 2021, 01:40 PM.

              Comment


              • #37
                Originally posted by perpetually high View Post
                It was, in fact, an Ubuntu problem. (in addition to using kernel 5.10+)
                Great to hear you got it working!

                Cheers

                Comment

                Working...
                X