Announcement

Collapse
No announcement yet.

Linux 5.9.12 Is In Good Shape With The AMD Radeon RX 6800 Series

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 5.9.12 Is In Good Shape With The AMD Radeon RX 6800 Series

    Phoronix: Linux 5.9.12 Is In Good Shape With The AMD Radeon RX 6800 Series

    With my testing of the Radeon RX 6800 series graphics cards last month it's been off Linux 5.10 (aside from when using the Radeon Software for Linux package driver) due to the Linux Git state often offering the best performance and features particularly for brand new hardware. As mentioned in the launch day article for the RX 6800 / RX 6800 XT, there was also an issue being encountered on Linux 5.9. Fortunately, that bug is indeed fixed with the recently released Linux 5.9.12 kernel...

    http://www.phoronix.com/scan.php?pag...Radeon-RX-6800

  • #2
    Linux still in awfull shape with RX 5700 series more than 1.5 years.

    Comment


    • #3
      Just tried xanmod 5.9.12 and it still blackscreens me with my 6800xt card. Back to 5.10rc6.

      Comment


      • #4
        With Arch Linux, I do not need linux-firmware-git anymore since version 20201120.bc9cd0b-1 for my 6800XT.

        Comment


        • #5
          Going to try so hard to buy an RX 6900 XT, seems like stock is limited like crazy

          Comment


          • #6
            I have a 6800 on on Arch Linux with 5.10rc6, latest linux-firmware and mesa 20.2.
            When running Steam (installed via flatpak) I get the following error:
            "radeonsi: GFX 10.3 requires LLVM 11 or higher"

            Not sure if it is because I'm using flatpak, or something else.

            Comment


            • #7
              Originally posted by SyXbiT View Post
              I have a 6800 on on Arch Linux with 5.10rc6, latest linux-firmware and mesa 20.2.
              When running Steam (installed via flatpak) I get the following error:
              "radeonsi: GFX 10.3 requires LLVM 11 or higher"

              Not sure if it is because I'm using flatpak, or something else.
              It seems that you run the amdgpu driver from AMD. You should tried the radeon driver, it works fine.

              Comment


              • #8
                Originally posted by santoniuk View Post
                Linux still in awfull shape with RX 5700 series more than 1.5 years.
                Can you please elaborate?

                Comment


                • #9
                  Originally posted by Crashone View Post
                  It seems that you run the amdgpu driver from AMD. You should tried the radeon driver, it works fine.
                  AFAIK we build Mesa with LLVM 11 in the packaged drivers as well - it is required for GFX 10.3.

                  Sounds like either the flatpak is bringing in an older Mesa build or Arch is building 20.2 with an older LLVM. The former seems more likely.

                  BTW the radeon driver does not support anything newer than CI (GFX7) - amdgpu (whether upstream or packaged) is the only driver with support for VI (gfx8) and newer.
                  Last edited by bridgman; 07 December 2020, 11:12 AM.

                  Comment


                  • #10
                    Originally posted by bridgman View Post

                    AFAIK we build Mesa with LLVM 11 in the packaged drivers as well - it is required for GFX 10.3.

                    Sounds like either the flatpak is bringing in an older Mesa build or Arch is building 20.2 with an older LLVM. The former seems more likely.
                    You are right. I didn't know that the Steam's Flatpak package included its own version of Mesa.

                    Comment

                    Working...
                    X