Announcement

Collapse
No announcement yet.

Linux 5.2-rc7 Is Quiet & Released On A Boat Somewhere

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by tildearrow View Post
    Except for the fact that sometimes it takes 2 minutes to shut down your computer for no reason by default
    The reason is clearly stated when you take time to read the console messages:
    some process isn't immediately quitting and systemd is giving 2 minute extra delay before force-killing it, in case it's just busy saving stuff before shutting down
    (some heavy applications can actually indeed take more than 10 second at teardown time)
    (but most of the time this is mostly due to the distributions being only sloppily integrated with systemd and the stopping of services simply not done correctly: there are left over processes)
    (or you're just clumsy and left a forgotten "autossh" which is still trying to spawn sessions in a loop).

    Comment


    • #12
      Originally posted by DrYak View Post

      The reason is clearly stated when you take time to read the console messages:
      some process isn't immediately quitting and systemd is giving 2 minute extra delay before force-killing it, in case it's just busy saving stuff before shutting down
      (some heavy applications can actually indeed take more than 10 second at teardown time)
      (but most of the time this is mostly due to the distributions being only sloppily integrated with systemd and the stopping of services simply not done correctly: there are left over processes)
      (or you're just clumsy and left a forgotten "autossh" which is still trying to spawn sessions in a loop).
      I think they didn't do it that well: 2 minutes are just too much for a PC, especially in modern days with SSDs and all. I perfectly understand that it may be important for a server, so please note that I'm not complaining about the default behavior. I edit settings to change default timeout to 20s, but it's not a full global settings, so I've to analyse every service taking 2 minutes and edit its specific settings.
      Last edited by Buntolo; 07-11-2019, 02:44 AM.

      Comment


      • #13
        Originally posted by Buntolo View Post
        I think they did'nt do it that well
        Well, perhaps your distro was overboard paranoid (CentOS? Ubuntu? Debian?)

        You can list units with their own local Timeouts with:

        Code:
        grep -RP 'Timeout.*=[[:space:]]*[[:digit:]]+' /usr/lib/systemd/system/
        Global change is in:
        Code:
        grep -iR 'timeout' /etc/systemd
        My distro (tumbleweed) only has excessively long timeouts on task that might take some time (databases such as mysql and maria: they might be mid-way through a backup replication or journal replay or vacuuming or something when the shut down happens).
        Most of the units follow global.

        Comment


        • #14
          Originally posted by DrYak View Post

          Well, perhaps your distro was overboard paranoid (CentOS? Ubuntu? Debian?)

          You can list units with their own local Timeouts with:

          Code:
          grep -RP 'Timeout.*=[[:space:]]*[[:digit:]]+' /usr/lib/systemd/system/
          Global change is in:
          Code:
          grep -iR 'timeout' /etc/systemd
          My distro (tumbleweed) only has excessively long timeouts on task that might take some time (databases such as mysql and maria: they might be mid-way through a backup replication or journal replay or vacuuming or something when the shut down happens).
          Most of the units follow global.
          I perfectly understand the importance of long timeouts, I just think that a global timeout should REALLY be a global timeout, overriding everyone else.

          Comment

          Working...
          X