Announcement

Collapse
No announcement yet.

Linux 5.1-rc4 Released - The Kernel Is Looking Good At Its Half-Way Point

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux 5.1-rc4 Released - The Kernel Is Looking Good At Its Half-Way Point

    Phoronix: Linux 5.1-rc4 Released - The Kernel Is Looking Good At Its Half-Way Point

    Linus Torvalds just announced the release of Linux 5.1-rc4 a few minutes ago as the latest weekly release candidate and just a few weeks out from the stable Linux 5.1 debut...

    http://www.phoronix.com/scan.php?pag...1-rc4-Released

  • #2
    The worrying thing is that at each new version of the kernel a warning is added at boot time. Instead of decreasing the warnings increase and this is not good.

    Comment


    • #3
      Originally posted by Charlie68 View Post
      The worrying thing is that at each new version of the kernel a warning is added at boot time. Instead of decreasing the warnings increase and this is not good.
      rc kernels are development kernels. Warnings will decrease when the final version is released. Use a non debug kernel to minimize kernel messages.

      Comment


      • #4
        Originally posted by debianxfce View Post

        rc kernels are development kernels. Warnings will decrease when the final version is released. Use a non debug kernel to minimize kernel messages.
        I wasn't referring to kernel 5.1, I was referring to the last stable kernels, which increased warnings messages at boot time and at each new version instead of decreasing they increase.

        Comment


        • #5
          Originally posted by Charlie68 View Post

          I wasn't referring to kernel 5.1, I was referring to the last stable kernels, which increased warnings messages at boot time and at each new version instead of decreasing they increase.
          Configure the kernel to match your hardware and other kernel settings. For example, I have Cpu frequency scaling disabled but had ACPI Processor enabled and then there is a stupid warning: "Consider compiling the cpu frequency governor". Disabling ACPI Processor removes the message. I have a clean boot.

          Comment


          • #6
            The kernel 5 was a disaster for me, on my acer aspire E1-522 AMD notebook.
            Among the messages :
            do_IRQ: 1.55 No irq handler for vector
            [ 0.005472] do_IRQ: 2.55 No irq handler for vector
            [ 0.005472] do_IRQ: 3.55 No irq handler for vector
            Couldn't get size: 0x800000000000000e
            [ 6.736514] MODSIGN: Couldn't get UEFI db list
            [ 6.736727] Couldn't get size: 0x800000000000000e
            acpi PNP0C14:01: duplicate WMI GUID 05901221-D566-11D1-B2F0-00A0C9062910 (first i
            nstance was on PNP0C14:00)
            16.483775] systemd[1]: nss-lookup.target: Dependency Before=nss-lookup.target dropped
            ACPI Warning: SystemIO range 0x0000000000000B00-0x0000000000000B08 conflicts with
            OpRegion 0x0000000000000B00-0x0000000000000B0F (\_SB.PCI0.SMBS.SMB0) (20181213/utaddress-213)
            wdat_wdt wdat_wdt: can't request region for resource [mem 0xfec000f0-0xfec000f3]
            The only thing I can do is run a distribution that uses an old kernel, such as Leap 15 or Ubuntu 16.04, no problem.






            Comment


            • #7
              Originally posted by Charlie68 View Post
              The worrying thing is that at each new version of the kernel a warning is added at boot time. Instead of decreasing the warnings increase and this is not good.
              I don't know if they are all warnings, here on Tumbleweed the kernel is set to be very chatty

              Code:
              sudo sysctl kernel.printk
              kernel.printk = 4       4       1       7
              the numbers mean this (from man klogctl):

              Code:
                     console_loglevel
                            Only  messages with a log level lower than this value will be printed to the console.  The default value for this field is DEFAULT_CONSOLE_LOGLEVEL (7), but it is set to 4 if the kernel command line contains the word "quiet", 10 if the kernel command line contains the word "debug", and to 15 in case of a kernel fault
                            (the 10 and 15 are just silly, and equivalent to 8).  The value of console_loglevel can be set (to a value in the range 1–8) by a syslog() call with a type of 8.
              
                     default_message_loglevel
                            This value will be used as the log level for printk() messages that do not have an explicit level.  Up to and including Linux 2.6.38, the hard-coded default value for this field was 4 (KERN_WARNING); since Linux 2.6.39, the default value is a defined by the kernel configuration option CONFIG_DEFAULT_MESSAGE_LOGLEVEL,
                            which defaults to 4.
              
                     minimum_console_loglevel
                            The value in this field is the minimum value to which console_loglevel can be set.
              
                     default_console_loglevel
                            This is the default value for console_loglevel.
              And the numbers mean this:

              Code:
                     Kernel constant   Level value   Meaning
                     KERN_EMERG             0        System is unusable
                     KERN_ALERT             1        Action must be taken immediately
                     KERN_CRIT              2        Critical conditions
                     KERN_ERR               3        Error conditions
                     KERN_WARNING           4        Warning conditions
                     KERN_NOTICE            5        Normal but significant condition
                     KERN_INFO              6        Informational
                     KERN_DEBUG             7        Debug-level messages

              As you can see the kernel is set to print anything from Informational and below.

              Change the kernel.printk setting to show only errors and worse with
              sudo sysctl -w kernel.printk="4 4 1 4"

              If you want this on boot you should pass "loglevel=3" (or with a lower number) as a kernel command line argument (do this in the Bootloader settings from Yast).
              Apparently, "quiet" command line parameter should have the same effect of "loglevel=4", so at least the MODSIGN: Couldn't get UEFI db list that I also get on my system is an error, not a warning. (which imho should not be. I specifically disabled UEFI secure boot and UEFI db lists are unavailable, this is normal. )

              https://superuser.com/questions/3513...ing-my-console
              Last edited by starshipeleven; 04-08-2019, 06:51 PM.

              Comment


              • #8
                Originally posted by starshipeleven View Post
                I don't know if they are all warnings, here on Tumbleweed the kernel is set to be very chatty

                Code:
                sudo sysctl kernel.printk
                kernel.printk = 4 4 1 7
                the numbers mean this (from man klogctl):

                Code:
                 console_loglevel
                Only messages with a log level lower than this value will be printed to the console. The default value for this field is DEFAULT_CONSOLE_LOGLEVEL (7), but it is set to 4 if the kernel command line contains the word "quiet", 10 if the kernel command line contains the word "debug", and to 15 in case of a kernel fault
                (the 10 and 15 are just silly, and equivalent to 8). The value of console_loglevel can be set (to a value in the range 1–8) by a syslog() call with a type of 8.
                
                default_message_loglevel
                This value will be used as the log level for printk() messages that do not have an explicit level. Up to and including Linux 2.6.38, the hard-coded default value for this field was 4 (KERN_WARNING); since Linux 2.6.39, the default value is a defined by the kernel configuration option CONFIG_DEFAULT_MESSAGE_LOGLEVEL,
                which defaults to 4.
                
                minimum_console_loglevel
                The value in this field is the minimum value to which console_loglevel can be set.
                
                default_console_loglevel
                This is the default value for console_loglevel.
                And the numbers mean this:

                Code:
                 Kernel constant Level value Meaning
                KERN_EMERG 0 System is unusable
                KERN_ALERT 1 Action must be taken immediately
                KERN_CRIT 2 Critical conditions
                KERN_ERR 3 Error conditions
                KERN_WARNING 4 Warning conditions
                KERN_NOTICE 5 Normal but significant condition
                KERN_INFO 6 Informational
                KERN_DEBUG 7 Debug-level messages

                As you can see the kernel is set to print anything from Informational and below.

                Change the kernel.printk setting to show only errors and worse with
                sudo sysctl -w kernel.printk="4 4 1 4"

                If you want this on boot you should pass "loglevel=3" (or with a lower number) as a kernel command line argument (do this in the Bootloader settings from Yast).
                Apparently, "quiet" command line parameter should have the same effect of "loglevel=4", so at least the MODSIGN: Couldn't get UEFI db list that I also get on my system is an error, not a warning. (which imho should not be. I specifically disabled UEFI secure boot and UEFI db lists are unavailable, this is normal. )

                https://superuser.com/questions/3513...ing-my-console
                Thank you very much, as soon as I have some time I try.

                Comment


                • #9
                  starshipeleven - Thanks to your suggestions, I managed to hide all the warnings, only do_IRQ remained: 2.55 No irq handler for vector, but that's ok. Among other things I had to reinstall, because I changed the hard disk and this time I chose the legacy mode, as I think my UEFI bios has some bugs too. Thanks a lot.

                  Comment


                  • #10
                    Originally posted by Charlie68 View Post
                    Among other things I had to reinstall, because I changed the hard disk and this time I chose the legacy mode, as I think my UEFI bios has some bugs too. Thanks a lot.
                    I know it's too late but leaving this here for the future generations: migrating from UEFI to Legacy should not require a reinstall.

                    Just boot SuperGrubDisk2 https://www.supergrubdisk.org/super-grub2-disk/ in UEFI or Legacy (whatever you want to migrate into), then scan for and boot your system, and then from there you can just uninstall GRUB and install the right kind of GRUB you need for UEFI or Legacy boot.

                    Comment

                    Working...
                    X