No announcement yet.

kernel configuration problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • kernel configuration problem

    Hi all,

    I'm trying to compile the AGNX driver ( on Ubuntu 8.10 AMD 64 with the 2.6.27-7-generic kernel. This compiles fine, but I can't insert the module into the kernel :S

    Running nm on agnx.ko returns unidentified symbols and the developer of the agnx driver advised me to build the module against the latest wireless-testing tree (

    I've pulled the kernel, but when I run make xconfig I get:
    [email protected]:~/Desktop/Wireless/git/wireless-testing$ make xconfig
      CHECK   qt
    * Unable to find the QT3 installation. Please make sure that
    * the QT3 development package is correctly installed and
    * either install pkg-config or set the QTDIR environment
    * variable to the correct location.
    make[1]: *** No rule to make target `scripts/kconfig/.tmp_qtcheck', needed by `scripts/kconfig/qconf.o'.  Stop.
    make: *** [xconfig] Error 2
    [email protected]:~/Desktop/Wireless/git/wireless-testing$
    Attempting to run make menuconfig returns lots of errors:

    drivers/crypto/Kconfig:187: unknown option "The"
    drivers/crypto/Kconfig:188: unknown option "as"
    drivers/crypto/Kconfig:190: unknown option "To"
    drivers/crypto/Kconfig:191: unknown option "will"
    arch/x86/kvm/Kconfig:16: unknown option "If"
    arch/x86/kvm/Kconfig:32: unknown option "This"
    arch/x86/kvm/Kconfig:33: unknown option "a"
    arch/x86/kvm/Kconfig:35: unknown option "To"
    arch/x86/kvm/Kconfig:36: unknown option "will"
    arch/x86/kvm/Kconfig:38: unknown option "If"
    drivers/lguest/Kconfig:12: unknown option "If"
    drivers/virtio/Kconfig:21: unknown option "Currently"
    drivers/virtio/Kconfig:22: unknown option "that"
    drivers/virtio/Kconfig:24: unknown option "If"
    drivers/virtio/Kconfig:34: unknown option "If"
    make[1]: *** [menuconfig] Error 1
    make: *** [menuconfig] Error 2
    I tried to copy the existing (running) kernel configuration over with no success. If someone can show me where I am going wrong or point me in the right direction it would be much appreciated.

    Thanks in advance

  • #2
    Looks like you don't have the qt-devel packages installed on your system.


    • #3
      Originally posted by deanjo View Post
      Looks like you don't have the qt-devel packages installed on your system.
      Well I've installed qt3-dev-tools_3.3.8-b5ubuntu1_amd64.deb from and still no luck :S
      kernel-package, libncurses5-dev & fakeroot are also installed.

      Is it necessary to place the wireless-testing source in /usr/src?

      I've noticed some guides symlink the source to /usr/src/linux - why?
      Last edited by hmmm; 11-03-2008, 11:11 PM.