Announcement

Collapse
No announcement yet.

Fedora's "Fedup" To Be Replaced In Fedora 23

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #11
    Originally posted by Fry-kun View Post
    Wouldn't it be cleaner to upgrade only a couple of packages offline -- only ones that really require it -- and then upgrade the rest online?
    Agreed, it would be simpler and nicer.

    Comment


    • #12
      I've always had serious problems with Fedup, and it's only worked for me once for F20-->F21. I've stopped using it as a result and just do fresh installs. In contrast, when I used to run Ubuntu Server pre F16, I always had fantastic results with apt-get dist-upgrade and similar. For several Ubuntu releases between 5.10 and 11.x, I used this command from work in an ssh terminal without losing the ssh session, and upon reboot, everything was spot-on, even third party repos i.e. universe/multiverse. I always thought that was just fantastic, and Fedup has been a major disappointment in comparison to that.

      Comment


      • #13
        Fedora is ahead of toy distros like Ubuntu on so many levels but wrt distro upgrades they have a nice GUI tool. Distro upgrades only working via CLI is so 1990s.

        Comment


        • #14
          Mostly positive experiences of fedup here. The one minor issue I can recall has since been fixed. Still, if it doesn't fit with their design going forward, I have no problem with it getting replaced.

          Comment


          • #15
            Originally posted by Aeder View Post

            The message with RPM Fusion seemed to say something about the repository keys having some sort of problem. It was easier to just remove the repository and install it again than trying to diagnose what went wrong.
            I had the same problem. A few of the RPM Fusion packages weren't downloaded due to being signed with invalid GPG keys. I noticed fedup imported several RPM Fusion keys during the download, so I just ran fedup a second time before upgrading. The second pass downloaded the missing packages fine.

            RPM Fusion packages don't seem to be dependent on the package their keys are distributed in, so I don't see how there's anything fedup can do about it. It's just blind luck whether it downloads the packages in the right order.

            In general ... I don't mind fedup (although the replacement sounds OK too). Trying to remotely upgrade systems in-place always feels like playing with fire to me.

            Comment


            • #16
              Originally posted by fagzal View Post
              FedUp should have never been introduced. I've tried it once, and it just crashed my system. Meanwhile, the "unsupported" yum upgrade path has always worked, and in that case at lease I see what is happening! Oh, and I am not offline during the process...

              Seriously, just support yum (now dnf), and lvm/btrfs/whatever snapshot rollbacks!
              You tried it once.
              I've been using Fedup since, what, F17, to upgrade a ~15 servers, dozens of VMs, and more than 20 workstations, desktops and laptops up to Fedora 21 with nearly zero issues.
              Me guess my anecdotal evidence beats yours, hands down.

              ... In short, don't be so quick to throw mud on something, especially given your *very* limited test case.

              - Gilboa
              DEV: Intel S2600C0, 2xE52658V2, 32GB, 4x2TB + 2x3TB, GTX1080, F27/x86_64, Dell UP3216Q 4K.
              SRV: Intel S5520SC, 2xX5680, 36GB, 4x2TB, GTX550, F27/x86_64, Dell U2711..
              BAK: Tyan Tempest i5400XT, 2xE5335, 8GB, 3x1.5TB, 9800GTX, F27/x86-64.
              LAP: ASUS Strix GL502V, i7-6700HQ, 32GB, 1TB+256GB, 1070M, F27/x86_64.

              Comment

              Working...
              X