Announcement

Collapse
No announcement yet.

Ubuntu 15.04 Receives Early Release Of Catalyst 15.3 Linux Driver

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ubuntu 15.04 Receives Early Release Of Catalyst 15.3 Linux Driver

    Phoronix: Ubuntu 15.04 Receives Early Release Of Catalyst 15.3 Linux Driver

    Early adopters of Ubuntu 15.04 Vivid Vervet can now use AMD's new Catalyst 15.3 Beta driver that's been packaged for Ubuntu and uploaded to the Vivid repository prior to its release on AMD.com...

    http://www.phoronix.com/scan.php?pag...5.04-15.3-Beta

  • #2
    Archive for non-Ubuntu 15.04 users wanting to look into it:

    http://archive.ubuntu.com/ubuntu/poo...00.orig.tar.gz

    Comment


    • #3
      About friggin time

      AMD should have pre-seeded Canonical months ago.

      It pisses me off that AMD is always late with the new drivers to support the latest kernel and X.Org Server, which is holding back Linux, desktop and X innovation for everyone.

      Comment


      • #4
        Will it work with my Radeon HD 3650 ? Cos I can't even start Steam on opensource drivers now

        Comment


        • #5
          My only response to this is....


          Ne1 know if I can get this to work with Mint 17.1?
          anyway will try it later today with Kernel 4.0 on Mint
          Last edited by grndzro; 11 March 2015, 03:49 PM.

          Comment


          • #6
            Today is a good day!

            Comment


            • #7
              Originally posted by uid313 View Post
              It pisses me off that AMD is always late with the new drivers to support the latest kernel and X.Org Server, which is holding back Linux, desktop and X innovation for everyone.
              Change distro or learn to patch.

              Here is pretty much every patch you would need. Download/Extract tarball and use patches
              https://aur.archlinux.org/packages/catalyst-total/

              Ubuntu/Mint/Debian/Fedora..steal the patches from Violo and patch normally
              Opensuse..Sebastian keeps the drivers up to date
              Arch/Antergos..Violo has up to date drivers

              Xorg 1.17 recently came out
              Gnome3/GDM issues are not AMD's problem. Catalyst works with every other display manager.

              Comment


              • #8
                Originally posted by plantroon View Post
                Will it work with my Radeon HD 3650 ? Cos I can't even start Steam on opensource drivers now
                Strange. I have HD 4850, and I haven't yet encountered a game not working on Steam with it with free drivers. HD 4850 does give better FPS too than Intel Ivy Bridge HD4000. That said, if AMD legacy drivers are not being updated to support X.org 1.17 etc., I really may have to get NVidia card. It does piss me big time I have a card which do have enough juice for most games in Steam, but AMD rather tries to force me to buy a new card.

                Comment


                • #9
                  Originally posted by moilami View Post
                  Strange. I have HD 4850, and I haven't yet encountered a game not working on Steam with it with free drivers. HD 4850 does give better FPS too than Intel Ivy Bridge HD4000. That said, if AMD legacy drivers are not being updated to support X.org 1.17 etc., I really may have to get NVidia card. It does piss me big time I have a card which do have enough juice for most games in Steam, but AMD rather tries to force me to buy a new card.
                  HD 3650 and HD4850 have a really different architecture. 2 completely different cards even in performance. HD 3650 has performance very close (a bit better maybe) to Intel HD 4000. Even on Windows, HD 3650 has bugs in "newer" games like Battlefield 3 where you can't see the HUD. No such thing happened with 4850. I have a dead 4870 at home and I believe it's similar to 4850. On Linux, 4xxx series has better opensource support and 3xxx series was known to suffer from lockups on opensource drivers.

                  Comment


                  • #10
                    If you want steam to work with radeon drivers,you probably need to delete libstdc and libgcc in steam runtime like arch users do since severals month.

                    Comment

                    Working...
                    X