Announcement

Collapse
No announcement yet.

F22 Switch From Evdev & Synaptics To Libinput

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • F22 Switch From Evdev & Synaptics To Libinput

    Phoronix: F22 Switch From Evdev & Synaptics To Libinput

    Those installing the latest development snapshot of Fedora 22 will now experience a difference in the default X.Org input driver...

    http://www.phoronix.com/scan.php?pag...ibinput-Switch

  • #2
    Originally posted by phoronix View Post
    Phoronix: F22 Switch From Evdev & Synaptics To Libinput

    Those installing the latest development snapshot of Fedora 22 will now experience a difference in the default X.Org input driver...

    http://www.phoronix.com/scan.php?pag...ibinput-Switch
    I tried xf86-input-libinput on my synaptics trackpad laptop. My main complaints are that two-finger scrolling is a bit oversensitive and there is no easy way to enable tap-to-click, which is possible with libinput but disabled by default.

    Comment


    • #3
      Originally posted by blackout23 View Post
      I tried xf86-input-libinput on my synaptics trackpad laptop. My main complaints are that two-finger scrolling is a bit oversensitive and there is no easy way to enable tap-to-click, which is possible with libinput but disabled by default.
      Similar results with KDE. I tried to play with the new KCM, but it is much more stripped down, so not as usable. I understand that the reduced configurations make sense from an abstract level (touchpad shouldn't access the keyboard for disable-while-typing) and such, but I switched back to -synaptics after a few days. Really it was the 2-finger scrolling speed that I couldn't live with.

      Comment


      • #4
        I also can't control pointer acceleration.
        Code:
        Section "InputClass"
          Identifier "AccelSpeed"
          MatchDriver "libinput"
          Option "AccelSpeed" "-1"
        EndSection
        does nothing.

        Comment


        • #5
          Originally posted by magika View Post
          I also can't control pointer acceleration.
          Code:
          Section "InputClass"
            Identifier "AccelSpeed"
            MatchDriver "libinput"
            Option "AccelSpeed" "-1"
          EndSection
          does nothing.
          Works fine for me. You're probably missing this:
          https://github.com/whot/xf86-input-l...b8f9f4efc3a8a0

          Comment


          • #6
            Tips for people having trouble with libinput

            Hi,

            One of the upstream libinput devs here.

            So for those of you having trouble with 2 finger scrolling, I assume the problem is that the scrolling is too fast, correct ?
            What about the regular pointer speed, is that ok, or too fast too? And for noth are they slightly too fast, or much too fast ?

            As for people not being able to configure things, if your on an up2date Fedora 22 snapshot and using gnome / kde
            you should be able to enable / disable tap to click by just using the config panel. If you're not on F-22 you can still
            configure things from the commandline, e.g. do:

            [[email protected] ~]$ xinput list
            ⎡ Virtual core pointer id=2 [master pointer (3)]
            ⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
            ⎜ ↳ USB OPTICAL MOUSE id=8 [slave pointer (2)]
            ⎜ ↳ Lite-On Technology Corp. USB Multimedia Keyboard id=11 [slave pointer (2)]
            ⎜ ↳ SINO WEALTH USB Composite Device id=13 [slave pointer (2)]
            ⎣ Virtual core keyboard id=3 [master keyboard (2)]
            ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
            ↳ Power Button id=6 [slave keyboard (3)]
            ↳ Power Button id=7 [slave keyboard (3)]
            ↳ Lite-On Technology Corp. USB Multimedia Keyboard id=9 [slave keyboard (3)]
            ↳ Lite-On Technology Corp. USB Multimedia Keyboard id=10 [slave keyboard (3)]
            ↳ SINO WEALTH USB Composite Device id=12 [slave keyboard (3)]
            ↳ Burr-Brown from TI USB Audio DAC id=14 [slave keyboard (3)]

            And then:

            [[email protected] ~]$ xinput list-props 8
            Device ' USB OPTICAL MOUSE':
            Device Enabled (132): 1
            Coordinate Transformation Matrix (134): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
            libinput Accel Speed (264): -0.469058
            libinput Natural Scrolling Enabled (265): 0
            libinput Send Events Modes Available (250): 1, 0
            libinput Send Events Mode Enabled (251): 0, 0
            libinput Left Handed Enabled (266): 0
            libinput Scroll Methods Available (267): 0, 0, 1
            libinput Scroll Method Enabled (268): 0, 0, 0
            libinput Button Scrolling Button (269): 0
            Device Node (252): "/dev/input/event5"
            Device Product ID (253): 5593, 2639

            [[email protected] ~]$ xinput set-float-prop 8 "libinput Accel Speed" -1

            And now I've configured my mouse to the slowest setting, the accel scale goes from -1.0 to +1.0 with 0.0 being the default.

            You can enable tap to click in a similar manner.

            Regards,

            Hans

            Comment


            • #7
              Originally posted by AnAkIn View Post
              Works fine for me. You're probably missing this:
              https://github.com/whot/xf86-input-l...b8f9f4efc3a8a0
              I am using Arch and said fix is already applied to the package :\

              Comment


              • #8
                Originally posted by magika View Post
                I am using Arch and said fix is already applied to the package :\
                I use this, it cover both evdev and libinput and works fine for me:
                Code:
                Section "InputClass"
                        Identifier "My Mouse"
                        MatchIsPointer "yes"
                        Option "AccelerationProfile" "-1"
                        Option "AccelerationScheme" "none"
                        Option "AccelSpeed" "-1"
                EndSection

                Comment


                • #9
                  Originally posted by jaxxed View Post
                  Similar results with KDE. I tried to play with the new KCM, but it is much more stripped down, so not as usable. I understand that the reduced configurations make sense from an abstract level (touchpad shouldn't access the keyboard for disable-while-typing) and such, but I switched back to -synaptics after a few days. Really it was the 2-finger scrolling speed that I couldn't live with.
                  Actually... If input is going to a game, disabling the touchpad while typing is wrong. In a game you want to be able to give mouse and keyboard input simultaneously. The best way to handle this would be for applications to say "I don't want you to block input for this [window/application]" much like the powermanagement protocol that prevents automatic screen dimming and locking while a video is playing.

                  Comment


                  • #10
                    Originally posted by Luke_Wolf View Post
                    Actually... If input is going to a game, disabling the touchpad while typing is wrong. In a game you want to be able to give mouse and keyboard input simultaneously. The best way to handle this would be for applications to say "I don't want you to block input for this [window/application]" much like the powermanagement protocol that prevents automatic screen dimming and locking while a video is playing.
                    THIS. the problem also exists with synaptics where I have to switch manualy every time I want to game with touchpad+keyboard.
                    Would be a nice feature to have in libinput and a reason to switch!

                    Comment

                    Working...
                    X