Announcement

Collapse
No announcement yet.

APT 2.9 Released: Debian's APT 3.0 To Have A New UI With Colors, Columnar Display & More

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SleeepyKat
    replied
    Best of all, apt 3.0 will respect the $NO_COLOR convention.

    Leave a comment:


  • Artim
    replied
    Originally posted by novideo View Post
    Oh thanks, that command will come in handy! It doesn't look too bad though, even if I remove --installed:
    Code:
    $ LANG=C apt rdepends apt --installed
    apt
    Reverse Depends:
    Recommends: libapt-pkg6.0t64 (>= 2.9.0)
    Breaks: libapt-pkg6.0t64 (<< 1.6~)
    Depends: apt-utils (= 2.9.0)
    Depends: tasksel
    Depends: reportbug
    Depends: python3-reportbug
    Suggests: python3-apt
    Suggests: dpkg
    Recommends: deborphan
    Depends: apt-file
    Breaks: libapt-pkg6.0t64 (<< 1.6~)
    Recommends: libapt-pkg6.0t64 (>= 2.9.1)
    Depends: apt-utils (= 2.9.1)​
    But it does once you include the implicit dependencies, not just the explicit ones.

    Leave a comment:


  • novideo
    replied
    Originally posted by Artim View Post

    Or if you had any idea how Debian based distros worked, you'd just look through reverse dependencies. There you'd see that there are a lot of packages depending on apt in some form. And not always will they accept any version of it. So good luck with the next OS upgrade without breaking everything.
    Oh thanks, that command will come in handy! It doesn't look too bad though, even if I remove --installed:
    Code:
    $ LANG=C apt rdepends apt --installed
    apt
    Reverse Depends:
      Recommends: libapt-pkg6.0t64 (>= 2.9.0)
      Breaks: libapt-pkg6.0t64 (<< 1.6~)
      Depends: apt-utils (= 2.9.0)
      Depends: tasksel
      Depends: reportbug
      Depends: python3-reportbug
      Suggests: python3-apt
      Suggests: dpkg
      Recommends: deborphan
      Depends: apt-file
      Breaks: libapt-pkg6.0t64 (<< 1.6~)
      Recommends: libapt-pkg6.0t64 (>= 2.9.1)
      Depends: apt-utils (= 2.9.1)​

    Leave a comment:


  • Artim
    replied
    Originally posted by Vistaus View Post

    It's rock solid with no breakages for a few major versions now, so I don't see why it would happen with 3.0.
    Then learn to actually read what I write and not what you guess. I never said what you imply. The exact opposite is true.

    Leave a comment:


  • Vistaus
    replied
    Originally posted by Artim View Post

    Then read back about what was written. At no point it was about apt updates failing in proper usage scenarios. But if you pin your apt version not to receive v3.0, your system will eventually either break or refuse the upgrade altogether.
    It's rock solid with no breakages for a few major versions now, so I don't see why it would happen with 3.0.
    Last edited by Vistaus; 14 April 2024, 01:51 PM.

    Leave a comment:


  • Artim
    replied
    Originally posted by Vistaus View Post

    Eh, I'm on Debian with Apt 2.6 and it has withstood the upgrades to 2.7, 2.8 and 2.9 so far. And it's still rock solid.

    And it's the same on Deepin V23, which is in its testing phase and built on top of Debian: 2.6 is default after install from the testing ISO, but you can upgrade to 2.7 or 2.8. I have not done that and the system is still upgrading and rock solid.
    Then read back about what was written. At no point it was about apt updates failing in proper usage scenarios. But if you pin your apt version not to receive v3.0, your system will eventually either break or refuse the upgrade altogether.

    Leave a comment:


  • Vistaus
    replied
    Originally posted by Artim View Post

    You may try to prove that highly questionable statement, but I don't know any distro that uses apt as package manager where you could choose not to update to a newer apt version. Sure, you can stay on Ubuntu LTS and even Debian has some long term support, but eventually you don't have any other choice than to update because of dependencies.
    Eh, I'm on Debian with Apt 2.6 and it has withstood the upgrades to 2.7, 2.8 and 2.9 so far. And it's still rock solid.

    And it's the same on Deepin V23, which is in its testing phase and built on top of Debian: 2.6 is default after install from the testing ISO, but you can upgrade to 2.7 or 2.8. I have not done that and the system is still upgrading and rock solid.
    Last edited by Vistaus; 14 April 2024, 10:40 AM.

    Leave a comment:


  • Artim
    replied
    Originally posted by novideo View Post
    Ok imma test this, gonna apt-mark hold apt and see how long it takes.
    Or if you had any idea how Debian based distros worked, you'd just look through reverse dependencies. There you'd see that there are a lot of packages depending on apt in some form. And not always will they accept any version of it. So good luck with the next OS upgrade without breaking everything.

    Leave a comment:


  • novideo
    replied
    Originally posted by Artim View Post

    You may try to prove that highly questionable statement, but I don't know any distro that uses apt as package manager where you could choose not to update to a newer apt version. Sure, you can stay on Ubuntu LTS and even Debian has some long term support, but eventually you don't have any other choice than to update because of dependencies.
    Ok imma test this, gonna apt-mark hold apt and see how long it takes.

    Leave a comment:


  • Artim
    replied
    Originally posted by Vistaus View Post

    That's incorrect.
    You may try to prove that highly questionable statement, but I don't know any distro that uses apt as package manager where you could choose not to update to a newer apt version. Sure, you can stay on Ubuntu LTS and even Debian has some long term support, but eventually you don't have any other choice than to update because of dependencies.

    Leave a comment:

Working...
X