Announcement

Collapse
No announcement yet.

Arch Linux Increasing Its vm.max_map_count To Help Steam Play Games & Other Software

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ahrs
    replied
    Originally posted by theriddick View Post
    still a common issue for new comers having it set way too low. Kind of wish steam had a way to handle this, or wine apps.
    Steam can't handle this because it requires root to change. They could perhaps add Polkit support and change it that way but I'd be hesitant of giving Steam root access (not that I don't trust them).

    Leave a comment:


  • rabcor
    replied
    Originally posted by Anux View Post
    Maybe the value gets set according to available ram at install? Is there any downside in setting the value super high, does it reserve RAM that isn't usable otherwise? And if so why not make it dynamic?

    Edit: arch with zen kernel: vm.max_map_count = 1048576 with 30 GB (-2 GB VRAM). I never touched that value and everything runs fine.
    Had 32gb on setup so it probably isn't that, unless it changed when i added the other 32gb.

    Leave a comment:


  • byteabit
    replied
    Originally posted by Anux View Post
    Edit: arch with zen kernel: vm.max_map_count = 1048576 with 30 GB (-2 GB VRAM). I never touched that value and everything runs fine.
    Interesting. I'm on EndeavourOS and have Zen Kernel and 32 GB RAM + 8 GB VRAM. The vm.max_map_count is the same value like you have. Here is the description of Zen Kernel, if that has anything to do with it: https://github.com/zen-kernel/zen-ke...d-Feature-List

    Leave a comment:


  • Anux
    replied
    Maybe the value gets set according to available ram at install? Is there any downside in setting the value super high, does it reserve RAM that isn't usable otherwise? And if so why not make it dynamic?

    Edit: arch with zen kernel: vm.max_map_count = 1048576 with 30 GB (-2 GB VRAM). I never touched that value and everything runs fine.
    Last edited by Anux; 09 April 2024, 03:24 PM.

    Leave a comment:


  • byteabit
    replied
    Originally posted by rabcor View Post
    well this seems a right mess on the arch based distros
    Only on Arch based distros or on all distros? I assume some applications or drivers can change this setting, depending on the hardware probably? In example I have a different setting, but I also use Linux Zen kernel (forgot about that when initially checking and replying here).

    Leave a comment:


  • rabcor
    replied
    well this seems a right mess on the arch based distros, it seems like the value is different for everyone despite nobody having touched the settings :'D

    Well at least the floor will now be higher for us. I just set it manually tho.

    Leave a comment:


  • Jonjolt
    replied
    Originally posted by stqn View Post
    Interesting, I’m at 65530 on Gentoo, and games tend to work fine… Do we have a list of games that require a higher value?
    It's not just games, Elasticsearch requires it and Intellij pushes the limits of the default value.

    Leave a comment:


  • stqn
    replied
    Interesting, I’m at 65530 on Gentoo, and games tend to work fine… Do we have a list of games that require a higher value?

    Leave a comment:


  • Kepsz
    replied
    Originally posted by rabcor View Post

    unless this was a very recent change, it isn't true, cuz i am on an endeavouros installation that is only a handful of months old and...

    Code:
    $ sysctl -a | grep max_map_count
    vm.max_map_count = 65530


    Manjaro on the other hand i recall did have this set higher by default.
    It is a 1.5 year old EndeavourOS KDE install. But the value today is: vm.max_map_count = 1048576

    *after the filesystem package update today.

    Leave a comment:


  • Ferrum Master
    replied
    I've encountered it in Star Citizen, without it crashes. (more often than usual).

    sudo sysctl -w vm.max_map_count=16777216

    So the bump is too conservative un you have to alter it either way.

    Leave a comment:

Working...
X