Announcement

Collapse
No announcement yet.

Debian 12 Switches To PipeWire & WirePlumber By Default With The GNOME Desktop

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debian 12 Switches To PipeWire & WirePlumber By Default With The GNOME Desktop

    Phoronix: Debian 12 Switches To PipeWire & WirePlumber By Default With The GNOME Desktop

    In addition to Ubuntu 22.10 switching to PipeWire as the default audio server replacement to PulseAudio, upstream Debian has done the same ahead of their Debian GNU/Linux 12 release next year...

    https://www.phoronix.com/news/Debian-12-PipeWire

  • #2
    Let's hope that issues like [1] get fixed soon... I really want to 100% switch to PipeWire.

    [1]: https://gitlab.freedesktop.org/pipew...r/-/issues/267

    Comment


    • #3
      Using it on KDE (Gentoo) with Bluetooth headset : wonderful. PulseAudio is dead.

      Comment


      • #4
        Pipewire worked fine for me on Ubuntu 22.04 and Fedora 36; games work no problem, but the one instance where I force PipeWire with SDL (Runescape 3) works fine on those distros, but not openSUSE TW a month or two ago.

        Comment


        • #5
          I don't think I've seen anyone seriously using Gnome on Debian since the Gnome 2 days.

          Can it be done? Clearly yes.
          Does it make any sense? Not much, when so many other distros do Gnome so much better, and when Debian does other things so much better.

          So for the vast majority of Debian users who do not use Gnome, this change will make no difference.

          Comment


          • #6
            When I tried PW on my past laptop (Ideapad 500-15ISK, Intel Sunrise Point-LP HD Audio), the sound was stuttering, and I couldn't fix that, so reverted back to PA. But now on ASUS ROG G513QY (AMD Family 17h/19h HD Audio Controller Pro) it works great OOB.

            Comment


            • #7
              Speaking of sound, when I switched to a new motherboard (like 2 years ago, MSI B360M Mortar) the audio doesn't start instantly anymore when I click Play on a player, it kinda gently fades up for like a second or half for the first time an audio player starts to play (since launched). Anyone knows what could be wrong (or an anti-feature)?
              Last edited by cl333r; 01 October 2022, 10:35 AM.

              Comment


              • #8
                Originally posted by cl333r View Post
                Speaking of sound, when I switched to a new motherboard (like 2 years ago, MSI B360M Mortar) the audio doesn't start instantly anymore when I click Play on a player, it kinda gently fades up for like a second or half for the first time an audio player starts to play (since launched). Anyone knows what could be wrong (or an anti-feature)?
                Maybe powertop can help you to check if energy saving is enabled for your audio device/chip. It sounds like it is powering down and when you play up again.

                Comment


                • #9
                  Originally posted by tachi View Post
                  Let's hope that issues like [1] get fixed soon... I really want to 100% switch to PipeWire.

                  [1]: https://gitlab.freedesktop.org/pipew...r/-/issues/267
                  Looks like the issue with hardware which doesn't work to the spec.

                  Comment


                  • #10
                    With stuff like pipewire, Wayland, libinput make linux desktop so much better. I'm glad to see these efforts come to fruition

                    Comment

                    Working...
                    X