Announcement

Collapse
No announcement yet.

Ubuntu 19.10 To 21.10: AMD Zen 2 + Radeon Performance On Linux Over Two Years

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts
    Vistaus
    Senior Member

  • Vistaus
    replied
    Originally posted by skeevy420 View Post

    cpupower on Arch, etc.
    Also on Debian and Deepin. cpufreq-info gives me nothing because it doesn't exist, but cpupower works fine.

    Leave a comment:

  • skeevy420
    Senior Member

  • skeevy420
    replied
    Michael
    Phoronix
    Michael Ran into a couple of issues when going to run these tests last night. First one is because I don't have a root user installed, I use "sudo su", so the PTS wouldn't install the missing packages on Arch. No biggie, I installed them manually.

    The 2nd, more important one, was that the npb install script didn't work on my system, ran into an issue on line 64 with "if [ "$CCVERSION" -gt 9 ]; when my GCC is showing 11.1.0. I think it's the decimals. The hacky fix of removing the if/then and just passing CFLAGS="$CFLAGS -fallow-argument-mismatch" worked but then I got this error

    Code:
    cp: cannot create regular file 'NPB3.4/NPB3.4-OMP/config/make.def': No such file or directory
    That file or directory exists

    Not a bug, but line 95 just seems odd doing a cd into my home. I don't think that's the intention.

    Code:
    cd ~/NPB3.4.1/NPB3.4-MPI/
    The 3rd one, more annoying than anything, is it kept telling me I didn't have "vulkan-tools" or "vulkan-icd-loader" when I clearly do so I kept having to skip that.

    And it does scale. Told me an estimated finish time of 19 hours.

    And it keeps telling me I'm using the powersave governor...I know damn well I'm not.

    Code:
    [FONT=monospace][COLOR=#54ff54][B][Performance Tip] The powersave CPU scaling governor is currently in use. It's possible to obtain greater performance if using the performance governor.[/B][/COLOR][/FONT]
    I'm actually using ondemand there.

    EDIT:

    It is the decimals. Changing it to string comparison worked...double brackets and <. Still have the cp issue. I feel like some $PWD's and cat EOF's could be used.

    Code:
    if [[ "$CCVERSION" < 9 ]]; then
    skeevy420
    Senior Member
    Last edited by skeevy420; 12 October 2021, 09:18 AM.

    Leave a comment:

  • soulnull
    Junior Member

  • soulnull
    replied
    How the hell is VP9 encoding THAT much slower than h265?! I thought I'd misread the labels at first, but nope: apparently it really is somwhere from 5x to 10x slower, to produce worse results.
    Horrible threading, very unoptimized reference encoder with no real mature alternatives.

    The most promising is SVT-VP9, which can do real-time encoding with comparable (arguably better) quality per bit. However, SVT is mostly focusing on AV1, so the VP9 encoder is an afterthought with a faction of the attention of the AV1 encoder. Still mostly an improvement over the reference encoder, though.

    Leave a comment:

  • arQon
    Senior Member

  • arQon
    replied
    How the hell is VP9 encoding THAT much slower than h265?! I thought I'd misread the labels at first, but nope: apparently it really is somwhere from 5x to 10x slower, to produce worse results.

    I mean, sure, on the plus side at least it's not an MPEG standard with all the BS that entails (though VPx has basically no client HW support, whereas h265 has been ubiquitous for years) - but...

    Am I missing something after all, and this isn't actually apples to apples? Or is the VP9 encoder really just catastrophically bad?

    Leave a comment:

  • skeevy420
    Senior Member

  • skeevy420
    replied
    Originally posted by perpetually high View Post

    I also like the package cpufrequtils, which gives you cpufreq-info and cpufreq-set:

    Code:
    $ cpufreq-info|grep -E 'driver|governors'
    driver: acpi-cpufreq
    available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
    cpupower on Arch, etc. I wish package naming was a bit more consistent between distributions.

    So, totally off topic but you'll get a kick, earlier tonight I ran

    Code:
    [FONT=monospace][COLOR=#000000]sudo mount -o remount,compress-force=zstd:15 /dev/sda2
    sudo btrfs filesystem defragment -r -v /
    sudo compsize -x /   [/COLOR]
    Processed 750635 files, 890436 regular extents (896758 refs), 357244 inline.
    Type       Perc     Disk Usage   Uncompressed Referenced   
    TOTAL       66%       70G         106G         107G        
    none       100%       42G          42G          43G        
    zstd        44%       28G          64G          64G [/FONT]
    and really wish I'd have thought about running compsize before doing that since I normally use compress-force=zstd:2

    Unfortunately, I was more interested in if I could rather than the before and after.

    Leave a comment:

  • perpetually high
    Senior Member

  • perpetually high
    replied
    Vistaus
    Senior Member
    Vistaus check which scaling governor you're using

    You may be using (if I remember correctly) one of the Intel one's (intel_pstate or intel_cpufreq). Can play around with Intel_pstate=disable and intel_pstate=enable in your GRUB.

    The scaling governor acpi-cpufreq should show all of them. Double check with phoronix-test-suite by Michael Larabel of Phoronix fame:

    Code:
    $ ./phoronix-test-suite system-info|head -n 15
    
    PROCESSOR: Intel Core i5-4670K @ 4.30GHz
    Core Count: 4
    Extensions: SSE 4.2 + AVX2 + AVX + RDRAND + FSGSBASE
    Cache Size: 6 MB
    Microcode: 0x22
    Core Family: Haswell
    Scaling Driver: acpi-cpufreq performance (Boost: Enabled)
    I also like the package cpufrequtils, which gives you cpufreq-info and cpufreq-set:

    Code:
    $ cpufreq-info|grep -E 'driver|governors'
    driver: acpi-cpufreq
    available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil

    Leave a comment:

  • F.Ultra
    Senior Member

  • F.Ultra
    replied
    Originally posted by [email protected] View Post

    Reviewers discovered it first, but AMD had acknowledge the issue themselves:

    https://www.amd.com/en/support/kb/faq/pa-400
    Which is somewhat strange in this context since Linux does not even have preferred core scheduling in the first place so we should be equally struck bu this issue as W11. There are some external patches to add it but I don't think any of them have been mainlined.

    Leave a comment:

  • skeevy420
    Senior Member

  • skeevy420
    replied
    Code:
    [FONT=monospace][COLOR=#808080]╭─[/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#080808]  [/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#e4e4e4]   [/COLOR][COLOR=#eeeeee][B]~[/B][/COLOR][COLOR=#1818b2][/COLOR][COLOR=#808080]························[/COLOR][COLOR=#000000][/COLOR][COLOR=#18b218] ✔ [/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#000000] at 15:35:23   [/COLOR][COLOR=#b2b2b2][/COLOR]
    [COLOR=#808080]╰─[/COLOR][COLOR=#000000] cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors [/COLOR]
    conservative ondemand userspace powersave performance schedutil  
    
    [COLOR=#808080]╭─[/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#080808]  [/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#e4e4e4]   [/COLOR][COLOR=#eeeeee][B]~[/B][/COLOR][COLOR=#1818b2][/COLOR][COLOR=#808080]························[/COLOR][COLOR=#000000][/COLOR][COLOR=#18b218] ✔ [/COLOR][COLOR=#b2b2b2][/COLOR][COLOR=#000000] at 15:36:24   [/COLOR][COLOR=#b2b2b2][/COLOR]
    [COLOR=#808080]╰─[/COLOR][COLOR=#000000] uname -r [/COLOR]
    5.14.11-xanmod1-cacule-1[/FONT]

    Leave a comment:

  • reba
    Senior Member

  • reba
    replied
    Originally posted by Vistaus View Post

    Schedutil doesn't seem to be available on my system (Deepin 20). Is that because I'm running the XanMod kernel?
    For me it's the other way around.

    Standard Debian kernel has powersave, performance and ondemand, IIRC.

    xanmod has:

    roo[email protected]:/tmp# cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
    conservative ondemand userspace powersave performance schedutil

    [email protected]:/tmp# uname -a
    Linux debian 5.14.11-xanmod1-cacule #0~git20211009.664b18d SMP PREEMPT Sat Oct 9 17:44:28 UTC 2021 x86_64 GNU/Linux

    Leave a comment:

  • reba
    Senior Member

  • reba
    replied
    Originally posted by Linuxxx View Post

    Just curious:
    Why 'ondemand' and not 'schedutil'?

    İ believe part of the improvements we see in this round of benchmarking also have to do with the switch of the CPU governors.

    İf You too could do a similar comparison by means of observation, that would be similarly great!
    Here are some graphs.
    One can see subtle, expected differences, especially between performance and powersave, however the used wattage, according to my wattmeter, are so close I cannot say I notice any meaningful difference. All were around 7,0 to 7,5 Watt for the full system with display, WiFi, Bluetooth, etc. on and Firefox and other stuff in the background with the system being idle otherwise.


    ondemand:


    performance:


    powersave:


    schedutil:


    Looking forward to skeevy's results.
    reba
    Senior Member
    Last edited by reba; 11 October 2021, 03:23 PM.

    Leave a comment:

Working...
X