Announcement

Collapse
No announcement yet.

Fedora Workstation 34 Looking To Employ Btrfs Zstd Transparent Compression By Default

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fedora Workstation 34 Looking To Employ Btrfs Zstd Transparent Compression By Default

    Phoronix: Fedora Workstation 34 Looking To Employ Btrfs Zstd Transparent Compression By Default

    Fedora Workstation 33 successfully switched over from EXT4 to using Btrfs as its default file-system. Now with Fedora 34 due out in the spring we are seeing Fedora beginning to make use of more features offered by Btrfs...

    http://www.phoronix.com/scan.php?pag...s-Zstd-Default

  • #2
    in openSuse when i try to use zstd compression GRUB cannot boot it... they said it was due to old GRUB but i have the similar issue with tumbleweed as well...

    Comment


    • #3
      Originally posted by smartalgorithm View Post
      in openSuse when i try to use zstd compression GRUB cannot boot it... they said it was due to old GRUB but i have the similar issue with tumbleweed as well...
      They patched grub to disable zstd support for i386.
      Yup, dumb as hell.
      https://bugzilla.opensuse.org/show_bug.cgi?id=1169211
      https://bugzilla.opensuse.org/show_bug.cgi?id=1161823

      Comment


      • #4
        I'm not a Fedora user so this is as good of a bug report as y'all are gonna get from me:

        Code:
        mount -o compress=zstd:1
        should be
        Code:
        mount -o compress-force=zstd:1
        "compress-force" makes BTRFS use Zstd's compression check algorithm when determining whether to compress a file or not and is more efficient than what BTRFS uses by default when just "compress" is used.

        Comment


        • #5
          Originally posted by smartalgorithm View Post
          in openSuse when i try to use zstd compression GRUB cannot boot it... they said it was due to old GRUB but i have the similar issue with tumbleweed as well...
          Are you using bios or efi?

          Comment


          • #6
            Originally posted by Mario Junior View Post

            Are you using bios or efi?
            BIOS i use

            Comment


            • #7
              Originally posted by skeevy420 View Post
              I'm not a Fedora user so this is as good of a bug report as y'all are gonna get from me:

              Code:
              mount -o compress=zstd:1
              should be
              Code:
              mount -o compress-force=zstd:1
              "compress-force" makes BTRFS use Zstd's compression check algorithm when determining whether to compress a file or not and is more efficient than what BTRFS uses by default when just "compress" is used.
              Interesting - do you have any sources/numbers that show it's better? And do you know about a bug report anywhere? Sounds like something that should get addressed.

              Comment


              • #8
                Originally posted by skeevy420 View Post
                I'm not a Fedora user so this is as good of a bug report as y'all are gonna get from me:

                Code:
                mount -o compress=zstd:1
                should be
                Code:
                mount -o compress-force=zstd:1
                "compress-force" makes BTRFS use Zstd's compression check algorithm when determining whether to compress a file or not and is more efficient than what BTRFS uses by default when just "compress" is used.
                I haven't switched from F32 and not really worked with BTRFS in general yet, but that option sounds backwards? In my head "compress-force" implies that files are compressed no matter what.

                Comment


                • #9
                  Originally posted by YamashitaRen View Post

                  They patched grub to disable zstd support for i386.
                  Yup, dumb as hell.
                  https://bugzilla.opensuse.org/show_bug.cgi?id=1169211
                  https://bugzilla.opensuse.org/show_bug.cgi?id=1161823
                  interesting... all my systems were x64,,,

                  Comment


                  • #10
                    Originally posted by YamashitaRen View Post

                    They patched grub to disable zstd support for i386.
                    Yup, dumb as hell.
                    https://bugzilla.opensuse.org/show_bug.cgi?id=1169211
                    https://bugzilla.opensuse.org/show_bug.cgi?id=1161823
                    Tumbleweed installer defaults to a GPT with a BIOS BOOT Partition of 8 MiB, plenty space to bring in zstd support. The reason was for compatibility reasons, ie: people with MBR disks with no BIOS BOOT Partition. I have old PCs with BIOS from 2011 that can boot GPT disks without problems.

                    Instead of warning users and/or make a special package for them, they just straight disabled it. I had to manually remove that patch and rebuild the grub RPM, argh!

                    EDIT: Didn't Arch made the same decision?

                    Comment

                    Working...
                    X