Announcement

Collapse
No announcement yet.

openSUSE Tumbleweed Now Shipping Linux 5.8

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • starshipeleven
    replied
    Originally posted by jospoortvliet View Post
    Yeah, openSUSE does have a speed advantage with their automated testing, of course. Well, openQA is open source, Arch could just take it... if they were smart ;-)
    Like all automated testing, it still needs some manpower to understand and set up and maintain.
    It's FAR LESS manpower than testing the whole distro each time something changes manually, but a dude or two need to work on it and then keep an eye on it.

    Arch is a high-speed low-drag operation, they don't have the manpower to do that. The community is the QA, with the testing branches.

    Leave a comment:


  • jospoortvliet
    replied
    Originally posted by starshipeleven View Post
    Also VMWare (workstation/Player) break hard on 5.8, for the same reasons of Virtualbox I guess.

    And yes, LXD isn't a VM so you are fine.

    I'm a bit annoyed because I'll have to lock the kernel to 5.7.something and not upgrade anymore until VMWare updates their own application, as I need that to run VMs for work.
    Maybe because being the first is newsworthy, being second is not? If Arch had been the first, I bet it had been covered instead of openSUSE. But only one can be first... ;-)

    And as 5.8 was a bit of a big deal, I can imagine Michael decided to notify everyone when the first distro shipped it in their stable branch. And there, obviously, the rolling distro's have an advantage so it was between Arch or openSUSE.

    Yeah, openSUSE does have a speed advantage with their automated testing, of course. Well, openQA is open source, Arch could just take it... if they were smart ;-)

    Leave a comment:


  • starshipeleven
    replied
    Originally posted by Raka555 View Post

    You will have to give us a bit more info. Which technology are you using for your VMs ? QEMU/kvm, xen, virtualbox, vmware etc
    I have been using LXD containers and everything is still working for me, but ofc it is not VMs.
    Also VMWare (workstation/Player) break hard on 5.8, for the same reasons of Virtualbox I guess.

    And yes, LXD isn't a VM so you are fine.

    I'm a bit annoyed because I'll have to lock the kernel to 5.7.something and not upgrade anymore until VMWare updates their own application, as I need that to run VMs for work.

    Leave a comment:


  • starshipeleven
    replied
    Originally posted by tildearrow View Post
    Why is openSUSE more important than Arch to Phoronix?
    Probably the fact that it has a graphical installer and is the free version of SUSE which is a commercial distro.

    WHile Arch is a DIY system where you are supposed to decide and install what you want and configure it.

    Leave a comment:


  • starshipeleven
    replied
    Originally posted by Jedibeeftrix View Post

    Is it?
    for me it is

    Leave a comment:


  • Raka555
    replied
    Originally posted by ngraham View Post
    Yes, Virtualbox being broken with 5.8 is a known issue: https://bugzilla.opensuse.org/show_bug.cgi?id=1175201.

    Looks like they're working on it.
    Looks like some of the "condom" work started in 5.8 already. It is probably going to get worse in 5.9 ...

    Leave a comment:


  • skeevy420
    replied
    Originally posted by tildearrow View Post

    It looks like it. When Arch gets the next <software here>, they don't care. However, when openSUSE gets it, they make an article about it.
    I thought it was odd that we got an article about "Rolling Release Distribution Now Shipping Linux Stable". Kind of a "No shit, Sherlock" situation.

    But I think Michael omits Arch from the news and benchmarks because it's more of a meta distribution whereas Tumbleweed isn't. The second we start tweaking various /etc/something.conf to install Arch and make it into what we want it to be it starts to lose the the reproducibility factor that an install like Tumbleweed or Ubuntu provides.

    Leave a comment:


  • tuxd3v
    replied
    I don't see the problem of being running 5.8..
    I am running 5.8 since its release, last sunday, and its rocking in my OrangePi One Plus..
    full throttle!

    Leave a comment:


  • Charlie68
    replied
    Upgraded my PCs with Tumbleweed and no problem. I don't use virtual machines anyway ...

    Leave a comment:


  • ngraham
    replied
    Yes, Virtualbox being broken with 5.8 is a known issue: https://bugzilla.opensuse.org/show_bug.cgi?id=1175201.

    Looks like they're working on it.

    Leave a comment:

Working...
X