Announcement

Collapse
No announcement yet.

Memfd Transport Now Enabled By Default For PulseAudio

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Memfd Transport Now Enabled By Default For PulseAudio

    Phoronix: Memfd Transport Now Enabled By Default For PulseAudio

    With this summer's PulseAudio 9.0 release was support for Memfd-based transport. That support is now enabled by default in time for PulseAudio 10...

    http://www.phoronix.com/scan.php?pag...-Memfd-Default

  • #2
    Doesnt matter I still hate pulse audio. Before this crap came I never had any issues with sound, now still have some suddenly 100% volume on notification problems.

    Comment


    • #3
      You don't read docs or use Google I guess. That's a feature. And an option. You can change it.

      Comment


      • #4
        I find it amusing that people are still complaining about PulseAudio at every possibility.

        I wonder if this means you could start packing Pulse sources and such applications into containers now, or if it's just for better actual audio data transfer. Been thinking of container-izing my current audio system layout and it would be nice to be able to drop the - very dependency rich - UPnP source generator application into it's own container. Only run it when I need to stream audio to the living room setup after all, and that doesn't happen all that often.

        Comment


        • #5
          Originally posted by wolas View Post
          Doesnt matter I still hate pulse audio.
          Is anyone forcing you to use it?

          Before this crap came I never had any issues with sound, now still have some suddenly 100% volume on notification problems.
          Complaining about it on Phoronix is definitely the best way to get it fixed. Good job!

          Comment


          • #6
            Originally posted by wolas View Post
            Doesnt matter I still hate pulse audio. Before this crap came I never had any issues with sound, now still have some suddenly 100% volume on notification problems.
            You need to turn off flat volumes in the pulseaudio config file, it's a stupid default and shouldn't be on, particularly as it absolutely doesn't work like how audio does in Windows which means they failed with the goal of what flat volumes was for.

            Comment


            • #7
              Originally posted by wolas View Post
              Doesnt matter I still hate pulse audio. Before this crap came I never had any issues with sound, now still have some suddenly 100% volume on notification problems.
              /etc/pulse/daemon.conf > flat-volumes=no i suspect will fix that

              Comment


              • #8
                The most annoying thing with Pulseaudio and multiple sound cards is, if I close all streams, the sound sink selection disappears as the streams disappear from pavucontrol. Now, when I start playing audio again, I don't know which sound card it will use. It's sometimes super annoying that you don't know which sound card is being used and also there's no simple sink selector applet (xfce) for the task bar like in OS X. The xfce mixer isn't pa compatible.

                Comment


                • #9
                  Originally posted by 89c51 View Post

                  /etc/pulse/daemon.conf > flat-volumes=no i suspect will fix that
                  /etc/pulse/daemon.conf > flat-volumes=no is default on Archlinux, nice. I guess that is why those problems never happen to me.

                  nice tip btw thanks

                  Comment


                  • #10
                    Originally posted by wolas View Post
                    Doesnt matter I still hate pulse audio. Before this crap came I never had any issues with sound, now still have some suddenly 100% volume on notification problems.
                    You may forget that before Pulseaudio, you were lucky to sometimes have sound sometimes. These days, audio (with the exception of JACK/low latency unfortunately, which is still a nightmare), is entirely plug and play, regardless of whether the app was designed for KDE, Gnome or others

                    Comment

                    Working...
                    X