Announcement

Collapse
No announcement yet.

GNOME or GDM doesn't respect monitor arrangement order nor gamma from xorg.conf?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • GNOME or GDM doesn't respect monitor arrangement order nor gamma from xorg.conf?

    I have my monitors arranged in the order the ports are laid out, so in-short, my monitor arrangement works fine out-the-box in most scenarios.

    The only case it doesn't work however is when dealing with GNOME. I'm not entirely sure if it's a GNOME-thing or GDM though, but if anything, it doesn't seem to happen with Ubuntu (13.10 to 15.04, Unity + LightDM, and various variants except Ubuntu GNOME) and other distros not using GDM nor GNOME (a SDDM + Plasma 5 combination is fine).

    The first issue is monitor arrangement. I use 3 screens, but for some reason, the far-left screen will want to be on the far-right instead. So instead of [L] [M] [R] (left, middle, right) it's [M] [R] [L].

    The second issue is that GNOME or GDM doesn't respect gamma levels set on xorg.conf. XOrg's log confirms it sets the gamma level, but it's not actually set visually.

    The first issue was an issue since at least 3.14 (not sure if I tried GNOME prior to that to really know with multi-monitor). Fedora 21 uses 3.14, and I don't recall there being a problem with gamma being set, so the gamma thing seems to happen with 3.16+. I can confirm both issues on both Fedora 22 (RC3) and openSUSE Tumbleweed (as-of today).

    The monitor arrangement thing isn't a big deal since it can be fixed by just re-arranging the monitors (I'd be really interested in understanding why this happens though), but the gamma issue is a bit annoying (my monitors look best at 0.8; the default 1 looks noticeably bright). Does anyone have any information or know of any fixes?

    I figured using a script to xrandr --gamma the monitors would work, but gamma changes seem to revert randomly in this case (usually when I mess around in Nautilus, and sometimes when I press the backspace key strangely).

  • #2
    I filed a bugzilla report - https://bugzilla.redhat.com/show_bug.cgi?id=1227956

    I'm having a hard time trying to pin this down. So far, it doesn't seem related to any particular driver/hardware combination, X.Org nor Wayland, or even LightDM or GDM.

    It seems like GNOME itself is taking color profiles from somewhere or something, but even with gnome-color-manager, shared-color-targets, and argyllcms being removed, GNOME still doesn't use the Gamma option.

    I really want to use Fedora and GNOME, but this gamma thing is bugging me. I need 0.8 gamma across 3 different computers in order for the screen to look good (EDID doesn't do a good enough job on it's own).

    I'm thinking GNOME has a script or something somewhere that just resets the display settings, but I'm not certain.

    Comment

    Working...
    X