Announcement

Collapse
No announcement yet.

The Steam Linux Client Is Now Available To Everyone

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • phoronix
    started a topic The Steam Linux Client Is Now Available To Everyone

    The Steam Linux Client Is Now Available To Everyone

    Phoronix: The Steam Linux Client Is Now Available To Everyone

    Valve has announced that their Steam Linux client is now available to all Linux gamers. It's open beta period now and just in time for the holidays...

    http://www.phoronix.com/vr.php?view=MTI1ODg

  • Gps4l
    replied
    Originally posted by duby229 View Post
    my only problem with it now is alot of games that they have that do have native linux clients arent available yet. I'd re purchase several games if they would add the linux client to the list. The other thing is that it doesnt do any dependancy checking. I've had to install several needed dependancies, but didnt get any indication from steam at all what was needed. Of course desura has the exact same problem, so it isnt exclusively a steam issue.

    if the game spits an error about missing a library, then steam should let the user know.
    I do agree but if I understand things right, you already can.

    To start teamfortress 2 on suse I need to

    first type
    export SDL_AUDIODRIVER=alsa
    SDL_AUDIODRIVER=alsa steam

    the second command creates allot of data, which because I am not a coder, I do nut fully understand but,
    it tells you if it cant find something.

    Leave a comment:


  • duby229
    replied
    my only problem with it now is alot of games that they have that do have native linux clients arent available yet. I'd re purchase several games if they would add the linux client to the list. The other thing is that it doesnt do any dependancy checking. I've had to install several needed dependancies, but didnt get any indication from steam at all what was needed. Of course desura has the exact same problem, so it isnt exclusively a steam issue.

    if the game spits an error about missing a library, then steam should let the user know.
    Last edited by duby229; 12-23-2012, 06:13 PM.

    Leave a comment:


  • vsteel
    replied
    I am running Kubuntu 12.10 with the 3.5.0-21-generic kernel and the 310.14 driver and it works great. The only problems I have had in steam so far is for the game unwritten tales, it wouldn't start but if you turn off the overlay it works fine, and some steam console menus you can't click on with the mouse but if you highlight the first item you can use your arrow keys to scroll down to the item you want. Yes I have filed bug reports on both.

    Leave a comment:


  • nightmarex
    replied
    I have less CPU consumption using steam with wine lol. TF2 is a mess all over but cogs works great!

    Leave a comment:


  • RussianNeuroMancer
    replied
    You have to report it here: http://bugs.freedesktop.org/enter_bug.cgi?product=Mesa.

    Leave a comment:


  • duby229
    replied
    kernel 3.6.8
    mesa 9.0
    xorg-server 1.13.0
    xf86-video-ati 7.0.0

    Hey guys, got steam installed correctly. But I seem to be having corruption in the gui. It is all garbled and messed up.... So I ran from the command line and got this message

    Code:
    radeon: The kernel rejected CS, see dmesg for more information.
    OK, checked dmesg and this is what it had to say....

    Code:
    [43006.708381] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43006.708384] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.708386] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43006.721341] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43006.721344] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.721346] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43006.738022] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    4300638025] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.738027] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43006.755002] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43006.755006] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.755007] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43006.771554] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43006.771558] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.771559] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43006.838297] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43006.838301] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43006.838302] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43007.909628] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43007.909631] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 1148
    [43007.909633] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !
    [43010.946440] radeon 0000:01:00.0: evergreen_surface_value_conv_check:330 cb invalid array mode 6
    [43010.946444] radeon 0000:01:00.0: evergreen_packet3_check:2136 invalid cmd stream 552
    [43010.946446] [drm:radeon_cs_ib_chunk] *ERROR* Invalid command stream !

    Leave a comment:


  • droste
    replied
    Originally posted by droste View Post
    for me this does the trick with pulseaudio to get sound on openSUSE 12.2 (64bit):
    Code:
    SDL_AUDIODRIVER=pulse steam
    it's actually: SDL_AUDIODRIVER=pulseaudio steam

    Leave a comment:


  • droste
    replied
    Originally posted by Pitmairen View Post
    If you have no sound try to run:
    SDL_AUDIODRIVER=alsa steam
    for me this does the trick with pulseaudio to get sound on openSUSE 12.2 (64bit):
    Code:
    SDL_AUDIODRIVER=pulse steam

    Leave a comment:


  • Pitmairen
    replied
    If you have no sound try to run:
    SDL_AUDIODRIVER=alsa steam

    Leave a comment:

Working...
X