No announcement yet.

Opera 12.10 Browser Improves Extensions

  • Filter
  • Time
  • Show
Clear All
new posts

  • #21
    Originally posted by RealNC View Post
    The Mozilla Foundation is a non-profit organization.
    They also have Mozilla Corporation, but I must admit that I don't really know the details of their organizational structure. The basics seem to be similar enough though; they employ a bunch of developers etc., write a browser and have to get some kind of revenue to keep doing so. Google donates money to them to be default search engine, we have business contracs for the same thing.

    Don't get me wrong though, I think it would be awesome if we could open up the source for (parts of) the Opera browser. I'm just saying that I'm quite sure there are reasons why we can't do it.


    • #22
      Originally posted by johanar View Post
      I'm not a desktop developer, and I just got some urgent stuff I need to work with so I haven't had time to look at it. Have you tried switching to another Opera theme (Appearance... menu)? Otherwise you can try going to Preferences... > Advaced > Content > Style Options and disable "Enable styling of forms". If that fails, try going to "opera:config" and look under the Colors and Interface Colors sections. Also be sure to use the latest version because it might be a fixed bug.
      Thanks for the response.

      I'm aware of those and some other workarounds, but none of those change the fact that Opera with its defaults was usable before 10.50 and every version since is not.

      Other browsers incl. Firefox handle the gtk theme better - again, with the defaults.


      Versions before 10.50 (or 10.60, may be wrong) rendered using Qt. Afterwards it uses their own renderer, which tries to use system theme.

      I just tested 12.10 - does not run on my system due to requiring a newer glibc


      • #23
        Originally posted by johanar View Post
        Nobody has been able to reproduce this problem here. Have you got Opera Turbo enabled? I know there was a problem with the WebP decoder (Turbo reencodes some images as WebP) which caused similar behaviour.
        Hi Johanar,

        sorry for the delay, tried with proxy on/off, opera turbo on/off, made no difference, still happens (right now the phoronix logo top left if halfloaded rest corrupted). I do believe its some library somewhere that opera depends on. Will keep trying different things but tbh I been looking into chrome, just a good wand tool stopping me

        anyways thanks for letting me know, and this sort of shows the flaw in the opera bug system, I have no idea if the bug got found or did not got found or even looked at