Announcement

Collapse
No announcement yet.

Ubuntu Unity Proves Very Slow To KDE, GNOME, Xfce, LXDE

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • disgrace
    replied
    Originally posted by Kakarott View Post
    Wasn't L4D2 faster on Ubuntu than on Windows?
    Didn't that Ubuntu use Unity? [http://blogs.valvesoftware.com/linux.../#comment-4328]

    Just imagine a "KDE SC 4.9 - Suspended" ? so much more frames per second ?
    last time i got a talk with a valve guy they was not working with unity but gnome 2.3x on ubuntu 10.10 xD

    Leave a comment:


  • M1AU
    replied
    Originally posted by Thaodan View Post
    KDE works flawless with Dual-Monitor: my System http://www.sysprofile.de/id123113.
    Sorry, I should have verbalized my question properly.
    What I actually wanted to know is if KDE can suspend desktop effects for better performance, how does it look like if you have a game like HoN running in fullscreen on the primary monitor while the secondary monitor handles the desktop? Does it still suspends desktop effects and how does using the desktop on the secondary monitor feels like?

    Thank you for an answer nevertheless.

    Leave a comment:


  • marek
    replied
    Originally posted by bug77 View Post
    I wonder why the full screen tweaks actually works. Since there is no more desktop to render, hence nothing to decorate, reason says there should be no performance penalty in the first place.
    Normally, a window writes into an offscreen framebuffer of the size of the window, which is later copied onto the screen at the position of the window. If the compositor can properly detect a fullscreen window, it can skip the copying and render to the screen directly. It's only the copying that makes the difference.

    Leave a comment:


  • blackout23
    replied
    Wonder how a stand-alone Openbox or Awesome WM Setup would compete.

    Leave a comment:


  • gururise
    replied
    Originally posted by narciso View Post
    Compiz, Mutter and xfce fullscreen detection mechanisms sometimes won't identify the application running at fullscreen, so it thinks that the game is running in a window, and doesn't suspend the effects.

    Cube2 or supertuxkart are some examples of games that are properly detected as a fullscreen game and effects are disabled by the compositor, making the game run with fullspeed and proper vsync.

    Trine 2 for example is a problematic game that only kwin runs flawlessly with the suspend fullscreen effects enabled. Mutter, compiz, xfce won't work very good with it.

    I run Xubuntu 12.10, and I spot that problem right away when I see screen tearing. Disabling the compositor fix it.

    Very good point. I'm wondering if what we are seeing is a problem with full-screen detection in these DE's. It has been rumored, that Mutter disables compositing effects when full-screen apps are detected. Anyone know if this is really the case? If so, I would expect performance to be very similar to Kwin with suspended effects.

    Leave a comment:


  • Hamish Wilson
    replied
    Originally posted by simongaiteiro View Post
    I wouldn't call that "to tweak KDE". You only need to check an option in system configuration.
    Well, the same is true for Xfce. What would you call it?

    Leave a comment:


  • bug77
    replied
    I wonder why the full screen tweaks actually works. Since there is no more desktop to render, hence nothing to decorate, reason says there should be no performance penalty in the first place.

    Leave a comment:


  • narciso
    replied
    Compiz, Mutter and xfce fullscreen detection mechanisms sometimes won't identify the application running at fullscreen, so it thinks that the game is running in a window, and doesn't suspend the effects.

    Cube2 or supertuxkart are some examples of games that are properly detected as a fullscreen game and effects are disabled by the compositor, making the game run with fullspeed and proper vsync.

    Trine 2 for example is a problematic game that only kwin runs flawlessly with the suspend fullscreen effects enabled. Mutter, compiz, xfce won't work very good with it.

    I run Xubuntu 12.10, and I spot that problem right away when I see screen tearing. Disabling the compositor fix it.

    Leave a comment:


  • simongaiteiro
    replied
    I was answered by Martin and he states that the results coming from this kind of tests are no relevant as "the difference is too low, it's performed on just one hardware, just one distribution, there is no indication about how often the tests have been performed and so on. The benchmark is saying exactly nothing."

    https://plus.google.com/115606635748...ts/YSRDPgeV8vE

    Leave a comment:


  • simongaiteiro
    replied
    I was answered by Martin Gr??lin and he states that the results from this kind of tests are not relevant as "the difference is too low, it's performed on just one hardware, just one distribution, there is no indication about how often the tests have been performed and so on. The benchmark is saying exactly nothing".

    https://plus.google.com/u/0/11560663...ts/YSRDPgeV8vE

    Leave a comment:

Working...
X