No announcement yet.

where is the grub2 video mode set in ubuntu?

  • Filter
  • Time
  • Show
Clear All
new posts

  • where is the grub2 video mode set in ubuntu?

    some of my machines boot to a nice purple high-res grub menu, and some just get the plain 80x24 console, but i can't figure out where this is set. #GRUB_GFXMODE=640x480 is commented out by default in etc/default/grub, and i haven't changed anything in /etc/grub.d/ on all my systems. also, it doesn't seem to matter whether i use open drivers. the machine w/ the nvidia proprietary drivers has high-res grub menu, and a different one with open drivers used to have it, but reverted to ugly when i "update-grub" and "update-initramfs -u"

    all my machines have the stock /etc/default/grub, and /etc/grub.d/* so where is this set, and why are my machines all acting different?

  • #2
    you usually set the payload: after sudo -i

    grep -q ^GRUB_GFXPAYLOAD_LINUX /etc/default/grub||(echo GRUB_GFXPAYLOAD_LINUX=1024x768 >> /etc/default/grub;update-grub)

    you can of course change the res in the file and run update-grub manually. it does not always work, but thats the grub 2 way now and not using vga=xxx for old vesa modes.


    • #3

      so err... if i didn't set GRUB_GFXPAYLOAD_LINUX my self, how does my laptop boot into the high res grub menu?


      • #4
        the payload is for the res used after grub especially on systems without kms. it is also possible to set it to keep, then the other value you mentioned above is used later too.


        • #5

          to clarify, i'm only talking about the grub boot menu, not the stuff that happens after that (like plymouth/kms, grub_gfxpayload, & etc).

          setting or uncommenting GRUB_GFXMODE followed by 'sudo update-grub; sudo update-initramfs -u' doesn't work for me. i have tried it on a machine with the nvidia driver, and one with both radeon and fglrx, and one with intel. i also tried dropping to the grub console with 'c', and 'set gfxmode=640x480' and a few other resolutions listed as available by vbeinfo. there prompt returns without an error message, but it doesn't change modes. changing other stuff in this way, like background color and background image, works fine.

          the machine with the nvidia proprietary driver, and a debian squeeze machine (intel) i looked at, both have a high res boot menu even though GRUB_GFXMODE is commented out in /etc/default/grub. i looked in /etc/grub.d/* and i can't see it being set there either. if it's supposed to be set somewhere other than /etc/default/grub, then the default doesn't work on either my clean install of natty, or on the oneiric beta.


          If this line is commented (#) or the resolution is unavailable GRUB 2 uses the default setting determined by /etc/grub.d/00_header.
          In GRUB 1.99 (Natty) the 'optimum' resolution is selected by GRUB if no resolution is specified.
          Default theme (no image): Aubergine background, selected item black on light gray background)
          this doesn't happen, except on the nvidia machine, which btw, was upgraded from prior ubuntu, while the rest were clean installs. it seems like i used to get a nice menu, and be able to change grub video modes in prior versions, but now i can't. my curiosity is piqued... could somebody else actually try changing (from /etc/default/grub, or from live grub prompt) it and let me know if it worked on natty or oneiric?


          • #6
            The "high res" mode is only used when a background image is configured. Most likely this is not done on your updated install.


            • #7
              ok, i tried setting GRUB_GFXMODE with and with out a splash image, on two ubuntu machines (intel, fglrx). it doesn't work, and certainly doesn't do what is described in the documentation.

              the same stuff is working fine for me on debian. so is it bug?