Announcement

Collapse
No announcement yet.

Adobe Flash 10.2 Brings Linux Video Acceleration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    Originally posted by Beiruty View Post
    VLC and Mplayper plays nicely almost any 1080p with just Xv. Why is it so hard to have falsh player do the same?
    http://blogs.adobe.com/penguinswf/20..._problems.html

    Comment


    • #32
      From reading Adobe's blog post, it sounds like flash files have to be explicitly written to use the new rendering method... it's not automatic. So, until flash video players are rewritten to use the new method, you won't see any performance improvements.

      For content providers, Stage Video will work with all of the existing video viewed in Flash Player once they utilize the new API in their video player SWFs.
      [...]
      Developers can learn more about how to enable their sites to take advantage of Stage Video today, and sites like YouTube have already started adding early support for Stage Video.

      Comment


      • #33
        Ah, that would explain things. However, at least one user already reported low CPU usage with this...?

        Comment


        • #34
          I think we've all read this guy's insulting diatribes before. We're perfectly aware that Flash "solves a different problem" - or, more accurately, that it does not solve the problem people actually want it to solve. If Adobe invested half as much effort in actually getting Flash working as they do in apologizing for it, we would have hardware-accelerated Flash on every platform on Earth by now.

          I don't understand why they could not just write against VA-API. Both Intel and AMD support it (to varying extents), and for NVIDIA, VDPAU can be used as the backend to VA-API. If you do that you've covered 90% or more of the video devices out there.

          Message to all software developers everywhere: Just because a problem is difficult or inconvenient, that does not mean you do not have to solve it.

          Comment


          • #35
            Originally posted by yotambien View Post
            Ah, that would explain things. However, at least one user already reported low CPU usage with this...?
            They reported below 10% usage with an i7. That's not particularly impressive... Unless you're talking about someone else?

            Comment


            • #36
              Originally posted by ad_267 View Post
              They reported below 10% usage with an i7. That's not particularly impressive... Unless you're talking about someone else?
              You are right, I didn't pay attention to the processor. For my pentium M 10% would be gold, usually I get 50-80%. I guess everything is normal, then.

              Comment


              • #37
                I just tried it on my lowly Thinkpad T60 with a intel graphics chipset. Videos are much better now, before I dialed down to 360p, now it looks like I can sustain 720p !

                Comment


                • #38
                  I actually wish they had chosen OpenVG for acceleration like they do in embedded. Adobe has a lot more experience with it. OpenVG support in Mesa is maturing pretty nicely too.

                  Comment


                  • #39
                    Incredible ! I had never been able to watch a 720p video such as this one (less than 1 fps with the previous Flash player): http://www.youtube.com/watch?v=4CZI2...ure=popt01fr15
                    Now my Core2Duo reports 50% utilization with a modest Intel G33 IGP, and it plays perfectly smoothly.
                    I cannot test 1080p with this small monitor.

                    Comment


                    • #40
                      Tried the latest Flash Player "Square" preview for 64 bit thanks to "My Science is Better" /the script here is modified for preview 3/
                      Code:
                      #!/bin/bash
                      # Script  created by
                      # Romeo-Adrian Cioaba [email protected]
                      echo "Stopping any Firefox that might be running"
                      sudo killall -9 firefox
                      echo "Removing any other flash plugin previously installed:"
                      sudo apt-get remove -y --purge flashplugin-nonfree gnash gnash-common mozilla-plugin-gnash swfdec-mozilla libflashsupport nspluginwrapper
                      sudo rm -f /usr/lib/mozilla/plugins/*flash*
                      sudo rm -f ~/.mozilla/plugins/*flash*
                      sudo rm -f /usr/lib/firefox/plugins/*flash*
                      sudo rm -f /usr/lib/firefox-addons/plugins/*flash*
                      sudo rm -rfd /usr/lib/nspluginwrapper
                      echo "Installing Flash Player Square"
                      cd ~
                      # 64 bit
                      wget http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_64bit_linux_111710.tar.gz
                      tar zxvf flashplayer10_2_p3_64bit_linux_111710.tar.gz
                      # 32 bit
                      # wget http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_2_p3_32bit_linux_111710.tar.gz
                      # tar zxvf flashplayer10_2_p3_32bit_linux_111710.tar.gz
                      sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
                      echo "Linking the libraries so Firefox and apps depending on XULRunner (vuze, liferea, rsswol) can find it."
                      sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so /usr/lib/firefox-addons/plugins/
                      sudo ln -sf /usr/lib/mozilla/plugins/libflashplayer.so  /usr/lib/xulrunner-addons/plugins/
                      # now doing some cleaning up:
                      sudo rm -rf libflashplayer.so
                      sudo rm -rf flashplayer10_2_p3_64bit_linux_111710.tar.gz
                      # 32bit
                      #sudo rm -rf flashplayer10_2_p3_32bit_linux_111710.tar.gz
                      CPU usage is a bit down from what it was with preview 2 on this site - http://www.10mg.nl/index.html
                      Fullscreen videos are much more responsive than before and playing with volume media buttons on the keyboard doesn't go off fullscreen. Responsiveness in 720p and 1080p HD videos in youtube is the same with a lot of lag.
                      I'm using AMD HD4870 with Catalylst 10.11 and dual-core Phenom.

                      Comment

                      Working...
                      X